Wifi stability - ping times

Hi all,

I’m looking at wifi stability and what could be improved. What should be expected ping time to device connected over Wifi? Similar behavior for clients connected over 5GHz or 2.4GHz

TO on 3.5.1 version - I didn’t install any other wifi firmwares / drivers.

When I ping TO from the client the response is less than 1 ms. However when I ping the devices from TO than the results are:

Ping to device connected over 5GHz

root@omnia:~# ping 192.168.12.83
PING 192.168.12.83 (192.168.12.83): 56 data bytes
64 bytes from 192.168.12.83: seq=0 ttl=128 time=118.439 ms
64 bytes from 192.168.12.83: seq=1 ttl=128 time=142.118 ms
64 bytes from 192.168.12.83: seq=2 ttl=128 time=166.109 ms
64 bytes from 192.168.12.83: seq=3 ttl=128 time=189.938 ms
64 bytes from 192.168.12.83: seq=4 ttl=128 time=214.236 ms
64 bytes from 192.168.12.83: seq=5 ttl=128 time=1.114 ms
64 bytes from 192.168.12.83: seq=6 ttl=128 time=57.270 ms
64 bytes from 192.168.12.83: seq=7 ttl=128 time=81.115 ms
64 bytes from 192.168.12.83: seq=8 ttl=128 time=104.932 ms
64 bytes from 192.168.12.83: seq=9 ttl=128 time=128.675 ms

Ping to device connected over 2,4GHz (even worse times)

root@omnia:~# ping 192.168.12.78
PING 192.168.12.78 (192.168.12.78): 56 data bytes
64 bytes from 192.168.12.78: seq=0 ttl=64 time=350.457 ms
64 bytes from 192.168.12.78: seq=1 ttl=64 time=582.735 ms
64 bytes from 192.168.12.78: seq=2 ttl=64 time=201.238 ms
64 bytes from 192.168.12.78: seq=3 ttl=64 time=414.885 ms
64 bytes from 192.168.12.78: seq=4 ttl=64 time=659.324 ms
64 bytes from 192.168.12.78: seq=5 ttl=64 time=39.982 ms
64 bytes from 192.168.12.78: seq=6 ttl=64 time=492.002 ms
64 bytes from 192.168.12.78: seq=7 ttl=64 time=29.141 ms
64 bytes from 192.168.12.78: seq=8 ttl=64 time=340.893 ms
64 bytes from 192.168.12.78: seq=9 ttl=64 time=566.815 ms
64 bytes from 192.168.12.78: seq=10 ttl=64 time=183.851 ms
64 bytes from 192.168.12.78: seq=11 ttl=64 time=407.221 ms
64 bytes from 192.168.12.78: seq=12 ttl=64 time=630.746 ms
64 bytes from 192.168.12.78: seq=13 ttl=64 time=1.041 ms
64 bytes from 192.168.12.78: seq=14 ttl=64 time=479.170 ms
64 bytes from 192.168.12.78: seq=15 ttl=64 time=66.717 ms
64 bytes from 192.168.12.78: seq=16 ttl=64 time=315.395 ms
64 bytes from 192.168.12.78: seq=17 ttl=64 time=544.330 ms
64 bytes from 192.168.12.78: seq=18 ttl=64 time=158.803 ms

I don’t like two things:

  • the high response times
  • the variation / instability of the response times

There are not really any other wireless networks in the neighborhood but when I try to scan for other network I don’t get any result.

root@omnia:~# iwinfo wifipribyl scan
Scanning not possible
root@omnia:~# iwinfo wifi5 scan
<doesn't even complete>

when trying through iw tool than

root@omnia:~# iw dev wifipribyl scan
root@omnia:~# iw dev wifi5 scan
command failed: Resource busy (-16)

no result for 2.4GHz and Resource busy for 5GHz

Result of iwinfo:

root@omnia:~# iwinfo
wifi5     ESSID: "XXXXXXXX"
          Access Point: 04:F0:21:24:24:BE
          Mode: Master  Channel: 52 (5.260 GHz)
          Tx-Power: 20 dBm  Link Quality: 41/70
          Signal: -69 dBm  Noise: -102 dBm
          Bit Rate: 6.0 MBit/s
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11bgnac
          Hardware: 168C:003C 0000:0000 [Qualcomm Atheros QCA9880]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy0

wifipribyl ESSID:  "XXXXXXXX"
          Access Point: 04:F0:21:23:3A:92
          Mode: Master  Channel: 11 (2.462 GHz)
          Tx-Power: 16 dBm  Link Quality: 20/70
          Signal: -90 dBm  Noise: -95 dBm
          Bit Rate: 6.5 MBit/s
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11bgn
          Hardware: 168C:002E 168C:30A4 [Generic MAC80211]
          TX power offset: unknown
          Frequency offset: unknown
          Supports VAPs: yes  PHY name: phy1

wifipribylguest ESSID:  "XXXXXXXX"
          Access Point: 06:F0:21:23:3A:92
          Mode: Master  Channel: 11 (2.462 GHz)
          Tx-Power: 16 dBm  Link Quality: 26/70
          Signal: -84 dBm  Noise: -95 dBm
          Bit Rate: 65.0 MBit/s
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11bgn
          Hardware: 168C:002E 168C:30A4 [Generic MAC80211]
          TX power offset: unknown
          Frequency offset: unknown
          Supports VAPs: yes  PHY name: phy1

And the wifi is configured as:

root@omnia:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/soc/soc:pcie-controller/pci0000:00/0000:00:02.0/0000:02:00.0'
        option hwmode '11a'
        option country 'CZ'
        option channel 'auto'
        option htmode 'VHT80'
        option txpower '20'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/soc/soc:pcie-controller/pci0000:00/0000:00:03.0/0000:03:00.0'
        option channel '11'
        option country 'CZ'
        option htmode 'HT40'
        option txpower '19'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option ssid 'XXXXXXX'
        option network 'lan'
        option ifname 'wifi5'
        option macfilter 'allow'
        option key 'XXXXXXX'
        option encryption 'psk2+ccmp'

config wifi-iface
        option device 'radio1'
        option mode 'ap'
        option network 'lan'
        option macfilter 'allow'
        option key 'XXXXXXX'
        option encryption 'psk2+ccmp'
        option ssid 'XXXXXXX'
        option ifname 'wifipribyl'

config wifi-iface
        option device 'radio1'
        option mode 'ap'
        option ssid 'XXXXXXX'
        option network 'wifiguest'
        option ifname 'wifipribylguest'
        option key 'XXXXXXX'
        option isolate '1'
        option encryption 'psk2+ccmp'

As there are no neighbors I’m trying to use channel width VHT80 and HT40 - the result is the same as with 40 and 20.

Can you think about why the ping are so high and why the scanning doesn’t work? I waited for the 3.5 version to see if the wifi problems are fixed but the situation is still worse than with previous router (Asus RT-N66) installed on the same place.

Thanks a lot for any suggestion.

my turris pinging client on AC wifi:

— x.x.x.x ping statistics —
10 packets transmitted, 10 packets received, 0% packet loss
round-trip min/avg/max = 0.710/1.307/3.283 ms

itsnt there any PB with routing of private ranges? (i mean conflict with ISP range etc.)
Do you have same timing for IPv6 and IPv4?

no conflict - I have public IP assigned from ISP. Also as my ISP provides IPv4 only I disabled IPv6 even internally so that all traffic goes over IPv4 only.

What kind of device do you ping?
I can give you few examples:
On 2,4G I have chromecast that has normal ping around 1-2ms from TO
On 5G I have connected smartphone who has ping 2-500ms, while ping from smartphone is 1-2ms. To me its seems to be like some power saving function of wifi on smartphone.
Also I see you are using HT40 on 2,4G wifi, that can have lower performance when there are other 2,4G network around.

The first result (5GHz) was a notebook (Dell Inspiron) and second was tablet (Samsung Galaxy Tab 8.4). As I wrote there are no other networks in the neighborhood and the behavior is the same with HT20.

Any idea why the network scan doesn’t work? I’m considering reinstalling TO from scratch but ideally would like to avoid it if possible.

I just tried pinging on my company network (not running Turris Omnia but a Netgear R8000)

If I take another pc then I get ping response times between 1 and 15ms.
If I ping my smartphone on the same wifi network then I get 194-384 ms. When the screen is off.
When the screen is on then I get 30-122ms as a result.

So it might be the devices themselves? Although if the notebook is plugged in to AC power it shouldn’t happen.

Thanks for the test. So it really looks like some power saving applied by the devices and probably the Dell Inspiron applies the same technique even when connected to AC.

Any idea about why the scanning doesn’t work?