Wifi not working - stuck at "Obtaining IP Adress"

I did firmware reset on my TO.
During setup wizard I turned automatic updates off.
Once setup, I could connect just fine to the TO.

I enabled automatic updates.
TO updated to 3.8.1
After mandatory reboot I can’t connect to wifi anymore… neither with two smart phones nor another notebook.

Isn’t that the same as Can’t connect to wifi ?

If it’s just about the categorization, I can reassign it.

It’s about the whole f**** thing not working…

trivial things don’t work… I really wonder why I actually spent money when it’s totally useless.

Again: I reset firmware to original… after going through the setup wizard (disabling automatic updates), wifi works.

Device Turris Omnia - RTROM01
Serial number —
Turris OS version 3.2.1
Kernel version 4.4.13-05df79f63527051ea0071350f86faf76-7

Everything else left as default.

Now I enable automatic updates. It pulls them. After a while, ethernet and wifi not working. I reboot. Ethernet works again, wifi doesn’t.

What good is a wifi router when wifi doesn’t even work?

I understand your frustration (have the same problem…) but please try to behave without such extreme emotions.
This forum is not official support.

Contact can be found here:
https://project.turris.cz/en/contacts

I already send them a request and you should do the same.

1 Like

OK, fixed it now.
In my frustration I tried many ways (factory restart / restore of configuration / nightly builds) nothing worked.
In final I did the medkit installation described here:
https://www.turris.cz/doc/en/howto/omnia_factory_reset

Basically take a usb (formated ideally to FAT32),
download the medkit: https://repo.turris.cz/omnia/medkit/omnia-medkit-latest.tar.gz
and boot the router to re-flash router (WARNING this can damage the router)

After this I am on latest version and wifi / ethernet works also after reboot.

So there is definitelly a problem with the stock factory -> 3.8.1 upgrade and it should get fixed… (I reported it to turris team).

Doesn’t help - WiFi is still broken.

There are multiple topics for this issue now (I started this one). There is a temporary config solution at https://forum.test.turris.cz/t/update-broke-my-router/4952/5.

The sad thing is that no one from the Turris team has replied to any of the topics for such a big issue like this one. Devices must work when they are factory reset and then their software is updated, otherwise the whole point of factory reset is lost.

I am sure that they are doing a pretty good job though and are working hard and I hope that we will have a better and more stable update process soon. I will probably flash a newer version to the router, too, when we have a more stable release without that many problems.

1 Like

That’s because the official way to get support is to write to tech.support@turris.cz. That’s how I was able to get NFSv4 support added to the TurrisOS kernel.

4 Likes

Exactly, the routers have to be flashed to much newer version so that the factory reset actually resets it to something working.

Something like this should be mentioned in another version of the Turris newsletter they sent earlier this month.

1 Like

How do you flash to a newer firmware?

When I tried that omnia-medkit-latest.tar.gz and put it onto a usb and reboot/reflashed it (4 Leds), it didn’t actually update the firmware to 3.8.1… because when I then reset to factory (3 leds) it was back at 3.2.1

1 Like

Question still remains:

I can I flash completely new (and current) firmware and remove every custom config etc. that’s currently in the TO?

Be sure that you have correct filesystem type (FAT,Btrfs,Ext,…) and that file starts with omnia-medkit and is only such file on usb. Note that it doesn’t list vFAT nor exFAT and I think that we don’t supoort them.

Yes, I tried that - didn’t work.

So, next attempt. This is how I prepared the USB Stick. It’s an old, 1GB usb 2.0 stick:

root@subi:/# mkfs.ext4 /dev/sdd
mke2fs 1.43.4 (31-Jan-2017)
/dev/sdd contains a vfat file system
Proceed anyway? (y,N) y
Creating filesystem with 252160 4k blocks and 63104 inodes
Filesystem UUID: 06c74fc7-4c5b-4534-a0a3-fc7c325d46ca
Superblock backups stored on blocks:
        32768, 98304, 163840, 229376

Allocating group tables: done
Writing inode tables: done
Creating journal (4096 blocks): done
Writing superblocks and filesystem accounting information: done

root@subi:/# mkdir /tmp/sdd
root@subi:/# mount /dev/sdd /tmp/sdd
root@subi:/# curl -o /tmp/sdd/omnia-medkit-latest.tar.gz https://repo.turris.cz/omnia/medkit/omnia-medkit-latest.tar.gz
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 42.5M  100 42.5M    0     0  42.5M      0  0:00:01  0:00:01 --:--:-- 38.7M
root@subi:/# curl -o /tmp/sdd/omnia-medkit-latest.tar.gz.sha256 https://repo.turris.cz/omnia/medkit/omnia-medkit-latest.tar.gz.sha256
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100    99  100    99    0     0     99      0  0:00:01 --:--:--  0:00:01   942
root@subi:/# sync
root@subi:/# sha256sum /tmp/sdd/omnia-medkit-latest.tar.gz
56dd92ec8414df25d1cdb882c7736921bf5a935d689b932882c0a654810c1366  /tmp/sdd/omnia-medkit-latest.tar.gz
root@subi:/# cat /tmp/sdd/omnia-medkit-latest.tar.gz.sha256
56dd92ec8414df25d1cdb882c7736921bf5a935d689b932882c0a654810c1366  omnia-medkit-201709202201.tar.gz
root@subi:/# umount /tmp/sdd

So, I did first create new ext4 system on the usb stick, then mounted it.
Then I used curl to download the latest mediakit and the sha256 checksum.
After downloading I issued a sync to make sure everythign was written.

I then verfified the sha256 checksum with the on in the file contained - they match.

Then I umounted the sick, put it into the TO.

I pressed the reset button on the back until 4 LEDs appeared.

The TO went out, came back to life, at some points all the LEDs were orange/red for a few seconds. During this period of time, the USB stick was also highlighted/glowing.

A little while further, it rebooted itself and is now ready for operations.

However, when I opened 192.168.1.1 I wasn’t greety by the install wizard but by login form. Once I logged in I check, it’s still running:

Device	Turris Omnia - RTROM01
Serial number	xxxx
Turris OS version	3.2.1
Kernel version	4.4.13-05df79f63527051ea0071350f86faf76-7

So question still remains:

How can I flash current firmware?

Just to humour myself, I did again but this time I just used FAT

root@subi:/tmp# mkfs.fat /dev/sdd
mkfs.fat 4.1 (2017-01-24)
root@subi:/tmp# mount /dev/sdd /tmp/sdd
root@subi:/tmp# curl -o /tmp/sdd/omnia-medkit-latest.tar.gz https://repo.turris.cz/omnia/medkit/omnia-medkit-latest.tar.gz
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 42.5M  100 42.5M    0     0  42.5M      0  0:00:01  0:00:01 --:--:-- 41.9M
root@subi:/tmp# sync
root@subi:/tmp# sha256sum /tmp/sdd/omnia-medkit-latest.tar.gz
56dd92ec8414df25d1cdb882c7736921bf5a935d689b932882c0a654810c1366  /tmp/sdd/omnia-medkit-latest.tar.gz
root@subi:/tmp# umount /tmp/sdd

Still the same result!

How can I flash current firmware onto the TO?

Are you sure you have 4 LEDs? The led numbered 2 is flash drive restore.

In my try I first did a factory reset then after I had the wizard I went for the medkit.

Did you contact turris support team?

I don’t really understand what you’re saying.

There’s like 12 LEDs on the TO and you’re asking if I have 4 LEDS?

Sorry if I was not clear, just checking if you really went to the USB restore mode. The LEDs are counted from left and the first is the power led. So the restore mode would be the led marked with the number 2.

WTF are you talking about? 2 LEDs is rollback…

https://www.turris.cz/doc/en/howto/omnia_factory_reset

1 LED: Standard (re)boot
2 LEDs: Rollback to latest snapshot
3 LEDs: Rollback to factory reset
4 LEDs: Re-flash router from flash drive
5 LEDs or more: Boot to rescue shell

I am trying to flash current firmware…