Wi-Fi in routed mode

I use the onmia in routed rather than bridged mode.

As of the lastest update, the boot scripts stopped adding the addresses to the wifi0 and wifi1 interfaces. I have to run ip a a … on each.

Even after doing that, dhcp failed.

I had to add dhcp-range commands to /etc/dnsmasq.conf for the two wifi interfaces; the configs in /etc/config are ignored.

Very annoying.

I cannot reproduce your issue. Please post your config. Mine is:

config interface 'lanx'
        option force_link '1'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'

config dhcp 'lanx'
        option interface 'lanx'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'
        option ignore '0'
        list dhcp_option '6,192.168.2.1'

I presume the “interface” blob is from network and the “dhcp” from dhcp, yes?

Mine are like:

config interface 'wifi50’
option proto 'static’
option ipaddr '172.42.50.1’
option netmask ‘255.255.255.224’

and:

config dhcp 'wifi50’
option leasetime '12h’
option interface 'wifi50’
option ra 'server’
option dhcpv6 'server’
option ra_management '1’
option start '5’
option limit ‘25’

Yes. Try to add option force_link '1' to the interface section.