WEB Interface + Local DNS

Hi All,

Yesterday I received my Omnia and I’m really disappointed by Luci Web interface, it looks like some unfinished product, for example DNS part is not working because kresd or unbound is used instead dnsmasq and webinterface was not adjusted to this. Also interface itself looks strange, not what I was used from dd-wrt or tomato.

I was searching for configuration of DNS to resolve local domain, but any of manuals I found were not working. So could somebody post here really working article how to configure Omnia to get local DNS resolution working? Currently I was trying with configuring of unbound for overal resolution nad dnsmasq only for local domain.

Thanks,

David

2 Likes

Local domain records were heavily discussed here. You either set dnsmasq as your main dns server or run dnsmasq on some higher port and set your dns server to forward queries for local domain to dnsmasq (recommended).

For the Luci itself, I don’t know what to say. If you don’t like Luci, then don’t buy router with it. It looks pretty much the same on all devices.

Hi Exander77,

Thank you for your reply. I was able to get it work but there were some differences with articles on net. By any chance do you have idea where host entries which you could enter in Luci - Network - Hostnames are stored? And how to configure DNS to resolve them?

In Turris Omnia unbound is using config file located at /etc/unbound/unbound.conf. But when you edit this config directly it is every time overwriten by configuration taken from /etc/config/resolver. Therefore there was needed to insret proper lines into /etc/config/resolver to get include function working, the rest was pretty simillar to manuals found on internet. So here is conclusion how I have done it:

  1. in /etc/config/dhcp edit this (change loc to name of your domain):
    option port '53535’
    option local '/loc/'
    option domain ‘loc’

  2. create file /etc/unbound/lan.conf and put this inside:
    server:
    domain-insecure: "loc"
    private-domain: "loc"
    do-not-query-localhost: no
    stub-zone:
    name: "loc"
    stub-addr: “127.0.0.1@53535”

  3. change the following line in /etc/config/resolver to configure unbound as default resolver:
    option prefered_resolver ‘unbound’

  4. put those line at the end of file /etc/config/resolver:
    config resolver 'unbound_includes’
    list include_path ‘/etc/unbound/lan.conf’

  5. restart unbound by running:
    /etc/init.d/resovler restart

  6. restart dnsmasq:
    /etc/init.d/dnsmasq restart

Now local resolution for .loc namespace should work. it will resolve all hostnames from dhcp leases.

3 Likes

Have it exactly the same and it works perfectly.

Thank you very much!