VLAN problem with DHCP

I made VLAN from port 0 omnia, according included screenshots, but DHCP not working. When i set static IP on PC connected to port 0 i can go to eth0.1, eth0.2, but not to wan (internet).
Can you help me with setup pls?

What’s your firewall configuration?

Can you post these files:
/etc/config/network
/etc/config/firewall
/etc/config/dhcp

Or use google transtlator for my manual:
http://www.s474n.com/project-turris-nastaveni-vlan/

1 Like

Thank you, I understand Czech / but for me Luci is better … (jsem spis klikac v LUCi)…

root@turris:~# cat /etc/config/network

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config globals ‘globals’
option ula_prefix ‘fd93:e536:fa43::/48’

config interface ‘lan’
option force_link ‘1’
option type ‘bridge’
option proto ‘static’
option ipaddr ‘192.168.1.1’
option netmask ‘255.255.255.0’
option ip6assign ‘60’
option _orig_ifname ‘eth0 eth2 wlan0 wlan1’
option _orig_bridge ‘true’
option ifname ‘eth0.1 eth0.2 eth2’

config interface ‘wan’
option ifname ‘eth1’
option proto ‘pppoe’
option username ‘XXXX’
option password ‘XXXX’
option ipv6 ‘1’

config interface ‘wan6’
option ifname ‘@wan
option proto ‘dhcpv6’

config switch
option name ‘switch0’
option reset ‘1’
option enable_vlan ‘1’

config switch_vlan
option device ‘switch0’
option vlan ‘1’
option vid ‘1’
option ports ‘1 2 3 5t’

config switch_vlan
option device ‘switch0’
option vlan ‘2’
option vid ‘2’
option ports ‘4 6t’

config switch_vlan
option device ‘switch0’
option vlan ‘3’
option vid ‘3’
option ports ‘0 5t’

config interface ‘VLAN0’
option proto ‘static’
option ifname ‘eth0.3’
option ipaddr ‘192.168.10.1’
option netmask ‘255.255.255.0’
option ip6assign ‘30’

root@turris:~# cat /etc/config/network

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config globals ‘globals’
option ula_prefix ‘fd93:e536:fa43::/48’

config interface ‘lan’
option force_link ‘1’
option type ‘bridge’
option proto ‘static’
option ipaddr ‘192.168.1.1’
option netmask ‘255.255.255.0’
option ip6assign ‘60’
option _orig_ifname ‘eth0 eth2 wlan0 wlan1’
option _orig_bridge ‘true’
option ifname ‘eth0.1 eth0.2 eth2’

config interface ‘wan’
option ifname ‘eth1’
option proto ‘pppoe’
option username ‘o2’
option password ‘o2’
option ipv6 ‘1’

config interface ‘wan6’
option ifname ‘@wan
option proto ‘dhcpv6’

config switch
option name ‘switch0’
option reset ‘1’
option enable_vlan ‘1’

config switch_vlan
option device ‘switch0’
option vlan ‘1’
option vid ‘1’
option ports ‘1 2 3 5t’

config switch_vlan
option device ‘switch0’
option vlan ‘2’
option vid ‘2’
option ports ‘4 6t’

config switch_vlan
option device ‘switch0’
option vlan ‘3’
option vid ‘3’
option ports ‘0 5t’

config interface ‘VLAN0’
option proto ‘static’
option ifname ‘eth0.3’
option ipaddr ‘192.168.10.1’
option netmask ‘255.255.255.0’
option ip6assign ‘30’

root@turris:~# cat /etc/config/firewall

config defaults
option syn_flood ‘1’
option input ‘ACCEPT’
option output ‘ACCEPT’
option forward ‘REJECT’

config zone
option name ‘lan’
option input ‘ACCEPT’
option output ‘ACCEPT’
option forward ‘ACCEPT’
option network ‘lan’

config zone
option name ‘wan’
option input ‘REJECT’
option output ‘ACCEPT’
option forward ‘REJECT’
option masq ‘1’
option mtu_fix ‘1’
option network ‘wan6 wan’

config forwarding
option src ‘lan’
option dest ‘wan’

config rule
option name ‘Allow-DHCP-Renew’
option src ‘wan’
option proto ‘udp’
option dest_port ‘68’
option target ‘ACCEPT’
option family ‘ipv4’

config rule
option name ‘Allow-Ping’
option src ‘wan’
option proto ‘icmp’
option icmp_type ‘echo-request’
option family ‘ipv4’
option target ‘ACCEPT’

config rule
option name ‘Allow-IGMP’
option src ‘wan’
option proto ‘igmp’
option family ‘ipv4’
option target ‘ACCEPT’

config rule
option name ‘Allow-DHCPv6’
option src ‘wan’
option proto ‘udp’
option src_ip ‘fe80::/10’
option src_port ‘547’
option dest_ip ‘fe80::/10’
option dest_port ‘546’
option family ‘ipv6’
option target ‘ACCEPT’

config rule
option name ‘Allow-MLD’
option src ‘wan’
option proto ‘icmp’
option src_ip ‘fe80::/10’
list icmp_type ‘130/0’
list icmp_type ‘131/0’
list icmp_type ‘132/0’
list icmp_type ‘143/0’
option family ‘ipv6’
option target ‘ACCEPT’

config rule
option name ‘Allow-ICMPv6-Input’
option src ‘wan’
option proto ‘icmp’
list icmp_type ‘echo-request’
list icmp_type ‘echo-reply’
list icmp_type ‘destination-unreachable’
list icmp_type ‘packet-too-big’
list icmp_type ‘time-exceeded’
list icmp_type ‘bad-header’
list icmp_type ‘unknown-header-type’
list icmp_type ‘router-solicitation’
list icmp_type ‘neighbour-solicitation’
list icmp_type ‘router-advertisement’
list icmp_type ‘neighbour-advertisement’
option limit ‘1000/sec’
option family ‘ipv6’
option target ‘ACCEPT’

config rule
option name ‘Allow-ICMPv6-Forward’
option src ‘wan’
option dest ‘*’
option proto ‘icmp’
list icmp_type ‘echo-request’
list icmp_type ‘echo-reply’
list icmp_type ‘destination-unreachable’
list icmp_type ‘packet-too-big’
list icmp_type ‘time-exceeded’
list icmp_type ‘bad-header’
list icmp_type ‘unknown-header-type’
option limit ‘1000/sec’
option family ‘ipv6’
option target ‘ACCEPT’

config include
option path ‘/etc/firewall.user’

config include
option path ‘/usr/share/firewall/turris’
option reload ‘1’

config include
option path ‘/etc/firewall.d/with_reload/firewall.include.sh’
option reload ‘1’

config include
option path ‘/etc/firewall.d/without_reload/firewall.include.sh’
option reload ‘0’

config rule
option src ‘wan’
option dest ‘lan’
option proto ‘esp’
option target ‘ACCEPT’

config rule
option src ‘wan’
option dest ‘lan’
option dest_port ‘500’
option proto ‘udp’
option target ‘ACCEPT’

config include ‘miniupnpd’
option type ‘script’
option path ‘/usr/share/miniupnpd/firewall.include’
option family ‘any’
option reload ‘1’

config redirect
option target ‘DNAT’
option src ‘wan’
option dest ‘lan’
option proto ‘tcp’
option src_dport ‘22’
option dest_port ‘58732’
option name ‘SSH honeypot’

config zone
option name ‘VLAN0’
option input ‘ACCEPT’
option output ‘ACCEPT’
option network ‘VLAN0’
option forward ‘REJECT’

config forwarding
option dest ‘wan’
option src ‘VLAN0’

root@turris:~# cat /etc/config/dhcp

config dnsmasq
option domainneeded ‘1’
option boguspriv ‘1’
option localise_queries ‘1’
option rebind_protection ‘1’
option rebind_localhost ‘1’
option local ‘/lan/’
option domain ‘lan’
option expandhosts ‘1’
option authoritative ‘1’
option readethers ‘1’
option leasefile ‘/tmp/dhcp.leases’
option resolvfile ‘/tmp/resolv.conf.auto’
option localservice ‘1’
option port ‘0’
option nonwildcard ‘0’
option logqueries ‘1’

config dhcp ‘lan’
option interface ‘lan’
option leasetime ‘12h’
option dhcpv6 ‘server’
option ra ‘server’
option start ‘2’
option limit ‘198’
list dhcp_option ‘6,192.168.1.1’
option ra_management ‘1’

config dhcp ‘wan’
option interface ‘wan’
option ignore ‘1’

config odhcpd ‘odhcpd’
option maindhcp ‘0’
option leasefile ‘/tmp/hosts/odhcpd’
option leasetrigger ‘/usr/sbin/odhcpd-update’

config host
option name ‘LXC_Xenial’
option ip ‘192.168.1.222’
option mac ‘de:3d:46:1c:01:fa’

config dhcp ‘VLAN0’
option start ‘100’
option leasetime ‘12h’
option limit ‘150’
option interface ‘VLAN0’
list dhcp_option ‘6,192.168.10.1’

root@turris:~#

Try next:

config interface 'lan'
    option ifname 'eth0.1 eth2'
    [...]

config interface 'VLAN0'
    option ifname 'eth0.3'
    [...]

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '1 2 3 5t'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '4 6'

config switch_vlan
    option device 'switch0'
    option vlan '3'
    option ports '0 5t'

Or if you prefer:

config interface 'lan'
    option ifname 'eth0.1 eth2.2'
    [...]

config interface 'VLAN0'
    option ifname 'eth0.3'
    [...]

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '1 2 3 5t'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '4 6t'

config switch_vlan
    option device 'switch0'
    option vlan '3'
    option ports '0 5t'

Thank you, its working. ///