V4 Beta - Updater Error message


#1

In Updater I have:

Data Collection - Software for participation in data collection and dynamic distributed firewall.

Device detection - Software for detecting new devices on local network (EXPERIMENTAL).

SSH Honeypot - Trap for password-guessing robots on SSH.

LuCI extensions Several addional tabs and controls for the advanced LuCI interface.

Internet connection speed measurement - Actively measures speed of Internet connection using netmetr.cz service.

OpenVPN - An easy setup of OpenVPN server from Foris.

Pakon - Software for in depth monitoring of your traffic.

Tor - Service to increase anonymity on the Internet.

Turned on - I got the following messages in Notifications, obviously the first is an error message and the second, an update message.

This was on a newly updated to 4.0.1 Beta


## Error from 2019/05/08 14:38:18

Updater selhal: Failed operations:

foris-controller-netmetr-module/postinst: + '[' -z ]

+ /etc/init.d/foris-controller restart

+ netmetr

Traceback (most recent call last):

File "/usr/bin/netmetr", line 11, in <module>

load_entry_point('netmetr==1.4.2', 'console_scripts', 'netmetr')()

File "/usr/lib/python3.6/site-packages/netmetr/__main__.py", line 807, in main

netmetr.load_uuid()

File "/usr/lib/python3.6/site-packages/netmetr/__main__.py", line 109, in load_uuid

self.download_uuid()

File "/usr/lib/python3.6/site-packages/netmetr/__main__.py", line 130, in download_uuid

resp_json = self.send_request(req_json, 'settings')

File "/usr/lib/python3.6/site-packages/netmetr/__main__.py", line 93, in send_request

resp = request.urlopen(req, data.encode(), context=ctx)

File "/request.py", line 223, in urlopen

File "/request.py", line 532, in open

File "/request.py", line 642, in http_response

File "/request.py", line 570, in error

File "/request.py", line 504, in _call_chain

File "/request.py", line 650, in http_error_default

urllib.error.HTTPError: HTTP Error 400: Bad Request

e[91mClient type not found, falling to: HW-PROBEe[0m

e[91mUuid not found, requesting new one.e[0m

e[93mChecking uuid on the control server...e[0m [×](http://192.168.1.1/foris/config/main/notifications/#)

## Update from 2019/05/08 14:38:18

• Installed version 0.6.1-3.6-1.8 of package python3-msgpack
• Installed version 6.38-1.0 of package libipset
• Installed version 6.38-1.0 of package ipset
• Installed version 1.0.16-1.1 of package libsodium
• Installed version 0.2.4-3.0 of package uclibcxx
• Installed version 4.1.4-1.1 of package libzmq-curve
• Installed version 18.0.1-3.6-1.9 of package python3-zmq
• Installed version 1.0-3.8 of package sentinel-dynfw-client
• Installed version 1-0.0 of package suricata-conntrack-flows
• Installed version 4-0.4 of package ouidb
• Installed version 5-0.8 of package pakon-lists
• Installed version 3260000-2.1 of package sqlite3-cli
• Installed version 1.2-rc3-4.1 of package libnet-1.2.x
• Installed version 0.5.25-1.0 of package libhtp
• Installed version 4.14.113-1-98c217cad6ab22101bb289c5936d189e.0 of package kmod-nfnetlink-log
• Installed version 1.0.1-1.0 of package libnetfilter-log
• Installed version 4.14.113-1-98c217cad6ab22101bb289c5936d189e.0 of package kmod-nfnetlink-queue
• Installed version 4.14.113-1-98c217cad6ab22101bb289c5936d189e.0 of package kmod-ipt-nfqueue
• Installed version 1.6.2-1.0 of package iptables-mod-nfqueue
• Installed version 5.25-2.1 of package libmagic
• Installed version 2.10-1.1 of package jansson
• Installed version 0.1.6-1.1 of package libyaml
• Installed version 4.0.3-4.6 of package suricata-bin
• Installed version 1-8.8 of package suricata-pakon
• Installed version 1.2.1-1.6 of package pakon
• Installed version 2-0.0 of package pakon-dev-detect
• Installed version 0.53-2.9 of package ahcpd
• Installed version git-19.122.38425-eb7d4ce-1.0 of package luci-app-ahcp
• Installed version 1.3.2-2.1 of package libogg
• Installed version 1.3.6-1.9 of package libvorbis
• Installed version 1.3.2-1.1 of package libflac
• Installed version 0.15.1b-4.1 of package libid3tag
• Installed version 1.6.34-1.1 of package libpng
• Installed version 2.9-1.1 of package libfreetype
• Installed version 4.14.113-1-98c217cad6ab22101bb289c5936d189e.0 of package kmod-input-core
• Installed version 4.14.113-1-98c217cad6ab22101bb289c5936d189e.0 of package kmod-sound-core
• Installed version 1.1.6-1.9 of package alsa-lib
• Installed version 1.2.0-1.1 of package libspeex
• Installed version 4.0.2-0.8 of package libffmpeg
• Installed version 9a-1.1 of package libjpeg
• Installed version 0.6.21-1.1 of package libexif
• Installed version 1.2.1-3.14 of package minidlna
• Installed version git-19.122.38425-eb7d4ce-1.0 of package luci-app-minidlna
• Installed version r182-10.9 of package mjpg-streamer
• Installed version git-19.122.38425-eb7d4ce-1.0 of package luci-app-mjpg-streamer
• Installed version 5.8.1-1.0 of package collectd-mod-network
• Installed version 5.8.1-1.0 of package collectd-mod-load
• Installed version 5.8.1-1.0 of package collectd-mod-interface
• Installed version 5.8.1-1.0 of package collectd-mod-memory
• Installed version 5.8.1-1.0 of package collectd-mod-cpu
• Installed version 5.8.1-1.0 of package collectd-mod-iwinfo
• Installed version 1.0.50-2.1 of package librrd1
• Installed version 5.8.1-1.0 of package collectd-mod-rrdtool
• Installed version 1.0.50-2.5 of package rrdtool1
• Installed version git-19.122.38425-eb7d4ce-1.0 of package luci-app-statistics
• Installed version 1.8.3-2.9 of package tinyproxy
• Installed version git-19.122.38425-eb7d4ce-1.0 of package luci-app-tinyproxy
• Installed version git-19.122.38425-eb7d4ce-1.0 of package luci-app-transmission
• Installed version 20151220-1.0 of package vpnc-scripts
• Installed version 4.14.113-1-98c217cad6ab22101bb289c5936d189e.0 of package kmod-tun
• Installed version 7.08-8.9 of package openconnect
• Installed version git-19.122.38425-eb7d4ce-1.0 of package luci-proto-openconnect
• Installed version 2016-02-07-ad0b25ad-2.9 of package relayd
• Installed version git-19.122.38425-eb7d4ce-1.0 of package luci-proto-relay
• Installed version 1.12-1.1 of package libgpg-error
• Installed version 1.6.6-2.1 of package libgcrypt
• Installed version 0.5.3.r550-7.8 of package vpnc
• Installed version git-19.122.38425-eb7d4ce-1.0 of package luci-proto-vpnc
• Installed version git-19.122.38425-eb7d4ce-1.0 of package luci-i18n-ahcp-en
• Installed version git-19.122.38425-eb7d4ce-1.0 of package luci-i18n-firewall-en
• Installed version git-19.122.38425-eb7d4ce-1.0 of package luci-i18n-minidlna-en
• Installed version git-19.122.38425-eb7d4ce-1.0 of package luci-i18n-statistics-en
• Installed version git-19.122.38425-eb7d4ce-1.0 of package luci-i18n-tinyproxy-en
• Installed version git-19.122.38425-eb7d4ce-1.0 of package luci-i18n-transmission-en
• Installed version git-19.122.38425-eb7d4ce-1.0 of package luci-i18n-upnp-en
• Installed version 3.4-3.6-1.9 of package python3-pyserial
• Installed version 1.0-1.0 of package rmbt-client
• Installed version 1.4.2-3.6-2.6 of package netmetr
• Installed version 0.4.2-3.6-1.8 of package foris-controller-netmetr-module
• Installed version 4.6-3.6-1.6 of package foris-netmetr-plugin
• Installed version 2.4.5-4.2.8 of package openvpn-openssl
• Installed version 2.1-0.8 of package dhparam
• Installed version 0.6-3.6-1.8 of package foris-controller-openvpn-module
• Installed version 16.6-3.6-1.0 of package foris-openvpn-plugin
• Installed version 0.2.1-3.6-1.8 of package foris-controller-pakon-module
• Installed version 2.6-3.6-2.8 of package foris-pakon-plugin
• Installed version 0.3.2.10-1.8 of package tor
• Removed package luci-i18n-base-de
• Removed package luci-i18n-base-cs
• Removed package cznic-repo-keys-test
• Removed package user-notify-l10n-cs
• Removed package luci-i18n-commands-de
• Removed package user-notify-l10n-de
• Removed package luci-i18n-commands-cs
• Removed package foris-diagnostics-plugin-l10n-de
• Removed package foris-l10n-de
• Removed package foris-diagnostics-plugin-l10n-cs
• Removed package foris-l10n-cs

#2

I formatted your post as it was really long. Next time, please include all the output in a spoiler/preformatted text or in [code][/code] and I moved it to Turris OS 4.0 beta1 thread. Can you include in your post if you have Turris Omnia or Turris MOX?


closed #3

split this topic #4

A post was merged into an existing topic: Turris OS 4.0 beta1 is released!