USB flash disk not present

i used USB flash disk in front usb port. I wanted that usb for store turris logs, but not worked so I had there only rrd database and torrent files setup etc.

Some time ago, that flash disk stop working at all. It is not present in luci mount points.
So format this disk and verify blocks with some RW testers. All results are OK. It works in PC and elsewhere. But i tried all formats (NTFS, ext3, ext4, fat32…) everythink is same. Disk is not present.
But strange is that disk is visible in system.

fdisk -l

Disk /dev/sdb: 29.9 GiB, 32078036992 bytes, 62652416 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x00061de8

Device Boot Start End Sectors Size Id Type
/dev/sdb1 2048 62652415 62650368 29.9G 7 HPFS/NTFS/exFAT

Logs from time when it mounting:

2017-11-02T19:47:57+01:00 notice kernel: [ 10.010233] scsi 3:0:0:0: Direct-Access Samsung Flash Drive FIT 1100 PQ: 0 ANSI: 6
2017-11-02T19:47:57+01:00 notice kernel: [ 10.019249] sd 3:0:0:0: [sdb] 62652416 512-byte logical blocks: (32.1 GB/29.9 GiB)
2017-11-02T19:47:57+01:00 notice kernel: [ 10.027348] sd 3:0:0:0: [sdb] Write Protect is off
2017-11-02T19:47:57+01:00 debug kernel: [ 10.032166] sd 3:0:0:0: [sdb] Mode Sense: 43 00 00 00
2017-11-02T19:47:57+01:00 notice kernel: [ 10.032666] sd 3:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn’t support DPO or FUA
2017-11-02T19:47:57+01:00 info kernel: [ 10.045530] sdb: sdb1
2017-11-02T19:47:57+01:00 notice kernel: [ 10.049752] sd 3:0:0:0: [sdb] Attached SCSI removable disk

Picture from luci:

Please are there any ideas what should be wrong ?

Fist of all I would suggest you to not use ntfs but for example ext4 instead.
Second of all I don’t see any way it isn’t visible. From your screenshot from luci I clearly see SamsungFlash drive to be mounted in /mnt/SamsuntFlash. Where is it missing from?

1 Like

The same problem by me. Flash disk has been set in the past, config is generated, but now is “not present”.

Sorry for late respond. I had no time for it lately.

Oh now I see what you mean. Can you please check that you really have given UUID on system? For example using lsblk -fs?

root@Omnia:~# lsblk -fs
mmcblk0p1 btrfs ea9076db-29f3-43c1-ba9f-6eb8bdf41a61 /

That’s the problem! Flash drive is mount, share folder, 'll on it Majordomo and rrd graphs-everything works.

In a few days with the face not present, graphs and majordomo works, from the PC I see the shared directory of this flash drive, but if the mount point does not present, if I try to reconnect it is not visible.

You really don’t have it in system. There is no /dev/sd*. @Stybyk posted output where clearly he has /dev/sdb. You have nothing like that so I suspect different problem. Probably problems with usb detection? Can you please record output of dmesg while you unplug and plug your usb back so we know what is happening why it doesn’t shows up in system.

Yes, dmesg tomorrow.

USB disk is “not present” in system, but fysicaly in function for /mnt/sda1/majordomo_db and /mnt/sda1/rrd and shared folder and MC.

If disk is not mounted then you are writing to internal storage (flash). That is why some people are mounting their drives to /tmp/mnt instead so if their memory fails to mount they are not damaging flash storage.

The disc is or is not connected ? - If I see Midnight Commander - connecting is ready?

To be sure run mount | grep /mnt/sda1. If that gives you no output then no it isn’t mounted and you have created those files/directories on internal storage.

After router reboot is all ready :slight_smile:

root@Omnia:~# mount | grep /mnt/sda1
/dev/sda1 on /mnt/sda1 type ext4 (rw,relatime,data=ordered)

When is state “not present”, command mount is no response.

root@Omnia:~# lsblk -fs
NAME         FSTYPE LABEL       UUID                                 MOUNTPOINT
sda1         ext4   TURRISOMNIA ec5a3e65-cda0-584a-8515-4a4081723c07 /tmp/run/mountd/sda1
mmcblk0p1    btrfs              ea9076db-29f3-43c1-ba9f-6eb8bdf41a61 /

I believe the command DMESG during ejection and insertion of a flash drive is unresponsive. Can you refine the procedure?

any ideas what should be wrong ?

Usually, and I do it in this way on my productional servers too, i prefer automounting based on file-system label. I consider it as more transparent… So perhaps delete (“Odstranit”) the config and try the one based on fs label. Today I had similar issue (and thats how I found this discussion thread) and label-based mount fixed the problem.

As it is linux box, I would try to go with linux filesystem, so not NTFS…

Thanks for idea … i try it

Which method of connection point definition is better, more reliable, or less problematic?

1, 2 or 3 ??

  1. is bad, because /dev/sda can change to /dev/sdb,/dev/sdc, etc. when you will attach another harddrive first, and sometimes event the same harddrive can reappear with the next available /dev/sdXX string after USB reconnect.

And 1) vs 2) - I am personally not able to remember and read the UUIDs so I use human-readable labels. But maybe someone will point to some good reason to use UUIDs instead of FS labels. I remember that some legacy filesystems have no labels… but this is not the case here with ext3/4.

As I wrote before, I had the samsung flash formatted in ext4 but when it was in “not present state” I tried to change the format to some else. Every time was the same result. But now I tried again change to ext4 again, and it works. Samsung flash is present now.
When I had this issue, I must to write uuid to mount point gui manually… from “blkid” command.
And after that it was not present for each format.
But now I formatted it again and gui offered me UUID allone. Which i only choose by mouse.
And disk is present now.

The formatting type for me did not affect the behavior.

My unverified assumption (feeling) is that a UUID connection is unreliable for me and disconnects or problematic piece od flashdisk. Trying to test.