Updater.sh not working

Hi, i found that my router is not updating. If i am running updater.sh i am getting following message:

root@turris:~# updater.sh
WARN:Branch overriden to stable-new
DIE:
unreachable: https://api.turris.cz/updater-defs/3.3/omnia/stable-new/base.lua: curl: (22) The requested URL returned error: 404 Not Found

uci: Entry not found
uci: Entry not found
uci: Entry not found

Anyone aware how to fix that?

1 Like

https://forum.test.turris.cz/t/err-connection-refused-after-updating-to-turris-os-version-3-3/2187/6

It seems that issue is fixed by replacing stable-new to stable in /etc/config/updater. But why it is this way?

Its not. Now i have

Error from 2016/12/14 13:31:07
Updater failed:
corruption: Signature validation failed (some keys are missing) 

Probably its time to reinstall everything?

Actually, you want to remove that option completely (unless you want to be testing some development branch).

Anyway, the problem there was, we compile the flashable images for development branches with these changed URIs, for our convenience. And one slipped into the production. You must have flashed during that time. Did you re-flash recently?

No, i never reflashed it yet. So probably i am in the “unlucky” branch. Any idea how to fix signature error?

I think i finally fixed it by commenting out branch, fixing opkg.feeds and reinstalling updater-ng package. Updater.sh works well for me now, so no need to reflash

No reflash? I’ll have to have a look how it got in.

You fix the signature errors by not being in the „stable“ branch. Only the normal (branch without any suffix) and the -rc branches are signed with the release keys. The other branches are auto-signed by the build machine, but as these keys need to be online, the keys are less secure ‒ therefore they are not installed by default. If you really wanted to be in some of these development branches, you could (by installing cznic-repo-keys-test). But then, the risk of hitting bugs would be higher, of course.

Yes, no reflash. I disabled temporary opkg signing, fixed feeds, reinstalled updater-ng and cznic-repo-keys-test packages, re-enabled signing and after switching to a normal branch updater.sh works as it should. A lot of packages were updated, router functioning properly, so i would probably will not reflash it for now.

@samm_git @vorner I get

root@turris:~# updater.sh
WARN:Script revision-specific not found, but ignoring its absence as requested
WARN:Script serial-specific not found, but ignoring its absence as requested
WARN:Lock on //var/lock/opkg.lock released by garbage collector
uci: Entry not found
uci: Entry not found
uci: Entry not found
root@turris:~#

when typing updater.sh Good or bad? I’ve also had the problem as described here and here. I was able to resolve it by /etc/init.d/lighttpd restart