Updater Notification 404 URL Not found

I recently updated my MOX to running the latest medkit and after installation tried performing an update once connected to the internet and received a 404 notification that a URL was not found.

It looked like the updater didn’t install the additional software packages from repositories that I had selected as well and, I think, just aborted the update after the 404.

The URL that it listed as 404 is:


I tried navigating here with my browser and noticed that it is 404 from my web browser as well.

The date on the medkit I used is 2021-05-14 with SHA256 sum of:


This looks like you used medkit that wasn’t from HBS. You should in general always use only medkits from HBS.

The longer answer is that because of the release process we have the same binary medkits in HBK, HBL and HBS branches. Those clearly have to point to HBS because we do not touch them when we move them from HBK to HBL and later to HBS. This means that as the first step after you configure your router you have to access terminal (trough console or SSH) and do switch branch to branch you downloaded medkit from. This of course applies only to HBL and HBK.

Same error here. Just bought a new Turris Mox Power WiFi and powered it up. Automatic updates are activated through the “First Run Wizard”, along the “LuCI Extentions” and “NAS”. A few moments later I got the following notice:

Updater selhal:

runtime: [string "requests"]:395: [string "utils"]:427: URI download failed: The requested URL returned error: 404 Not Found 

Any advice?

Removing “LuCI Extentions” and “NAS”, doing updates, adding those back again worked.

I think TurrisOS should first check for (core-)updates and then for additional software.