Updater fails: unable to resolve host address 'repo.turris.cz'

solved

#21

I too have the same problem, the router was working fine up to the beginning of this Month (exactly) when it suddenly started failing to resolve repo.turris.cz

I run pi-hole which also serves my DNS & DHCP as a container on the router, WAN Adv settings have the Pi-hole as the DNS address.

It’s not an internet outage, all my devices on the network resolve repo.turris.cz the router fails to resolve the address however.

Where can I force the router to use the pi-hole for it’s internal DNS query? (as I suspect this is the problem as it has a static LAN address.)

I’ve worked around this for now by adding 217.31.192.69 repo.turris.cz to my hosts file.


#22

I have solved this now by adding my pi-hole container IP as a nameserver in addition to localhost in resolv.conf.

Why things break on this router with no intervention from me is a mystery!

eg:
/etc/resolv.conf

search lan
nameserver 127.0.0.1
nameserver 192.168.1.4


#23

I recently started suffering from the resolv.conf being over written on reboot. The following solves that:


Replace the xx IP with the DNS IP (192.168.1.4 in my case).