Updater failed: unreachable /tmp/crl.pem

Reset # 45 in three months! And now again

Why would you reset your Router because of this error? As expected this is fixed just by itself

Router not available!

If your router stopped working 45 times already, I would look into RMA’ing the unit as it is most likely a hardware problem.

There are similar issues already reported.

I’ve got the same error message after update to OS version 3.6
Reboot helped.

CRL is gone after reboot.

root@xsoft-turris:/tmp$ date
Sat Mar 11 16:08:56 CET 2017
root@xsoft-turris:/tmp$ df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/mmcblk0p1            7.3G    320.3M      7.0G   4% /
tmpfs                   503.6M    668.0K    503.0M   0% /tmp
tmpfs                   512.0K      4.0K    508.0K   1% /dev
root@xsoft-turris:/tmp$ ls /tmp/c*
ls: /tmp/c*: No such file or directory
root@xsoft-turris:/tmp$ get-api-crl
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  1076  100  1076    0     0  15769      0 --:--:-- --:--:-- --:--:-- 16059
root@xsoft-turris:/tmp$ ls -al /tmp/c*
-rw-r--r--    1 root     root          1076 Mar 11 16:09 /tmp/crl.pem
root@xsoft-turris:/tmp$ head /tmp/crl.pem
-----BEGIN X509 CRL-----

root@xsoft-turris:/tmp$ sync
root@xsoft-turris:/tmp$ reboot

I can confirm works fine now

Hi there, after updating to 3.6, I have the same error message:

Error from 2017/03/12 17:20:05
Updater failed:
unreachable: /tmp/crl.pem: No such file or directory

However, I rebooted like others have suggested here, but the error message remained, as evidenced by the date/time stamp above.

Should I remove /tmp/crl.pem via ssh as suggested?


Yes, you can remove/retrieve the file as much as you can. So check for the file and if missing get new one using above mentioned command. This issue was reported many times (same occured during 3.4 and 3.5 updates as well).
For me it worked well.
No file, get me new one : [ -r /tmp/crl.pem ] || get-api-crl
or have file, remove it and get me new one: [ -r /tmp/crl.pem ] && { rm /tmp/crl.pem ; get-api-crl ; }

I have the same issue.
The download of crl.pem works. But after I do a reboot the file is gone and I get the update error message because of missing crl.pem again.

same here, crl.pem is missing or empty without doing anything specific on the router. get-api-crl fixes this but it’s just temporary. How to fix this bug ?

This is not bug really. It’s just wrong error message. What it in reality means is that router lacked the Internet connection at time of update run. We run update in some cases as part of boot process. What this in reality means is that your ISP is slow in IP address assignment and we managed to boot before you have the Internet connection. Because of this it received minimal priority and we had more important tasks to tackle than this. But it should be fixed in Turris OS 3.7. Better message was added in Updater’s version 55 and wait for the Internet connection was added in Updater’s version 58.0.


thank you for this precision about this non-bug :wink: which will be fixed very soon.

1 Like

Out of interest, when can we expect Turris OS 3.7 to appear?

Probably in two or three weeks, maybe sooner, maybe later. I can’t promise anything as it depends on how long will finishing touches take. We are doing pretty big step with old Turris 1.x routers. They are being migrated to updater-ng. And so we are trying to be sure that it will work as expected.


I suppose the problem with updater-ng and possibility collect data off on old blue router will be fix.

This is topic about something else. Please don’t clatter unrelated topics. But yes according to my knowledge it should be fixed.

Sorry … and thanks for your info.