Update Firmware without internet connection

The about page shows the following information:

Device Turris Omnia - RTROM01
Serial number XXXXXXXXXXX
Turris OS version 3.2.1
Kernel version 4.4.13-05df79f63527051ea0071350f86faf76-7

My provider (Init7 from Switzerland) seamed to have had troubles with Turris Omnia in the past but fixed them with an update. I’m not sure what kind of update, but I’m guessing they contributed to the firmware, as a lot of people reported for them it’s just “plug&play” now. The SFP Module and Cable was supplied by them and was labeld with “SFP for Turris Omnia”, so that should (probably) work.

Unfortunately their support is only available during Workdays, so I can’t call them until Monday, which kind of sucks.
Since there is Turris OS 3.7 out and 3.8 as RC, I thought, I’ll just update the router myself and see if it then works.

I found this thread: Get current FW version and force update telling me to run the command in /usr/bin/updater.sh the only trouble for me is, that I have no internet connection on the router. I also found the github repo (https://github.com/CZ-NIC/turris-os).

Now to the question: How do I install a new OS version without Internet connection?

I thought about downloading the github zip, transfer it using ssh (scp) and the unzip it on the router. But how to install it then? Or is there a simpler way?

Hello and welcome,

if I have understood correctly you have a possibility to download something?
If no settings have been made, this would be a possibility to upload a new image of the current version.


Use option 4 “re-flash router” with the following address to get the image:


However, it is about the current 3.7.5 version and not the 3.8 RC
This should work.

Best regards

Thanks, I’ll try that one!

I currently have the possibility to download to Ubuntu or Windows, using a hotspot on my smart phone, and then connect the computer using a lan cable to the router, but I don’t have a direct option to download on the router. However in this case, I guess that should work.

So finally was able to flash it. Now I’ve got:

Device Turris Omnia - RTROM01
Serial number XXXXXXXXXXX
Turris OS version 3.7.5
Kernel version 4.4.79-967673b9d511e4292e3bcb76c9e064bc-0

Which is an improvement. However Internet is still not working.

During setup, it didn’t get further than step 3, connectivity check. I then skipped the wizard. In the DNS tab, I tried both Disable DNSSEC enabled and disabled. Still no luck.

With the old firmware, all the checks failed. With the new version, one works, the IPv6 gateway connectivity is now showing ÒK. All others still fail and I can’t ping Google or any other page.

Additionaly in the WAN tab, I get the notification: “WAN port has no link, your internet connection probably won’t work.” (it was the same with the old firmware). Could it be, that it still tries to use the RJ45 WAN port instead of the SFP module? If so, how can I check this and how/where can I change that to the SFP module? Are there any debug outputs I should dump, to see what’s wrong?

It won’t work without contacting fiber7. The @fiber7_ch support team asks @turris_cz users to call when they install the router, in oder to reconfigure their switch port to “speed nonegotiate”.