Unable to reflash my Omnia / update it. Only possibility seems via serial connection?


I’m trying to flash my Omnia (running Turris OS v3.2.1) using the USB flash method as described here (4 LED flash)

Since it’s very old software, I’d obviously like to do this before connecting to the Internet.

However, it unfortunately doesn’t seem to be working (see vid: https://0x0.st/i5SD.mp4)

I think I’m running into this issue.

I’ve already tried:

And so I’ve understood (thanks to user embargo from IRC) that my only option currently is updating it via serial.

Unfortunately I don’t currently own a USB to serial adapter, and the one I ordered comes only on Monday :frowning:

So is there any other way I can update to the latest Turris OS version?

Thanks in advance.

Are you using partitions on the USB drive (e.g., /dev/sdb1 instead of just /dev/sdb? It only worked with a partitioned drive in my case, I used ext4.

Yes, I used /dev/sdb1 every time.

Which medkit are you using? Can you provide a link to the image?

One of your pastebin dumps it lists a file called turris1x-medkit-202011130923.tar.gz – if this is the medkit you’re trying to flash it would explain why it isn’t working, since it’s for the Turris v1 version (different hardware). Also, can you confirm the filename on the USB drive is omnia-medkit-latest.tar.gz? I’m not sure how much flexibility we have in terms of file naming but I can confirm that it did work for me using this file name.

1 Like

Correct, that was a mistake before I found out that I had to have the omnia-medkit-202011130855.tar.gz, which I subsequently used. Unfortunately that didn’t work either. I did try renaming it to omnia-medkit-latest.tar.gz but that didn’t work too.

Hm, I’m slowly running out of ideas here. I can provide you with the steps that worked for me. I’d just go through the whole procedure again to rule out any assumption-based issues:

  1. Download the right medkit and its checksum
  2. In the download folder: cp omnia-medkit-latest.tar.gz omnia-medkit-202011130855.tar.gz; shasum -c omnia-medkit-latest.tar.gz.sha256; rm omnia-medkit-202011130855.tar.gz (the .sha256 file contains the wrong filename).
  3. Determine the USB drive device, then use fdisk to remove any partitions, create a standard MBR partition table with one physical partition; save
  4. mkfs.ext4 <your new partition>
  5. Mount newly created ext4 filesystem somewhere, copy omnia-medkit-latest.tar.gz to it, leave away the checksum
  6. sync
  7. Give it a try!

Good luck!