Unable to open LAN page in reForis


I am unable to open the LAN page in reForis.

“Timeout occurred during performing foris controller action.”

Any idea how to fix this?

Are you using Windows and Avast or AVG antiviruses?

Windows 11, yes. No, just Windows Defender.

There are several users (including me) who observed that some Websocket requests from Reforis are blocked on Windows. The current hypothesis was that it is only caused by AVG and Avast antiviruses (turning off HTTPS scanning in them solved the issue). I think you’re the first on having this issue without any of these two AVs.

There is already a lengthy discussion about this topic (unfortunately, in Czech): Nelze potvrdit žádné nastavení v reForis .

I do not use any kind of “Security” software besides what’s integrated in Windows. And the issue happens in both Firefox and Chrome.

Try another browser, for me it helps to use Chrome instead of Opera. The second option is to try http connection if possible. In Avast I have set the necessary exceptions.


reForis automatically switches to https and then there is no way to change the settings - for too long response time.

The situation sometimes changes for the better, but in reForis I sometimes have a problem to change some settings. Previously my LAN connection was http and reForis worked correctly

I tried switching to https, then the router ran into this:

I had to reboot via SSH and now the LAN page works :thinking:

Might be, but I guess that this is not the case.

Usually there are two cases of “Timeout occured during performing foris controller action”:

  1. In the “Cannot update any settings in reForis” scenario, AV software usually interferes with the POST requests. GET request should be fine, at least based on our testing.
  2. It could be issue just with the reforis backend itself, i.e. request was send, but never received or processed, when backend is not responding for whatever reason.

Of course I could be wrong, but this looks more like a reforis backend issue.

My guess is based on the fact, that this issue arises when trying to load LAN page and following screenshot confirms my suspicions.

I am glad that it helped and hopefully it will work fine from now on.

However in case this issue arises again, please reach out to our support department.

1 Like