TurrisOS 3.9.1 is out!

Dear Turris users,

we just released Turris OS 3.9.1. It mainly contains mainly fixes and few updates:

  • coreutils: update to the latest version
  • uci: less sync calls - faster commits
  • hostapd: updated patches from LEDE
  • kernel: update to the latest version, fix LXC error
  • pakon: more robust installation
  • updater: more robust updates and fixes to local repos handling
  • knot-resolver: update to the latest version
  • foris: updated translations and more diagnostics
  • haas-proxy: more robust firewall integration

This should fix some issues from 3.9 release.

Happy routing,

Team Turris

3 Likes
INFO:Running post-install and post-rm scripts
Output from knot-resolver.postinst:
+ [ -z  ]
+ /etc/init.d/dnsmasq restart
udhcpc: started, v1.25.1
udhcpc: sending discover
udhcpc: no lease, failing
+ sleep 2
+ /etc/kresd/kresd.postinst.sh
+ uci -q get resolver.kresd.static_domains
+ stat_dom=
+ [ ! -z  ]
+ /etc/init.d/resolver restart
uci: Entry not found
+ rm /etc/kresd/kresd.postinst.sh
+ /etc/kresd/convert_config.sh
uci: Entry not found
+ rm /etc/kresd/convert_config.sh
+ uci -q get resolver.common.prefered_resolver
+ [ kresd = kresd ]
+ uci -q get resolver.common.forward_upstream
+ egrep -q (1|yes|true|enabled|on)
+ ping -c 1 api.turris.cz
Output from updater-ng-localrepo.postinst:
Traceback (most recent call last):
  File "/usr/bin/localrepo", line 541, in <module>
    main()
  File "/usr/bin/localrepo", line 537, in main
    cmd_check(args)
  File "/usr/bin/localrepo", line 429, in cmd_check
    gen_updater_config()  # Just to be sure, regenerate
  File "/usr/bin/localrepo", line 48, in gen_updater_config
    with open(os.path.join(REPO_PATH, "localrepo.lua"), "w") as file:
IOError: [Errno 2] No such file or directory: '/usr/share/updater/localrepo/localrepo.lua'
Output from updater-ng-opkg.postinst:
+ [ -f /etc/updater/conf.d/opkg-auto.lua ]
+ UPDATER_CONFIG=/etc/updater/conf.d/opkg-auto.lua
+ sed -n s/^Package.*content *= *"file:\/\/\([^"]*\)".*/\1/p /etc/updater/conf.d/opkg-auto.lua
+ read PKG
+ localrepo clean --repo auto
+ sed -i /^Package.*content/d /etc/updater/conf.d/opkg-auto.lua
+ rm -rf /usr/share/updater/local-pkgs
Output from foris-controller.postinst:
+ [ -n  ]
+ /etc/init.d/foris-controller enable
+ /etc/init.d/foris-controller restart
Output from foris-common.postinst:
+ [ -n  ]
+ [ -f /www2/forris.pyc ]
+ /etc/init.d/lighttpd enable
+ /etc/init.d/lighttpd restart
Output from foris-config.postinst:
+ [ -n  ]
+ /etc/init.d/lighttpd restart
Output from foris-wizard.postinst:
+ [ -n  ]
+ /etc/init.d/lighttpd restart
Output from foris-diagnostics-plugin.postinst:
+ [ -n  ]
+ /etc/init.d/lighttpd restart
Output from foris-l10n-cs.postinst:
+ [ -n  ]
+ /etc/init.d/lighttpd restart
Output from foris-diagnostics-plugin-l10n-cs.postinst:
+ [ -n  ]
+ /etc/init.d/lighttpd restart
Output from foris-openvpn-plugin.postinst:
+ [ -n  ]
+ /etc/init.d/openvpn enable
+ /etc/init.d/lighttpd restart
grep: /proc/26700/cmdline: No such file or directory
grep: /proc/26701/cmdline: No such file or directory
Output from foris-openvpn-plugin-l10n-cs.postinst:
+ [ -n  ]
+ /etc/init.d/lighttpd restart
Output from foris-tls-plugin.postinst:
+ [ -n  ]
+ /etc/init.d/lighttpd restart
Output from foris-tls-plugin-l10n-cs.postinst:
+ [ -n  ]
+ /etc/init.d/lighttpd restart

Nahozeno, krom toho tracebacku OK.

I guess that you have forgotten to disable debug messages from dnsmasq. See sample from my System Log

2017-12-21T12:26:03+01:00 debug dnsmasq-script[4942]: ret >
2017-12-21T12:26:03+01:00 debug dnsmasq-script[4942]: __call_kresd hints.add_hosts(‘/tmp/kresd/hints.tmp’)
2017-12-21T12:26:03+01:00 debug dnsmasq-script[4942]: ret > [result] => true
2017-12-21T12:26:03+01:00 debug dnsmasq-script[4942]:
2017-12-21T12:26:03+01:00 debug dnsmasq-script[4942]: >
2017-12-21T12:26:03+01:00 debug dnsmasq-script[4942]: __call_kresd hints.add_hosts(‘/tmp/dhcp.leases.dynamic’)
2017-12-21T12:26:03+01:00 debug dnsmasq-script[4942]: ret >

On Turris Omnia 2GB after reboot in kernel log

[   31.301929] Hardware name: Marvell Armada 380/385 (Device Tree)
[   31.307860] Backtrace: 
[   31.310326] [<c001c61c>] (dump_backtrace) from [<c001c85c>] (show_stack+0x18/0x1c)
[   31.317911]  r6:00000000 r5:60000013 r4:c06c63e8 r3:00000000
[   31.323628] [<c001c844>] (show_stack) from [<c02f38c8>] (dump_stack+0x98/0xac)
[   31.330869] [<c02f3830>] (dump_stack) from [<c00abacc>] (warn_alloc_failed+0xec/0x120)
[   31.338801]  r6:00000001 r5:00000000 r4:024000c0 r3:c06bee4c
[   31.344518] [<c00ab9e4>] (warn_alloc_failed) from [<c00d5c78>] (__vmalloc_node_range+0x170/0x214)
[   31.353407]  r3:00017669 r2:c05cb04c
[   31.357007]  r6:c008c69c r5:00000000 r4:00017669
[   31.361665] [<c00d5b08>] (__vmalloc_node_range) from [<c001d1c0>] (module_alloc+0x5c/0xbc)
[   31.369946]  r10:f0ec24c0 r9:f0ead000 r8:00017669 r7:ffffffff r6:c008c69c r5:024000c0
[   31.377843]  r4:c06de41c
[   31.380394] [<c001d164>] (module_alloc) from [<c008c69c>] (load_module+0x7b4/0x1cd4)
[   31.388153]  r8:00017669 r7:00000aa0 r6:f0ec2ba4 r5:000002ea r4:ed01ff34
[   31.394919] [<c008bee8>] (load_module) from [<c008dc98>] (SyS_init_module+0xdc/0x14c)
[   31.402764]  r10:00000051 r9:0001223f r8:ed01e000 r7:f0ecd0a4 r6:b66ff0b4 r5:00000000
[   31.410661]  r4:000000a4
[   31.413210] [<c008dbbc>] (SyS_init_module) from [<c0009d00>] (ret_fast_syscall+0x0/0x48)
[   31.421317]  r10:00000000 r9:ed01e000 r8:c0009ec4 r7:00000080 r6:00000000 r5:00000000
[   31.429213]  r4:00000000

Turris 1.1 under contract - repeating error message

root@turris1:~# cat /var/log/messages | grep 'err foris'
2017-12-21T13:15:31+01:00 err foris-controller[]: Failed to parse content of '/usr/share/server-uplink/contract_valid'.
2017-12-21T13:15:36+01:00 err foris-controller[6018]: Last message 'Failed to parse cont' repeated 20 times, suppressed by syslog-ng on turris1
2017-12-21T13:15:38+01:00 err foris-controller[]: Failed to parse content of '/usr/share/server-uplink/contract_valid'.
2017-12-21T13:15:39+01:00 err foris-controller[6018]: Last message 'Failed to parse cont' repeated 8 times, suppressed by syslog-ng on turris1
2017-12-21T13:15:39+01:00 err foris-controller[]: Failed to parse content of '/usr/share/server-uplink/contract_valid'.
2017-12-21T13:15:44+01:00 err foris-controller[6018]: Last message 'Failed to parse cont' repeated 8 times, suppressed by syslog-ng on turris1

I got the same anomalies as @Radovan_Haban

After a while, without my intervention, those messages stopped to appear.

OK, I don’t know if this has been asked before, but… When are you guys going to stop messing around with user configuration? /etc/config/* should be sacred, and every single time there’s an update the dhcp configuration is changed and the resolver script reenabled. I personally only use dnsmasq (no unbound or knot) and I’m really getting annoyed at this whole deal. Really, no excuses, just stop it.

Which LXC error was fixed? I noticed that multiple LXC-related errors were reported in the forum recently:

  1. Problems with lxc - Can not create container from GUI
  2. LXC - Container can only be started one time

I cannot create LXC container from Luci too, even with 3.9.1. lxc-create -t download -n test works for Debian but not for ArchLinux (tar: Ignoring unknown extended header keyword 'SCHILY.fflags' error).

Unfortunately these topics are duplicate and honestly I don’t know why the creator create another same thread, but ok and I’m going to close one of it or merge it.

Let’s take it one by one
Installing containers via LuCI doesn’t work. We know it and working on it and I already confirmed in some thread.
Workaround: Use SSH. In past we thought that api should work, but please don’t use it and stay with repo.

What was fixed?
Starting/stopping/restarting containers via LuCI.

About ArchLinux, thanks. I’ll notify @miska

It is mentioned in the kernel news, so the second issue :wink: Not the LuCI one. SHILY.flags should be harmless, but I’ll check whether Archlinux didn’t changed something in their tarballs.

EDIT: Yep, regardless of SHILY.flags warnings container is installed fine.

I am stucked on this message. Enter does nothing

root@turris:~# updater.sh
WARN:Script file:///usr/share/updater/localrepo/localrepo.lua not found, but ignoring its absence as requested
WARN:Requested package luci-i18n-ddns-en that is missing, ignoring as requested.
WARN:Requested package foris-netmetr-plugin-l10n-cs that is missing, ignoring as requested.
WARN:Requested package foris-netmetr-plugin-l10n-de that is missing, ignoring as requested.
WARN:Requested package https-cert that is missing, ignoring as requested.
INFO:Queue install of updater-ng/turris/60.0.5-2
Press return to continue, CTRL+C to abort

Turris 1.0
TurrisOS 3.9.0

In general, enter runs updater, which will then silently update all your packages, so be patient :slight_smile: Being more verbose is in todo.

I’m already waiting for ~ 15 minutes

Hi there… can someone explain me how the new Haas honeywagon works? I see my unit there, but no data. And it is sending data…should i remove the p22 FW rule that used to work?

Best, Dikke

1 Like

Ok, thanks @miska and @Pepe for the info. Of course I could check the kernel news but I didn’t know where to find it. I would consider to put a link to a commit/release in those announcements (if there is more info for those who want to know more details).

@miska I re-tested ArchLinux container and you are right, it works despite warnings. I can also confirm that Start/Stop/Reboot works correctly now with containers.

So with a postponed restart exactly under the Christmas tree. Thank you. I look forward to further improvements.

My Turris Omnia successfully upgraded to 3.9.1. All services seem to be fine, except I still cannot login to Foris. I get a “500 - Internal Server Error” when trying to connect to the router. The Foris interface entered this state since the 3.8 update, and worked fine before that. The LuCI entry works, though. Any ideas how to solve Foris are appreciated.

Try clearing browser cache.

Thanks, tried that, did not help. I also tried from different systems (Windows10, Mac High Sierra) and different browsers (Firefox 57.0.2 64-bit, Chrome 63.0 64-bit). This makes me believe that it is an issue on the Turris Omnia side and not on the browser side.

1 Like