TurrisOS 3.8.5 is out!

Dear Turris users,

we just released Turris OS 3.8.5. It contains various security fixes but apart from them, we finally pinned down the bug in update approvals. If you have enabled manual approvals of updates, next release will be installed only after you confirm it (this release just installs this fix).

Full release notes are as follows:

  • updater: fix update approvals
  • resolver: various fixes mainly regarding local domain names
  • knot-resolver: update to the newer version
  • unbound: update to the latest version
  • syslog-ng: fixed init script
  • curl, ntpd, irssi a tor: security updates

We are looking forward to your feedback!


Update approval seems indeed to be working. I first got an email about updater-ng and libcurl being updated and now I got a notification about all the other packages waiting for my approval. Thank you

I can confirm, updater approval works ok now, the first time (if it is set this way).

Omnia 2GB, NAS,OpenVPN, LXC Debian(Nextcloud, PiHole) update to 3.8.5 ok.

Release appears to be working fine. Did this update to Kresd fix the compression problem that was preventing some devices getting usable DNS responses ( see the Yamaha receiver thread for example? ).

No, libknot is still on 2.5.x.

Thnings are allright. But DNS local devices are no longer working.
I cannot have e.g. router.lan dns.lan or notebook.lan.
It used to work but no longer is.

This started to behave this way after restart.

For me everything is working as expected. In use are adblock, dyndns (bug: still displaying wrong update-IP), OpenVPN.

Same issue with resolving local dns records for Turris 1.x

Local dns records are back online. Issue probably temporary. I will monitor it.

I just want to say thank you for the continuous updates.

Update approval worked for me. There was an update to updater that it installed without approval, but I bet this fixed the approvals :slight_smile:

I am gaining trust in Omnia Turris software and so I did two things now:

  1. I enabled data collection. I will monitor it in the first weeks, but I am pretty confident already that it doesn´t do anything nasty.

  2. I switched to kresd for resolving. I had the issue that on deinstalling dnsmasq-full somehow the dnsmasq service was disabled completely. I enabled it again in LuCi web gui and now it works nicely. I just need to be patient enough to start up.

Aside from that I made Turris OS a bit more comfortable for me, by installing procps versions of ps, free and top as well as Z-Shell. And vim-runtime for syntax highlighting. All with a configuration that matches my Debian configuration as far as I want it to.

I know I gave quite harsh feedback initially, partly even unjustified, yet… as I see that you take user feedback seriously and for example installed update approvals, it becomes easier for me to trust.

1 Like