Turris OS v.3.8.1 bug: OpenVPN client not working after update

I had an OpenVPN client setup with a firewall zone to send all traffic through the VPN.

After upgrading yesterday the OpenVPN settings page shows the connection started but no traffic is going through the VPN.

Any idea what could have changed to the network interface/ firewall/ VPN due to the upgrade?

1 Like

I can confirm having the very same problem.
@conel: And what do you mean with “with a firewall rule”? You usually achieve this within client config (I am using “OpenVPN für android”).

Solved: The router was updated, but not restarted (looking into the log-files, it’s been online for 5 days now and the update was 2 days ago. So I restarted the router and now it is working again.

@ssdnvv I meant a firewall zone. I skipped 3.8.0, was it working for you under 3.8.0?

On a related note, do the start/ stop buttons on the Luci OpenVPN work reliably for you?

I have to repeatedly check/uncheck the “enabled” boxes and click apply/save/start/stop to get the VPN to start or stop. It’s a mess.

It’s not solved for me, I’ve rebooted my router.

It was working without problems for me.
As I don’t know your configuration, I could help if you tell me:

  • Has it been working for your before 3.8.x?
  • your configuration-files:
  1. network
  2. firewall
  3. openvpn
  4. client config (and which client do you use - android (which app), windows…?)

The problem is with the OpenVPN client running on the Turris Omnia, I"m not running a VPN server.

I’ve created an “unmanaged” network interface named “VPN” covering “tun0”.

I’ve created a firewall zone which accepts input/output/forward/masquarde and allows forward from LAN to VPN and VPN to LAN.

I’m able to start VPN instances using the web ui but traffic through the router doesn’t use the VPN.

This was working fine prior to the upgrade to 3.8* (I had skipped 3.8.0).

1 Like

Sry, my fault. I am running a openVPN server on the TO.
Then I cannot help you any further :frowning:

The stop button isn’t working. But you can use stop from the startup tab.
I have the same problem. Since 3.8 dns resolving doesn’t work through the tunnel. TO as client.

Hi, did you solve this problem? I have the same on 3.9.2

Exactly the same here.