Turris OS 6.4.0 is released now!

Dear Turris users,
we just released Turris OS 6.4.0 with some new features, minor fixes and security updates.

:rocket: New Features

  • Add support for Neoway N75-EA, Quectel EP06 and Sierra Wireless WP7607
  • Nextcloud now uses the upstream updating solution which automatically updates it to the last Nextcloud version

:pushpin: Updates

  • rainbow: update to 0.1.4, fixes brightness changing over time
  • lighttpd: update to 1.4.71, package is now closer to the upstream OpenWrt package
  • Linux kernel updated to 5.15.120 (MOX, Omnia) and 5.10.186 (Turris 1.x)
  • bind: security update to 9.18.16

We appreciate any feedback regarding this release.


So for the first time in ages the LEDs ended up at the configured brightness after a restart! I still need to test a cold boot with power down, but I am mildly optimistic this (for me cosmetic) issue might be solved.

1 Like

Everything seems still running on my Turris Shield.
But when I try to access the reforis login it now just gives me an "Unhandled Exception

An unhandled exception was thrown by the application" Page. Multiple Reboots didn’t fix the Problem.

1 Like

wasn´t this an error on the browser end? iirc, deleting browser cache or using another browser should fix that.

I tried clearing the Cache, using another Browser and using another device. Didn’t work, same error.

TO 2016, HBS branch, 2 GB, 2x WiFi, HaaS, RIPE Atlas, Sentinel, lxc, SSD (logs etc.), simple config, all seems OK.

v6.4.0 is still not tagged on GitLab


@Pepe you also noticed that


GitLab is not used much anymore.

After 6.4.0 upgrade, I loose the LTE support using an E3372 USB dongle.

Issue: LTE support lost after 6.4.0 upgrade (#922) · Issues · Turris / Turris OS / Turris OS packages · GitLab

Restoring the 6.3.3 snapshot brings the support back.

1 Like

Why does the rainbow command return an error?

This topic was automatically closed after 20 days. New replies are no longer allowed.