Turris OS 6.3.0 is now released

Dear Turris users,

After a short time in the testing branch, we released Turris OS version 6.3.0. The main change is replacing Netmetr with LibreSpeed. Netmetr will get shut down soon, so we decided to implement a UI for LibreSpeed instead and host our own LibreSpeed server. Unfortunately the librespeed-cli client we are using on the backend is written in go which doesn’t support the Turris 1.x CPU. Users who had Netmetr installed should also get Librespeed installed with this release and in a future version of Turris OS, Netmetr will get uninstalled.

:rocket: New Features

  • Syncthing and Transmission WebApps now use Turris Auth
  • Enabled multiple speed optimizations on Turris Omnia and Turris MOX
  • LibreSpeed reForis plugin for measuring network speed replacing Netmetr

:bug: Bug Fixes

  • Fixed webfinger support in Nextcloud
  • Fixed QoS for guest network
  • Notifications now correctly report reboot date at the end of the month
  • Hide incompatible packages from reForis on Turris 1.x

:pushpin: Updates

  • Linux kernel updated to 5.15.96 (MOX, Omnia) and 5.10.170 (Turris 1.x)
  • Nextcloud updated to 24.0.9
  • Sentinel Common Passwords updated for Q1 2023

We appreciate any feedback regarding this release.


Today at three in the afternoon and at half past five I received this notification from my Turris 1.1:

Error notifications


Updater execution failed:

inconsistent: Requested package librespeed-cli that is not available."

I haven’t changed anything for a long time and updates are only allowed with approval. I assume it’s related to the upgrade to version 6.3.0, which is supposed to include librespeed. However, in that case, there’s probably a bug somewhere.


librespeed-cli is new in this update and not available on Turris 1.x, so this is definitely related to this update. Could you confirm if you have the netmetr package enabled in reForis and if disabling it makes the update go through fine?

If what I assumed is true, I think I found the issue - we are installing librespeed for every user who had netmetr installed, but don’t actually check if librespeed is available on that board (which it isn’t on Turris 1.x): pkglists/net_monitoring: do not install librespeed on turris1x (!70) · Merge requests · Turris / Turris OS / Turris updater lists · GitLab, we will try to test this and release a fix as soon as possible.

1 Like

Yes, I had Netmetr. So that means that when I removed it, I will have no internet speed measurement as librespeed is not supported on Turris 1.1. So why you did not let it be on Turris 1.1 as it was until you support librespeed on Turris 1.x?
To be able to remove Netmetr, I had to approve update, which also approved update to 6.3.0. This is not what I wanted that early. Well, it’s too late to chase the bull.
At least I can confirm that after removal of Netmetr, update to 6.3.0 started and went well without any further error messages.


So that means that when I removed it, I will have no internet speed measurement as librespeed is not supported on Turris 1.1. So why you did not let it be on Turris 1.1 as it was until you support librespeed on Turris 1.x?

This is unfortunately a bug. The update shouldn’t have tried to install librespeed on Turris 1.x. You will be install and use netmetr again with the next Turris OS version until the netmetr service is shut down.

A few days or weeks ago I’ve noticed bad interaction between Turris Auth and Luci. If I first log in to reforis making turris auth happy, accessing Luci does not take me to the login page of Luci, but it shows the Luci Dashboard. It might be good, but this view of the Dashboard has no visible elements that would lead to the login page. And the main menu is empty, it contains just Dashboard. To actually get to the login page, I have to navigate to a URL saved in my browsing history that would access some of the password-protected Luci parts.

Hi! Have you fixed the issues with IGMP multicast traffic?

Hi, update on my MOX 6.2.4 to 6.3.0 has 3 small issues netmetr was not removed, USB 3 devices are still not recognized and morce has following error message - Updater execution failed:
inconsistent: Package morce requires package snort3 that is not available."

+1 I have noticed the same issue. There are other mentions of this in another forum post.

Upgrading to version 6.3.0 caused a loss of connectivity to the Internet.

Rebooting the router helped.

Regarding libre-speed:

Server	Date and Time	Download [Mb/s]	Upload [Mb/s]	Jitter [ms]	Ping [ms]
Virginia, United States, OVH	3/29/2023 9:01 PM	88.56	33.86	0.23	16.36

Since I am in Germany, 16.36 milliseconds to Virginia USA is optimistic :wink: something is misnamed here…

More importantly for the LibreSpeed Autostart Settings page:

Here you can enable Autostart. The measurement will occur once daily, and the time is picked randomly during the night hours.

Respectfully, I can understand why this was changed from the up to every hour schedule that netmetr allowed, but this is far less useful this way… maybe at least allow to pick one of the 4 6 hour segments of a day here?


Just FIY, still getting the “Updater execution failed:
inconsistent: Requested package librespeed-cli that is not available.” on my 1.x bluey right now.

Netmeter package still available in reForis, but About page still shows Turris 6.2.4, as of March 30, 2023 12:XX AM.

Did the whole scheduled update to 6.3 fail because of the librespeed-cli issue, or is that something else? I gathered from the notes 1.x should still update to 6.3, just without the librespeed package. But it did not. Manual update check in reForis shows nothing new available, still on 6.2.4. No evidence of 6.3 being available here.

Turris 1.x, HBS branch, Turris OS 6.2.4, reForis 1.4.1

Many thanks!

[edited for clarity and errors]

I have same problem.

What is Turris Auth ?

The same here (omnia user). Also, a few hours after reboot I can’t login to reForis and found this in lighttpd logs:

2023-03-30 07:49:08: (../src/gw_backend.c.283) establishing connection failed: socket: unix:/tmp/fastcgi.turris_auth.socket-0: Connection refused
2023-03-30 07:49:08: (../src/gw_backend.c.993) all handlers for /reforis/? on /reforis are down.
2023-03-30 07:49:10: (../src/gw_backend.c.360) gw-server re-enabled: unix:/tmp/fastcgi.turris_auth.socket-0  0 /tmp/fastcgi.turris_auth.socket

Restart of lighttpd solved the login problem:
/etc/init.d/lighttpd restart

Turris Auth is the unified login page you can see when logging into Reforis (and now also Syncthing and other services). The login is shared by all the applications except Luci, so if you login into Reforis, you should no longer need to login into Syncthing.


for last two weeks I’m getting an error when trying to check for updates:

Updater execution failed:
runtime: [string “requests”]:432: [string “utils”]:443: Unable to finish URI (https://repo.turris.cz/hbs/omnia/lists/pkglists/openvpn.lua): Signature verification failure"

Is there anything I can do to be able to update to the latest version and get version of that error? I’m now on 6.2.4 version and I’m getting this error also during the day (automatic updater).

Best regards!

Hi, on my Turris 1.1 the update also did not start with the updater error message about the netmeter. After removing the netmetr package in Reforis, the update ran fine immediately.
However, I still see Speed Measurement in the package list after the update. Can I uncheck/enable it? I thought Netmeter was removed.