Turris OS 6.0.3 is now released

Suddenly my drive was visible today. I don’t know how, there hadn’t been any updates or packages installed, just the power was accidently off for some hours.
So storage is finally there under 6.0.3.

Nevertheless setting up Nextcloud is still not possible and ends up with this error message:

Error while trying to create admin user: Failed to connect to the database: An exception occurred in the driver: SQLSTATE[HY000] [2002] No such file or directory

So when will this be fixed as the error appeared in previous versions too???

Turris Omnia: 2020 2GB edition
Current/previous TOS: v5.4.4
Update to: TOS v6.0.3

Oke, today i thought let me try to update it as from TOS 6.0 there have been problems.

I updated it from 5.4.4 → 6.0.3. First my Linux container was not visible. Then i got a minor update, that fixed it, but the LED’s were still very bright compared to my previous settings.

It got stuck. I tried a reboot from the terminal no response. I tried it through Luci, it worked. Then TO did not give any response to my pc (wired connection). When i grabbed my tablet, my tablet was connected to the wifi and i was able to see everything that i need to see. But those LEDs were still very bright. My PC still could not ping or visit the Reforis/Luci. I then decided through my tablet to go to Reforis and do a rollback to TOS v5.4.4. (cant thank you guys enough for implementing the rollback functionality. Yes testing is part of getting things to work correctly, but at least have the possibility to rollback is just a MUST. So good job on that!!).

For TOS 6.0.x to work. Just contact us about the issues and we maybe can fix it together what is going on. If you need other information from me to fix these issues (like logs etc). Just let me know.

May I ask why? (Personally using ondemand basically on all my environments and as was said previously, on my Omnia cpu didnt actually do any changes)

This is a fix for MOX users experiencing random reboots. On Omnia it shouldn’t make a difference i guess


does someone have the same issue as me? Every time I want to leave the bash I get:

root@turris:~# bash --version
GNU bash, version 5.1.4(1)-release (powerpc-openwrt-linux-muslspe)

root@turris:~# ^C
reader_loop: bad jump: 8388608
last command: reboot
Aborting...Connection to closed.

Turris 1.1

1 Like

Nit: the normal way to leave a shell is ^D, not ^C. (of course, it still looks like a bug)

Doesn’t matter if I use ctrl+d, ctrl+c, exit

reader_loop: bad jump: 8388608
last command: reboot
Aborting...Connection to closed.
1 Like

tried the update again, but it not worked.
even not with your config.

I see that /var is linket into /tmp
@jondifool did you found a solution?

Just a heads-up that I (inadvertently) upgraded last night, and it broke my web services. So rolled back (schnapps rocks!) and will diagnose as time permits. The problem is usually that I have a highly configured lighttpd reverse proxy configuration that the upgrade breaks, and so diffing those configs generally sorts me out. But the updater was not comforting with a load of worrying output like:

Command failed: Not found

(without a reference to what command though appearing after “INFO: Running”)

I will try and extract all the INFO/fail pairs from my log (I took a copy from the console though wonder if there’s one on disk?)

I would not be surprised if these are so widespread because of a domino effect. One premise early broken and so a lot of downstream failures. We shall see.

In 6.0, lighttpd configs load in a different order (numbering was added to the start of the config files to make the order explicit). Check your custom files and assign numbers as needed. This might fix lighttpd.

The Command failed: Not found lines are mostly harmless, they come from the LED controller that still has some bugs.


How to skip update to Turris 6.0.3?

I have a MOX with SIDO and currently installed fresh Turris OS 5.4.4, but updater going to update to Turris OS 6.0.3. Even manual switching to another branch with switch-branch --force hbs-sdio doesn’t help. The problem is that I can’t install other required packages, cause they require full update (in case of using reforis), or, using opkg, they require newer packages from 6.0.3, like a newer version of kernel.

What I need to do?

I think, the best way to install is via medkit, but I dont have Mox and some users here mentioned above few problems after that installation to TOS6.

I had the same problem. I had to replace hbs with hbs-sdio in /etc/opkg/distfeeds.conf
As suggested here: https://forum.turris.cz/t/mox-hbs-5-4-4-s-sdio-se-chce-updatovat-na-tos-6-0-i-kdyz-by-nemel/17901/2?

Thank you for pointing me to the solution!
I’ve changed hbs to hbs-sdio at /etc/opkg/distfeeds.conf and successfully updated to 5.4.5.


I found the solution for at least the omnia-LXC-problem i had, which was simpler as thought.
Before i got the solution, i installed the package luci-app-lxc via reForis webUI which includes some more lxc-packages like lxc-config, lxc-attach and so on.
I thought, that would be enough. But today via luci i enabled the lxc-container extension and after that it worked on reForis (no idea why it has setup on luci too). But hey, all my container are running now.


after alot of tries to upgrade via webui automatic updater and by ssh-shell from OS 5.4.5 to 6.x every tries ended up into reboot loops and reset to 5.4.5 (latest running schnapps version).
This morning i wanted to login to work at homeoffice but saw again reboot loops (i am really sure i disabled automatic updater) - so i tried to reset again to 5.4.5. But the router still got the reboot loops.
I had to copy the latest version (https://repo.turris.cz/hbs/medkit/omnia-medkit-latest.tar.gz) onto my usb-stick and reset into usb-recovery mode which set up the factory OS version 6.0.3.
What a luck i got a backup of the /etc configs (wifi, firewall, dhcp and so on) and could set up all base settings from this backup version.
Now i can get into the web again and the firewall settings are all like before as first impression.

But what i am wondering about - why is luci-lxc not set up by default again ?
I had to install the luci-lxc packages manually, which isnt a problem so far - but i cant create a container yet with any OS (it still show the button “create”). And my container i made before with version 5.4.x are not accepted to start with lxc-attach -n . Really weird. I guess i have to checkout the logs when i get more time to do so (probably 6.0.4 will resolve it).

Maybe someone here have an idea whats going wrong withg lxc on OS 6.0.3 or what to do to get it running again.


Zero problems with the MOX classic here after 6.0.3 I do wonder , was the solution to the reboot/cold reboot issue just that simple line of ‘performance’ configcode ?


No I didn’t find any solution yet but it may be related to some configurations.

Wow that was a long update… from 6.0.1 to 6.0.3 required 3 reboots to get a stable system, over 15 mins of “Moving /srv/www/nextcloud/” and various other files (I dont use nextcloud!) and then the PPoE refused to come back up (complaining about no ppp) and no LXC until on the third reboot, all happy again now!

I was just about to roll back when I decided on a 3rd reboot ‘just in case’ !


This topic was automatically closed after 20 days. New replies are no longer allowed.