Turris OS 5.3.6 is out!

Am I right to assume that this mostly affects networks that configured advanced VLAN usage on the switch/LAN ports? Since I only use VLANs on eth2 for WAN, do I need to prepare for big issues when switching to TOS6? (Having configured DSA on a different router I feel the pain, yes DSA clearly is the only available way forward for OpenWrt, but we are still a bit in the rough in the conversion; and the defaults are not as helpful as they should be*).

*) I think that OpenWrt should default to using a VLAN with bridge-vlan-filtering on br-lan, as otherwise anybody splitting up br-lan into different VLANs will run into the issue of loosing access to br-lan when committing the change. But this is probably not the right forum to whine about OpenWrt :wink:

3 Likes

I configured automatic updates with approval.
I configured “Automatic Restarts After Software Update”-delay to 3 days.

I expected the usual “restart is needed” notification. (And automatic restart after 3 days.)

But my Omnia just restarted immediately without any warning.

PS: Thanks for information about TOS6.

Yes, you are right.

TL;DR/offtopic

This usage doesn’t invoke DSA. DSA is only invoked when VLAN-traffic is transported between switch-ports without passing the CPU - your internet-traffic passes your firewall and your sqm…

1 Like

Could be that only network was restarted? I lost connection to my lxc container, but uptime is 33 days and running kernel is still the previous one.

root@turris:~# uname -a
Linux turris 4.14.264 #0 SMP Tue Feb 8 00:42:25 2022 armv7l GNU/Linux

root@turris:~# uptime
21:34:17 up 33 days,  1:31,  load average: 0.07, 0.13, 0.21

Omnia with LXC and MWAN3 (for load balancing two lines) and MOX with LXC went smooth. No problems. Everything was up again. Only Problem: MOX needed a power cycle to reboot.For me it is not a real problem. The MOX allready has reboot-issue-workaround-v4.

Just collision info … I removed tcpdump-mini

Updater failed: 
[string "transaction"]:327: [string "transaction"]:151: Collisions:
• /usr/sbin/tcpdump: tcpdump-mini (existing-file), tcpdump (new-file)

MOX classic 512 MB, simple config, branch HBS, after upgrade to 5.3.6 LED config section in LuCI empty, even though there was an entry for RED heartbeat LED before.

EDIT: moreover, cron table for root disappeared as well :frowning:

From your post, it is not clear to me if it was solved by removing tcpdump-mini or not.

  • If not, feel free to reach our customer service department.
  • If yes, then this issue was already mentioned here.

Upgrade TO 1GB 5.3.5 to 5.3.6 worked without issues.

I’ve also lost connectivity to my LXC containers after update has been installed, but after a reboot LXC containers are working fine.

At that time, I was returning to an older image, other update processes were underway - the last mentioned error message was announced today at 9:07 AM.

Yes, I didn’t search the forum, I have to improve. The last mention of this error was in November 2021 … Tcpdump updater error. For me, the problem manifested itself only now in the course - 6 alerts during 22-23. March.

Every update from version 5.3.6, follectd is installed and … weeds syslog of a lot of records
collectd [32747]: Available write targets :: [none]
I always have to retry uninstall follectd

==
Otherwise, the syslog has been nicely cleaned of permanent unnecessary errors :slight_smile:

No, at least on omnia, switch configuration is broken from factory: Omnia + TOS 6.0 (HBL): Switch configuration broken (#336) · Issues · Turris / Turris OS / Turris Build · GitLab

In one direction, it kind of works as a hub, not switch, right now (with all performance implications)…

MOX A+D TOS 5.3.5 smooth upgrade.
Approval is enable, when I approved the upgrade it rebored right away, without prompting, did you change that behaviour?

However, this was the first time since TOS 5.2.0? I did not need to unplugg power to get it up again. Nice!

(No fw reboot workaround installed)


This does not look good. Should I do something about this?

I double checked that, uptime was reset to zero, new kernel running. In my case Omnia rebooted immediately without any warning. Also notification just contained the change-log, without any further information, no “installation was succesfull”, just the plain list as present in the first post.

Same experiance with my MOX

My Turris Omnia also rebooted immediately after update even though there are 7 days restart delay set.

Additionally following error showed:

Updater failed:

runtime: [string “requests”]:430: [string “utils”]:422: Unable to finish URI (https://repo.turris.cz/hbs/omnia/lists/pkglists/openvpn.lua): Download failed: Couldn’t resolve host ‘repo.turris.cz’

You are lucky. Both of my MOXes hangs as usually (v4 workaround installed).

This topic was automatically closed after 6 days. New replies are no longer allowed.