Turris OS 5.3.3 is out!

Dear Turris users,

Since this week, there was released Turris OS 5.3.3 into the Testing branch. Now, it is released to everyone! :wink:

There are just a few things fixed.

  • Fixed network configuration in medkit for Turris Shield
  • Updated Knot Resolver

You will be automatically updated to this version shortly. If not, check reForis for more details.

We appreciate as always feedback regarding this release.


List of known bugs:

Turris HW known bugs:

  • In some cases, Turris MOX and Turris Shield are not correctly rebooted.
    You could try to remove the power supply and plug it back. We are working to have the solution with the manufacturer of SoC (Marvell). In the meantime, you can try this workaround.

All routers:

  • Cosmetic issue:
    Mismatch of different Turris OS versions in /etc/turris-version and /etc/openwrt_release .
    This is caused that package base-files was not updated. This package is versioned as you can see here by using two variables PKG_RELEASE and VERSION . PKG_RELEASE is stated in Makefile, but REVISION comes from commit hash of openwrt-19.07 branch. This was not changed during 5.3.2 and 5.3.3 . You can compare it on repo.turris.cz, where you go to HBS and HBT folders and check git-hash file.

Omnia update went fine. Mox Classic did not rebooted after upgrade. I had to pull out the cable and plug it again.
I forgot to mention, that the workaround (v4) was applied before this update and the Mox was rebooted before update too. So the workaround did not fix the issue of failing reboots after upgrade.

Turris Mox 5.3.3

  1. I used a workaround.
    For me, the reboot problem is not solved.
  2. There is an incorrect version in the banner file.


The firmware installation is probably not correct.


Oh, I think @jada4p mentioned that in the testing branch. It is known issue and happens from time to time. I added it to the known bugs! Thank you.

1 Like

Both problems are known… as to incorrect version in banner, see Turris OS 5.3.3 is in the testing branch - #3 by cynerd, as to reboot proble, it remains open in spite of some attempts of its solution, see “List of known bugs” above :wink:

1 Like

Wifi dissapeard again on Turris 1.0 (update from 5.3.1 → 5.3.3).

Seems that wireless config file is fully erased everytime (empty = 0 Bytes). After filling it from backuped file, wifi is recognized and shown in LuCI and can be managed in reForis again.

But (!) after power loss it was erased again. Maybe power loss or restart came too soon after the update, it is weird.

Is there some recommendation, for how long not to touch anything after update, to make it fully OK?

Update on PAB(WLE1216v5-20) went off again without a hitch as well as reboot. As this is the second in a row I will try activating automatic updates :slight_smile:
Update on A(SDIO)B(WLE900VX) worked, but reboot still needed physical interaction. So I installed reboot-issue-workaround-v4 and already the first reboot (for this workaround) succeeded.

Me too. It’s never ending story. At first, only one MOX sometimes got stuck, but in the last year both have always hangs reliably.

I have updated my Omnia from 5.3.2 to 5.3.3, but I have not been asked to reboot.
Is this intentional?
How can I check if a restart is planned after update?

I am asking because I have not been asked after the last update, too. Instead my Omnia was rebooted after 3 days or so automatically.
I have configured updates to be installed after approval. (“Update approval needed”)

Login still says TurrisOS 5.3.2.
reForis info page says TurrisOS 5.3.3.

No kernel update = no reboot
A bit different from windows :slight_smile:

Depending on what’s being updated, I sometimes do reboot on my own - in cases that I use features which were updated… just to be sure that updated files are actually used :wink:

My last experience is TOS 5.3.1 (kernel update), but topic is closed now.

Mox a+d simple conf
Update from 5.3.2 → 5.3.3 went smooth
No need to reboot so I have not tested the ”reboot freeze issue”

Thank you team!

well, HAAS stopped working after the update, restarting HAAS did not solve it, so i had to remote (VPN) reboot a MOX classic. Lockup. So needed a trip to the location to pull the power.
Also had the v.4 mod placed, but this seems to be never solved?

So, waiting for the omnia 2022, so i can put the mox in the shredder :slight_smile: or use it as a wifi AP.

No way. This is not happening. You should check your configuration first. There is something wrong, and we are not touching Wi-Fi configs anyhow in fixup releases. Your Wi-Fi configuration was configured in re/Foris or LuCI?

Sometimes, it is required to slightly modify Wi-Fi configs due to changed syntax in newer OpenWrt versions, but we always say it in advance before it reaches stable reache.

You can send us diagnostics to take a look, what is wrong with your configuration.

WiFi config was default one - just added password for wifi network in reForis.
After the update, error in reForis (reset wifi settings didn´t helped), wireless network completely dissapeard from LuCI, wireless config file was empty.

After it has completely dissapeared from LuCI, I had to fill wireless confg file manually. After that, I was able to reset wifi settings in reForis and configure wifi network via reForis.

I have then tested, that everything is working and turned router off, to move it to another place. After turning it on, no wifi in LuCI again…

This topic was automatically closed after 20 days. New replies are no longer allowed.