Turris OS 5.3.2 is out!

Dear Turris community,

Since Monday (6th December), we have released two RC versions of Turris OS 5.3.2 with important fixes for migration for users who are still using the old stable version of Turris OS 3.x. Afterward, we will trigger another wave for Turris Omnia routers because it will allow us to focus on developing new things and declare that version as End-of-Life (EoL).

But this release is not just about fixing stuff in the migration process. We bring essential security updates and various fixes for current users as well.


* Security update: MariaDB, icu
* Updated: Knot Resolver, unbound, lighttpd, msmtp, syslog-ng, libpaho-mqtt-c, libsass
* And many improvements for the migration process from old stable Turris OS 3.x.

This update will be downloaded and applied automatically. If not, I suggest you check reForis to approve the update.

If you found any regression, don’t hesitate to reach our technical support department.

We appreciate any feedback regarding this release.


Everything went ok. Even during my work with the PC. Thanks.

1 Like

Mox a+d simple conf smooth upgrade.

Thank you team!

1 Like

The Update of my Omnia von 3.11.23 to 5.3.2 was smooth and automatic. Just an interruption of about 2 minutes for the reboot, LXC-Containers, mwan3 configuration (load balancing and fail over with two lines) and tinyproxy configuration were changed and everything worked fine.

The Update of Mox vom 5.3.1 to 5.3.2 worked without reboot. .


After the update from 3.11.xx to 5.3.2 was smooth and automatic except for the problem with the certificate to set SSL for as the system states for the Turris certificate “This CA root certificate is considered untrusted because it is not stored in the CA’s trusted root certificate store.” (Tento kořenový certifikát certifikační autority je považovaný za nedůvěryhodný, protože není uložen v úložišti důvěryhodných kořenových certifikátů certifikační autority.)

// Asked in separate thread:

Updated MOX PAB(WLE1216v5-20), dump AP-configuration: No issues.

And, for first time at all, my MOX restartet without the typical reboot hang! :partying_face:
Let’s see if the update MOX AB(WLE900VX) 5.3.1->5.3.2 will also positively suprise me. That would get me close to unleashing automatic updates! :closed_lock_with_key:
edit: Answer for second MOX below.

1 Like

Turris 1.1 seems to be ok even openVPN :slight_smile:

1 Like

I confirm the observations from ssdnv or rwg on the MOX, whereby in this case the automatic upgrade to 5.3.2 did not require a hard manual reboot… a good surprise as I haven’t even updated the firmware to the version that is supposed to fix the reboot problem.

2x TurrisOmia upgrade from 3.x to 5.3.2 working.
But one Turris have mSata disk (240GB - with set one partition 100GB) which is connected as /srv, was formated during upgrade => all user data for FTP share lost (/srv/vsftpd/$USER).
There were only data backups on the formatted disk, I will have to create new ones.

I have to withdraw my positiv feedback - my MOX A(SDIO)B(WLE900VX) needed a power cycle to come back to live after the update 5.3.1->5.3.2. :-1:
So either it was simply luck why my MOX PAB(WLE1216v5-20) rebooted fine or it has something to do with the SDIO-module (or the WLE900VX or… maybe the moon phase :zipper_mouth_face:).

Check what is mounted as /srv. Especially if it is a subvolume or there are any subvolumes.
Mine update 5.3.1 to 5.3.2 on two Ominas was smooth (one with lxc and lots of other thingns, one with OpenVPN server only).

I checked it 5 times, only one partition on mSata disk exist and after upgrade is conected to /srv, and IMHO partition was formatted during upgrade. But as i sayed, it was only backup data => i made new backup copy.