Turris OS 5.2.6 is released out!

I had a snapshot saved in form of a medkit that contained all of my config. I tried to flash it with that but that failed. I then flashed it with the latest medkit (omnia-medkit-202108260508.tar.gz) and that worked, but now my config is obviously gone. Is there a way I can extract config from the old snapshot and load it up in my newly flashed Omnia?

See schnapps document Schnapps - Turris Documentation - you can mount your schnapps and extract all you need from it…

MOX A+D

Needed to cut the power as mentioned by pepe. Other than that everything ok.

Thank you team!

I doubt I’ll see this update for a while, since August 26, 2021 12:37 PM I’ve been getting the following:

Updater failed:

runtime: [string “requests”]:430: [string “utils”]:420: Getting URI (https://repo.turris.cz/hbs/omnia/lists/pkglists/3g.lua) failed: SSL certificate problem: self signed certificate

Is this something that needs fixing on the repository side of things or something I can fix locally?
(Turris OS 5.2.5)

By any chance, could it be the same mistake as in here? Turris Omnia 3.11.23 updates broken (claiming server certificates are self signed) - #6 by Nafets

1 Like

Yep - exactly that (added as the repo kept being unresolved some time ago!)

Removed and updates now looking for approval :slight_smile:

I hope its not some Turris backdoor…

Yes, I’d say so. I think it is called somehow like serial connection. I can not remember the exact word… :stuck_out_tongue: Maybe even RMA or sending the router to us? Who knows.

I’m happy with this update. Omnia seems way more stable, less cpu usage compared to previous versions. Overall a great impression of its performance.

Same problem here. First server errors from the webinterfaces (Foris, LuCI), now bootloop. I’ve just contacted tech support. Wasn’t even tinkering with it, only set up an LXC with Kali from the official repo, on an mSATA storage that has been installed a year ago. It broke down 12 h later, when i did nothing but browse the web. With all due respect, a (supposedly) stable OS update (which installs itself automatically) should not brick a $400 router like that. I was in the middle of an online python course, now connected over mobile data as well (flat rate, luckily). How did it turn out for you?

Can you tell us something more about the server errors from Foris and LuCI? It is unusual to happen for both. Are you sure that the LXC container was installed on the mSATA SSD and not using internal storage? You didn’t experience any power outages recently, right? How long do you have your router? Because I briefly looked at your diagnostics to confirm if it is HW or SW related, and it seems related to HW in your case, especially to the internal storage as something is going on with eMMC.

I am sure that our technical support department will handle this and tell you more on Monday.

Dear Pepe,

I have my router now for 2.5 years. The server errors were code 500 for ReForis and undefined text outputs for LuCI (looked like paths to missing files, didn’t take a screenshot, unfortunately). Pretty sure LXC was installed on the mSATA, because i set it with the built-in storage module. No power-outage either. I now had to flash from a usb thumb drive, and it’s working again (for now).

Btw, the previous LXC with Kali Linux was still there, after i flashed the OS and re-selected the mSATA SSD for /srv. Hence, it could not have been on the internal storage.

Wow, this is true! My torrents were capped at 7 MB/s on previous versions.
Now I am able to reach 30 MB/s

1 Like

So I had to reflash my Omnia 2 previous snapshots back, because my latest backup snapshot had the same bootloop effect unfortunately. Everything now more or less works.

Also, I think I may have figured out why the static lease list got wiped.

I was configuring my Omnia in a network which already had a main router, and in order to avoid conflicts I configured its DHCP server to have a different network address. So main router was 192.168.1.1/24 and as such I configured the Omnia to be an automatic DHCP client on its WAN port, but have its DHCP server be on 192.168.2.1/24 (I did so in ReForis → LAN → Router IP address)

In LuCi however, I could specify static leases already with the intended network address. Once I did so (and of course saved the config in LuCi), I then disconnected the Omnia from its WAN port and configured the intended router IP in ReForis → LAN → Router IP address. This seemed to wipe the static lease list that I could view in LuCi.

I reliably reproduced this only once, but now I don’t have any opportunity to do so (since I’m using the Omnia as my main router), so perhaps this could be a bug.

This Turris OS 5.2.6 announcement claims a new kernel. That kernel is 4.14.243. It is nearly 4 years old, having been released Nov 12, 2017.

Since that time Linux’s networking has added LOTS of improvements. Will we ever see those, either via backports or via a major kernel upgrade?

My guess is that TOS will inherit a newer kernel once it is based on OpenWrt 21.02, since TOS 5.2.X is based on the OpenWrt 19.07 series, kernel 4.14 is expected, 21.02 should move that up to 5.4. (OpenWrt wants to switch to 5.10 soon, but I guess TOS will take some time before it follows, so 5.4 ist the more realistic option in the near future). If you feel adventurous I believe that switch-branch hbd should get you a newer kernel (but also something probably too bleeding edge for production use)…

P.S. Kernel 4.14.243 was released 2021-08-08. (But I get your point, the 4.14 series is in long term maintenance mode where bugs are still fixed but new features are not added).

3 Likes

This topic was automatically closed after 20 days. New replies are no longer allowed.