Turris OS 5.1 is out

Yes, that # got lost in posting.

But it is put just below the #!/bin/sh ?

Syslog shows no error now :)…yet.

edit, works! Thxs!

Aug 28 21:01:01 turristhuis sentinel_nikola: Logrotate took 0.087390 seconds
Aug 28 19:01:01 turristhuis crond[14366]: (root) CMDOUT (Logrotate took 0.087390 seconds)
Aug 28 21:01:02 turristhuis sentinel_nikola: Syslog parsing took 0.219289 seconds
Aug 28 21:01:02 turristhuis sentinel_nikola: Records parsed: 310
Aug 28 19:01:02 turristhuis crond[14366]: (root) CMDOUT (Syslog parsing took 0.219289 seconds)
Aug 28 19:01:02 turristhuis crond[14366]: (root) CMDOUT (Records parsed: 310)
Aug 28 21:01:02 turristhuis sentinel_nikola: Sending records took 0.004145 seconds

Yes that’s correct, just below #!/bin/sh

The cron only runs once every 15 minutes so you won’t see if it worked until then.

1 Like

I also like to mention this line that keeps popping up… any idea?

turrisXXXX haas-proxy-start[20570]: 2020-08-29T09:30:18 CRITICAL twisted ‘channel open failed, direct-tcpip is not allowed’

you must have installed the SSH honeypot (haas-proxy) This puts a fake SSH endpoint for people outside your network to try to login to, attempts to login to this are logged and sent to nic.cz so they can analyze patterns of people attacking Turris routers. Warning is harmless, just means someone is trying to connect to the proxy in a way it doesn’t support.

yes, installed it, including token. Works by the way. And i also see there was a 2 year old github ‘bugreport’ that mentioned this.


I had a same issue with mdadm as you had. Nevertheless now works fine…

If you have update approvals then you have to approve it twice because of package list reorganization we did. Initially update is unaware of some of those packages so it removes them but subsequent update request should install them back.

Any word on the auto update from the 3.x branch yet?

You can trigger migration if you want. There are blockers still before automatic migration is released.

1 Like

Thanks. Just did the migration and it went great.

1 Like

Same here, haas-proxy service was not enabled after update to 5.1. I enabled and started it, and got the same error as you.

Btw. there were more services I had to do this for: kresd, adblock, samba4

yep, but strange enough did adblock run after update on the TO, but not on the mox. Solved it by just activating all by hand.
What i find strange is that for example pakon is only to be seen in foris, but not in reforis. But i assume all this get fixed over time, as usual.

thxs cynerd for adjusting the postings, i always forget how to make those :slight_smile:

Is there a 5.1-based medkit? I’m still on 3.x and would like to try a clean install soon.

Yes, there is a medkit for each version. It can be found on repo.turris.cz and it is mention in our documentation.

FYI the documentation contains a link which results in 403 forbidden (https://repo.turris.cz/hbs/medkit/omnia-medkit-latest.tar.gz). And none of the medkits mention a version; just a date.

Yeah, it’s a known bug, which we are working on.

1 Like

Are there instructions on how to switch the drivers manually? reForis’s Wi-Fi page doesn’t work for me as I have customised my network substantially.

Anybody is facing issue that folders shared by samba are not accessible after the upgrade on Turris Omnia? Have not touched samba settings from the day I have installed version 5 but have found yesterday I`m not able to access shares. Two notebooks but as well android phones. USB disks are accessible (Plex works perfectly, through SSH I see all the data).

Edit : I can see samba4 being disabled in Luci (system/startup) and cannot start it

Edit 2 : after running pkgupdate (no update of any package, just four packages mentioned as ignored and there has been at least two reloads previously after upgrade) I`m able to enable samba4 and shares are accessible.

Hi @pete,

Could you please let us know which device do you have? I see that you did it manually, but reboot or running pkgupdate again didn’t help you?

It’s Indiegogo Omnia 2gb, w/ NAS.

I did not try rebooting or running pkgupdate. The device got rebooted on Sunday morning @ 3.30 am.

Strange thing is that I received another email about kernel being upgraded on Sunday afternoon - and this triggered another reboot.

I have the logs stored on /srv for all those days, if you care to go through them, I can surely provide them.