Turris OS 5.0.1 is released!

Another try with opkg install wget, if that fails download the package from repo https://repo.turris.cz/hbs/omnia/packages/packages/wget_1.20.3-4_arm_cortex-a9_vfpv3-d16.ipk and install with opkg

It seems to be present

/bin/wget https://repo.turris.cz/hbs/omnia/packages/packages/wget_1.20.3-4_arm_cortex-a9_vfpv3-d16.ipk

Downloading ‘https://repo.turris.cz/hbs/omnia/packages/packages/wget_1.20.3-4_arm_cortex-a9_vfpv3-d16.ipk
Connecting to 217.31.192.69:443


but this fails . . . . not sure what is going on here . . . do I have two versions.

/usr/bin/wget https://repo.turris.cz/hbs/omnia/packages/packages/wget_1.20.3-4_arm_cortex-a9_vfpv3-d16.ipk

Error loading shared library libssl.so.1.1: No such file or directory (needed by /usr/bin/wget)
Error loading shared library libcrypto.so.1.1: No such file or directory (needed by /usr/bin/wget)


Ouhm, pointed to wrong device tree in the repo - O instead of M (different arch) https://repo.turris.cz/hbs/mox/packages/packages/wget_1.20.3-4_aarch64_cortex-a53.ipk

Also uninstall wget first and use uclient-fetch for the download

Ok thanks. Will talk soon. . . . retiring for the night now. Cheers

Update: Install of wget using uclient-fetch resulted as below. From memory I installed the acme package while attempting to solve the typical Firefox encryption warning. Now it is removed.

What do you think about this discussion? - it talks about these packages.

uclient-fetch https://repo.turris.cz/hbs/mox/packages/packages/wget_1.20.3-4_aarch64_cortex-a53.ipk
Downloading ‘https://repo.turris.cz/hbs/mox/packages/packages/wget_1.20.3-4_aarch64_cortex-a53.ipk
Connecting to 217.31.192.69:443
Writing to ‘wget_1.20.3-4_aarch64_cortex-a53.ipk’
wget_1.20.3-4_aarch6 100% |*******************************| 211k 0:00:00 ETA
Download completed (216180 bytes)
root@turris:~# opkg install wget_1.20.3-4_aarch64_cortex-a53.ipk
Installing wget (1.20.3-4.0) to root…
Configuring wget.
root@turris:~# pkgupdate
INFO:Target Turris OS: 5.0.1
line not found
line not found
line not found
line not found
line not found
line not found
line not found
ERROR:
inconsistent: Package acme requires package wget-ssl that is not available.

Both seem to have broke for me on my Mox. I presume it was the update anyways, not sure since the Foris login page directs to a “503 Service Not Available” on the IP/foris/config/ and Luci while it works returns a: “Error: logfile not found!” for System Log. Wired connections fortunately still works at least. Will probably disable automatic updates given how botched the router now seems to be and try to reflash to 5.0.0 or something.

Edit: Alas, I can only find the 6/15 (5.0.1) firmware, not whatever one was prior on https://repo.turris.cz/hbs/medkit/

Do you think uclient-fetch is the way to go?

After installation wget reports

wget

Error loading shared library libssl.so.1.1: No such file or directory (needed by /usr/bin/wget)
Error loading shared library libcrypto.so.1.1: No such file or directory (needed by /usr/bin/wget)
Error relocating /usr/bin/wget: OPENSSL_sk_value: symbol not found
Error relocating /usr/bin/wget: SSL_CTX_set_default_verify_paths: symbol not found
Error relocating /usr/bin/wget: MD4_Update: symbol not found
Error relocating /usr/bin/wget: TLS_client_method: symbol not found . . . . . snip


It seems that something gone awry during

since those library files are provided by the libopenssl package which though is available in the repo but appears to be mysteriously absent on your node.

I would suggest to rollback via schnapps to the snapshot taken pre-installation of TOS5.x and start from there again, else you might end up with some issues that will be difficult to debug later on, after the rollback (mind rebooting):

  • remove wget and acme (make sure they are not present in /etc/updater/conf.d/user.lua)
  • go through the update process (hopefully without errors then)
  • reboot after the update process completes
  • attempt to install acme again - if it throws an error then again notify the OS vendor through applicable channels (email or GItlab)

Many thanks for your input.

This message appeared but should not stop the update . . .

root@turris:~# opkg remove acme
Removing package acme from root…
Not deleting modified conffile /etc/config/acme.
WARNING: You probably just removed a package that was installed as part of a user list or the basic system. This package will return durring the next updater run. We suggest you disable the user list instead.

Not sure about the user list. I will leave this for now.

Is a list of packages being installed by request of the user, specified either in

  • /etc/updater/conf.d/user.lua, or
  • /etc/updater/conf.d/opkg-auto.lua

The point of removal is that acme not getting automatically re-installed during the

and therefore you should not

but make sure that the package is not lsited in either of the a.m. files prior initiating the update process.

Done! Turris Mox is running 5.0.1 Yay . . . .thanks for your help with this.

I am still working on my Nextcloud - but that is ongoing . . and another post.

Cheers

1 Like

For anyone dealing with WiFi down issues, here is how to revert to a last known working firmware until 5.0.x gets fixed:

  1. Open terminal/console
  2. Enter ssh root@[router IP Addr]
  3. Enter schnapps list. This will return a list of numbers. Find one that pre-dates 2020/06/15 (5.0.1 release)
  4. Enter schnapps rollback [number]
  5. Power reboot your router by unplugging power for 30 seconds, plugging back in. Using the reboot option from Luci UI likely won’t work
  6. [Optional] Make sure to either disable automatic updates, or set it to require approval to prevent from going back to bad firmware
1 Like

I ended up rolling back to 3.x and no issues. Will wait till 5.x becomes more stable.

I am still on Turris OS 4.0.5 on my mox Classic and i would like to update to 5.0.1
Unfortunately auto-update does not do anything. How can I manually trigger the update?

Edit: SSH and pkgupdate triggered the process.
However, I install and altearntive Atheros drivers. need a way to fix this.

`DIE:[string "transaction"]:328: [string "transaction"]:153: Collisions:/lib/firmware/ath10k/QCA988X/hw2.0/board.bin: ath10k-firmware-qca988x-ct-htt (existing-file), ath10k-firmware-qca988x-ct (new-file)Aborted`

Ok I just reversed the installation process
opkg update opkg remove ath10k-firmware-qca988x-ct-htt opkg install ath10k-firmware-qca988x opkg install kmod-ath10k

Turks 5.0.1 is installed but I have problems with some menu pints in foris (e.g.DNS)

Error: 500 Internal Server Error

Sorry, the requested URL ‘http://192.168.11.1/foris/config/main/dns/’ caused an error:

Template ‘config/dns.html.j2’ not found.

Fixed it by executing pkgupdate on CLI again.