Turris OS 4.0 is out!

In my case, Debian container created in 3.x works in 4.x
It only requires some config changes.
If You do not want to create new container only for check current config file format - post me a PM

Here you go. We are going to release another RC of Turris OS 4.0.1 tomorrow, where it will be fixed.

1 Like

Well, installed from scratch. Trying to setup Nextcloud, but I am unable to add shared HDD´s from Turris NAS there. External storage app is empty without any options…

Those are configured external storages. Go to Settings / External Storages to configure new ones.

The same screen is displayed in settings…

IT seems that actual medikit package for 4.0 is not working as Update. Connection is recognized with addresses but there is no handshaking for establishing Internet Connection following?! (Ethernet cable).
Interferences come from IP 0.0.0.0 and 1.0.0.1 and
fd5b:8e9d:1dd::1,[192.168.2.1]. This Blackhat is making update impossible.
I dont know if medikit package is corrupted.

I don’t know what kind of interference you have in mind, but FYI 0.0.0.0 is not a valid address (it’s a wildcard), 1.0.0.1 is borrowed by Cloudflare for DNS resolver, and fd... and 192.168... are not routable through internet (i.e. they are local).

In the Administration part, not the user part. You should have this:

If you click “allow users to mount external storage”, you’ll get this in the user part as well (not mandatory).

Your latest medikit package of today Friday, downloaded at about 18:33 CET - does not work to be flashed. Ethernet with cable is recognized but is not establishing Internet Connection?! Have checked anything.

Last Thing I Check now, is if there is a Malware in area of network Manager. (Solus 4.0 here)

With due respect it seems, reading also Update issue howto...?, that there is rather a bit of a struggle to make the transition to TOS4x. with medkit, rather than being a medkit issue in general.

Perhaps it would be better to continue in the other thread and describe more detailed/specific of what the issue is. It likely would achieve better input/help return from forum members.

Have done this :

Downloaded medikit latest package with size of 35,1 MB.
Went sudo su on my machine and then in terminal called nautilus as root.
Plugged in the usb-stick (ext4) and copied the medikit.tar.gz file to usb-stick with nautilus.

no error-report so far. I switched on internet-modem and waited until boot is finish.
then I switched on turris omnia device and waited after boot is finish - plugged in usb-stick into front sided port. Pressed then the reset-button at rear side until 4 LEDS went red-orange and released the reset-button. Flash went normal and in the end are then 4 white LEDs shining. Duration was about 5 minutes. Then I rebooted turris-omnia and waited if there is an online update patch for 4.0 (because of 4.0.1-release). But there was no online-update of 4.0 for 4.0.1 - (I dont know then if auto-update is disabled ?)
It seems that Flash went alright, but ethernet is not working.
malware-test was negative. there is no virus or malware.
Internet-connection is recognized with all addresses - only in the end of recognition there seems to be lack of hand-shaking for establishing internet-connection ?!

Sorry for my English. (I know only German, English and Sign-Language and somewhat Latin.)

Yeah - Blackhat is hiding behind 0.0.0.0 or behind 1.0.0.1 - because immense traffic there makes him invisibly …

IT is chaotic at present…

1.) Internet Interferences at several Providers.
2.) Mozilla Firefox confirmed several Bugs in Download Feature of Firefox.
3.) so it is a Java Thing at moment, so Chrome Has These bugs too?
4.) better wait a few days until Chaos is over.

For me is not working creating LXC container, from cmd and also from GUI. It create folders, but then nothing happens.

I tried to create and start LXC from cmd, it ended with this:

root@turris:/srv/lxc# lxc-start -n monitor
lxc-start: monitor: lxccontainer.c: wait_on_daemonized_start: 842 Received container state "ABORTING" instead of "RUNNING"
lxc-start: monitor: tools/lxc_start.c: main: 330 The container failed to start
lxc-start: monitor: tools/lxc_start.c: main: 333 To get more details, run the container in foreground mode
lxc-start: monitor: tools/lxc_start.c: main: 336 Additional information can be obtained by setting the --logfile and --logpriority options

What about “run the container in foreground mode” “To get more details

Probably you have bad config.

Dear @miska

I have Turris MOX, these versions:
foris version: 100.4
Powered by LuCI branch (git-19.268.83312-f61c49b) / TurrisOS 4.0 87d5791

How to upgrade (better without losing current configuration) to this release of Turris OS?
I didn’t find any manual for it, instead of from scratch installation via medkit.

Thanks for a help.

It is freshly flashed TO.

If you haven’t disabled automatic updates and your MOX is connected to the Internet, it will update automatically.

From CLI, you can make sure that you are up to date by running command pkgupdate.

Looks like problem with LXC was fixed by last update.