Turris OS 4.0 beta5 is out!

Dear Turris users,

We released a new beta version of Turris OS 4.0. This beta 5 release is for Turris MOX and Turris Omnia routers.

Release notes:

  • Initial support for Nextcloud setup from Foris
  • Storage plugin is now part of the base installation
  • Added CESNET feed with Nemea
  • znc: CVE-2019-12816
  • Fixed kernel panic sometimes occurring on Omnia

When you were using our previous release (Turris OS 4.0 beta4), you should be updated to this version automatically within a few hours.

If you would like to give it try on Turris Omnia router, which is running Turris OS 3.11.5 release and would like to start from scratch, you will need to download medkit and by using re-flash method, which is described in our documentation. It will erase all your data including settings or you can use schnapps, which is a tool for snapshots.

Enjoy the release and we appreciate any feedback regarding this release.

Known bugs:

Turris Omnia specific

  • Second CPU ethernet port to switch chip is disabled, only one of two ethernet ports between CPU and switch is in use.
  • Old version of libmariadb when using Nextcloud from Turris OS 3.11.x. Will be fixed in beta6 release.

Turris 1.x specific

  • Currently not working because of kernel issues. Please do not test this release on Turris 1.x.

No errors during upgrade.
LXC works, usb z-wave dongle works, openvpn - clients does not work (ping from router - ok, ping from host in lan - destination unreachable).

finally working!!! well i can log in to my omnia and set it up, however i do not get an internet connection. unplugging the sfp module & reinserting it generates zero kernel messages.

anyone else having trouble using a fiber ftp module? anyone got a working one?

jep, using a borrowed fiber to lan converter and attaching that to the GbE WAN port it’s working!
created an issue : https://gitlab.labs.nic.cz/turris/turris-build/issues/60

Are you referencing to this thread?

Yes, this one.
Full report has been sent to tech.support.
I believe there is something wrong with firewall, but I’m not able to fix it.

are you aware that you manually have to activate the sfp port, automatic switching wan (ethernet) <> sfp does not work in the beta

MOX after restart was inaccessible. Manual restart helped.

German language removed, “Prepare token” button still not working.

nope didn’t know that. it’s not documented anywhere…
how can i manually activate the sfp port?

EDIT: searching through the older alpha topics i see this was already mentioned, however i can’t find where it’s explained how to enable the sfp port…

EDIT2: the necessary command to switch wan to sfp is ln -sf armada-385-turris-omnia-sfp.dtb /boot/dtb && reboot

which Browser do you use? Try Firefox

Chrome and Edge, I won´t install other browser.

I had the same Browsers and Problems…
Then I testet Firefox an there it works.
Firefox isn´t so bad…

I can corroborate that it does not work with Edge but FF (staying away from Chrome and any derivate)

Token downloaded via Internet Explorer 11 (Turris OS 4.0 beta5), but I can´t click to “Managed devices” (Turris OS 3.11.5).

With Chrome:

First try (downloaded JSON)

Remote Exception: Internal error not a gzip file('<class 'tarfile.ReadError'>')

Second try (GZipped JSON)

Remote Exception: Internal error truncated header('<class 'tarfile.ReadError'>')

Third try (TGZipped JSON)

Remote Exception: Internal error 'device_id'('<class 'KeyError'>')

Cloud Backups seem to be missing. Are they coming back?
Also wasn’t there a GUI Tab for the Data Collection package?

And do i have to reformat the persistent storage drive on /srv? is it possible to reattach an existing one?

Thank you for your reporting. We were able to reproduce it, and we are looking into it. We created an issue on our Gitlab.

storage plugin does not seem to work… after selecting disk, pressing format & set as well as rebooting i got the following state :

with ssh omnia mount not showing /dev/sda as mounted and /etc/config/storage having some wierd entry :

config srv 'srv'
        option old_uuid '14b35544-0fc8-4e09-881d-e63bce1fd6c6'
        option uuid 'b7aa0ae4-506b-4b51-9926-21ed96c47818'

fixed it by adding the disk to /etc/config/fstab :

config 'mount'
        option  target  '/srv'
        option  uuid    'b7aa0ae4-506b-4b51-9926-21ed96c47818'
        option  options 'defaults,subvol=@'

now it shows correctly in foris :

EDIT: i guess this also answers (in a hacky way) my question of how to reattach the stoarge disk without formatting

I submitted it to Tech Support, but just so it’s recorded here in the public, on an A+G Mox accessing ‘Network Interfaces’ via the guide (after setting mode router) or exiting the guide and going to the page itself results in an error. Also can’t get a DHCP release by my modem for the Mox, not sure if related, but I presume so?

Remote request

{"module": "networks", "action": "get_settings", "kind": "request"}

Stack trace

Traceback (most recent call last):
  File "/message_router.py", line 140, in process_message
  File "/message_router.py", line 40, in wrapper
  File "/message_router.py", line 76, in validate
  File "/validator.py", line 257, in validate
  File "/validators.py", line 348, in validate
jsonschema.exceptions.ValidationError: {'type': 'wifi', 'bus': 'pci', 'state': 'up', 'slot': '0', 'module_id': None, 'link_speed': 0, 'id': 'wlan0', 'configurable': False, 'ssid': 'My WIfi 5G'} is not valid under any of the given schemas

Failed validating 'oneOf' in schema['properties']['data']['properties']['networks']['properties']['lan']['items']:
    {'oneOf': [{'additionalProperties': False,
                'properties': {'bus': {'$ref': '#/definitions/interface_bus'},
                               'configurable': {'type': 'boolean'},
                               'id': {'$ref': '#/definitions/interface_id'},
                               'link_speed': {'$ref': '#/definitions/interface_link_speed'},
                               'module_id': {'$ref': '#/definitions/interface_module_id'},
                               'slot': {'type': 'string'},
                               'state': {'$ref': '#/definitions/interface_state'},
                               'type': {'allOf': [{'$ref': '#/definitions/interface_type'},
                                                  {'enum': ['eth',
                'required': ['id',
                'type': 'object'},
               {'additionalProperties': False,
                'properties': {'bus': {'$ref': '#/definitions/interface_bus'},
                               'configurable': {'type': 'boolean'},
                               'id': {'$ref': '#/definitions/interface_id'},
                               'link_speed': {'$ref': '#/definitions/interface_link_speed'},
                               'module_id': {'$ref': '#/definitions/interface_module_id'},
                               'slot': {'type': 'string'},
                               'ssid': {'maxLength': 32,
                                        'minLength': 0,
                                        'type': 'string'},
                               'state': {'$ref': '#/definitions/interface_state'},
                               'type': {'allOf': [{'$ref': '#/definitions/interface_type'},
                                                  {'enum': ['wifi']}]}},
                'required': ['id',
                'type': 'object'}]}

On instance['data']['networks']['lan'][16]:
    {'bus': 'pci',
     'configurable': False,
     'id': 'wlan0',
     'link_speed': 0,
     'module_id': None,
     'slot': '0',
     'ssid': 'My Wifi 5G',
     'state': 'up',
     'type': 'wifi'}

Non-working buttons in Subordinates and Access tokens tabs on Chrome browsers and some others are fixed in Turris OS 4.0 beta6.

Non-working “Network interfaces” tab in some configurations, which was posted by @snarfel was also fixed in Turris OS 4.0 beta6.

About missing data collection tab in Turris OS 4.x releases. Our previous data collection system uCollect is not available in newer versions of Turris OS as it is going to be replaced by Sentinel. The data-collect package list contains a dynamic firewall, which is not dependent on registration and you’ll get the firewall updates. There are some things, which needs to be done and they can be found here:
https://gitlab.labs.nic.cz/turris/foris/issues/158 most notably WebUI integration.

Can confirm beta6 fixes my network interfaces issue, not getting a DHCP lease from the ISP modem, and not being able to connect to the internet in general.

Edit: Certain things are still broke, although arguably much more minor in comparison to prior issues. Despite being able to connect to the internet now, “Connection test” when ran doesn’t terminate; all four tests have a continuous spin icon for Status. Same issue for “Update time” where it doesn’t terminate and icon constantly spins and never seems to update time.