Turris OS 4.0.1 is out!

Dear Turris users,

We just released a new version of Turris OS 4.0.1 for Turris Omnia routers and as well for Turris MOX owners.

In this release, you can find several packages updated mostly due to security vulnerabilities and fixed issues in some packages, which we sent to upstream. Based on your request, we enabled CONFIG_BRIDGE_VLAN_FILTERING in kernel.

Release notes for this release:

  • include eeprom drive in Omnia medkits (used in some tests)
  • fix reForis dependencies
  • expat: updated to version 2.2.9, fix CVE-2018-20843, CVE-2019-15903
  • python[2,3]: fix CVE-2019-16056, CVE-2019-16935
  • libgcrypt: fix CVE-2019-13627
  • mosquitto: updated to version 1.5.9, fix CVE-2019-11779
  • python-crypto: fix CVE-2013-7459 and CVE-2018-6594
  • security fix for Foris translation
  • unbound: update to version 1.9.4, fix CVE-2019-16866
  • haveged: update to version 1.9.8
  • nextcloud: update to version 16.0.5.
  • python3-pip: fix shebang
  • enable CONFIG_BRIDGE_VLAN_FILTERING
  • kernel: Update to version 4.14.148

If you are using previous version Turris OS 4.0, you should be automatically updated to this version if you are not using approvals. If you do, take a look at Updater tab in Foris.

Your feedback is welcome for this release.

2 Likes

Update for MOX OK. Only reboot problem is persistent :frowning: which is annoying :open_mouth: I eased it inserting switch into power cord, which is also helpful in three (or more) hand problem doing hard reset :slight_smile:

1 Like

same for me … update was ok, but reboot issue persist … :confused:

1 Like

This issue prevent deploy MOX in operation.

Omnia updated to 4.0.1 so far no issues.

Hello everybody,

after having massive problems with TurrisOS 3.11.8, I took the step to TurrisOS 4. After a fresh installation by Reflash method (4 LED) everything worked fine but this message came today:
Updater failed:

runtime: [string “requests”]: 395: [string “utils”]: 427: URI download failed: The requested URL returned error: 404 Not Found

How can I fix this or is the problem not on my side?

Best regards!

2 Likes

I have updated my Omnia to 4.0.1 , but I´am facing a problem with add-on NetBoot for my Mox.
Under 3.11.x Mox was shaky too and I have some experience to get it running, but under 4.0.1 I don´t have luck. After reinstalling “NetBoot-Addon” under Foris I get this Error:

Error from 2019/10/17 12:22:02
Updater failed: Failed operations:

turris-netboot-tools/postinst: udhcpc: started, v1.28.4
udhcpc: sending discover
udhcpc: no lease, failing
Regenerating configuration…
Getting new rootfs…
Downloading ‘https://repo.turris.cz/hbs/netboot/mox-netboot-latest.tar.gz’
Connecting to 217.31.192.69:443
Writing to ‘/srv/turris-netboot/rootfs/rootfs-new.tar.gz’
/srv/turris-netboot/ 4% |* | 1759k 0:00:22 ETA
/srv/turris-netboot/ 100% || 42066k 0:00:00 ETA
/srv/turris-netboot/ 100% |
| 42066k 0:00:00 ETA
Download completed (43075675 bytes)
Downloading ‘https://repo.turris.cz/hbs/netboot/mox-netboot-latest.tar.gz.sha256’
Connecting to 217.31.192.69:443
Writing to ‘/srv/turris-netboot/rootfs/rootfs-new.tar.gz.sha256’
/srv/turris-netboot/ 100% || 98 0:00:00 ETA
Download completed (98 bytes)
Downloading ‘https://repo.turris.cz/hbs/netboot/mox-netboot-latest.tar.gz.sig’
Connecting to 217.31.192.69:443
Writing to ‘/srv/turris-netboot/rootfs/rootfs-new.tar.gz.sig’
rootfs-new.tar.gz: OK
/srv/turris-netboot/ 100% |
| 151 0:00:00 ETA
Download completed (151 bytes)
Cannot open file ‘/etc/opkg/keys//XXXXXXXXXXXXXX’ for reading

Tampered tarball

What is the Problem? Can anybody help me?

I was already on version 4.0.1, I found the mistake why the updater did not work.
Had still chosen the option:

Hardening (experimental)
Seccomp tools for system hardening.

Have this option deselected and the download worked.

Maybe that helps a few!

Best regards!

1 Like

Will OS 4.0.x roll out through the normal updater as well or is a manual install required? I have an Omnia if that matters.

Welcome to the forum :wave:!

To answer your question: Yes a migration is planned from TurrisOS 3.x to 4.x, but still needs some time.
Look here:
https://forum.turris.cz/t/turris-os-4-0-is-out/

I own an Omnia and jumped over Flash method to version 4.0.1.
You can wait a bit or update via the Flash method.

Best regards!

Awesome! I don’t mind waiting, I just wanted to know if manual action would be required :slight_smile:

Thanks! Based on your post, I was able to find what’s wrong. This is going to be fixed in the upcoming release.

//EDIT: This is going to be fixed in Turris OS 4.0.2.

I have problem with Midnight Commander on TOS 4.0.1. Mause not working and in command line
text appears after clicking the mouse on the MC window

4M;4m;4M;4m;4M;4m3;4M83;4M83;4M3;4m3;4M3;4m;5M;5m;5M;5m;6M;6m;6M;6m;1M;1m3;1M3;1m3;1M3;1m;2M;2m

Thanks for reporting this issue to us. We looked at it and it is going to be fixed in Turris OS 4.0.2.

1 Like

HBK changelog

##### News announcements #####
 • added missing hardening package list
 • fixed autodetection of router address in Foris OpenVPN
 • irssi: updated to version 1.2.2, fix CVE-2019-15717
 • sudo: updated to version 1.8.28p1, fix CVE-2019-14287
 • bind: updated to version 9.11.11
 • openldap: updated to version 2.4.48, fix CVE-2019-13565
 • kernel: updated to version 4.14.149
 • libpcap: updated to version 1.9.1, fix CVE-2019-1516{1,2,3,4,5}
 • tcpdump: updated to version 4.9.3, fix multiple CVEs

Hi, I recently joined Turris customers with an Omnia 2019 2GB. It is a product that is really sexy from an aesthetic point of view. Unfortunately, however, I immediately had to work hard to make it work (even if in the end I succeeded). The problem is that updating to Turris 4.0.1 I can’t get my line to work using the SFP connector and activating a WAN interface with the operator’s values. I have enabled the SFP port manually and it is working. The problem I believe depends on the change of the VLAN and the absence of the related settings in version 4. By rolling back to Turris 3.11 everything works as expected, except for an error in Foris where both the WAN check and the DNS fail, but in reality I am connected to Internet. Your DNS is a bomb!
I hope you can improve the software more and more so that even those who use PPPoE on SFP can use Turris 4.

1 Like

@Pepe I have a Turris Omnia connected to my operator’s SFP (TIM Italia), I still have the same problem with all versions of Turris 4.x, including this one. The eth2 interface continues to be not ready and therefore I cannot connect to the internet and access the operator’s network via PPPoE. Which on the other hand I do very well on Turris OS version 3.11.x, where all the interfaces are ready and I can easily create eth1.835 to connect. I don’t know if the problem derives from some issue to the module that gets the SFP (that I active through ln -sf to / boot / dtb), or something related to eth2. Other users say they can easily connect with SFP on Omnia and Turris OS 4.x. I’m really sorry for being left out of the new version of the operating system and being relegated to 3.11.8 which is conceptually a couple of years old. On Linksys WRT3200ACM I’m on OpenWRT 18.06.4 and on Omnia still on 15.
I also opened a thread here on the forum, not really understanding what the problem was at first. Omnia Turris 4.0.1 PPPoE configuration
Can you help me?

Just upgraded to 4.0.1 per medkit directly comming from 3.11.7.
And i got the same issue like descriped here by @ssdnvv. Just had for 2.4 and 5 GHz each a “?” SSID in there. Did not changed even after using Foris to enable both radios. They have been stayed there just additionally. Anyway Wifi worked normally…needed to remove manually in Luci.
You may want to have a view on it as i doubt that it was a random issue.
And the WAN Setup Section should really include a hint to the SFP activation process. Without mobile internet i would have never been able to fix that.

Anyway everything else works and is quite fast! Thanks for your work :slight_smile: