Turris OS 3.x to Turris OS 4.x to Turris OS 5.x


I would like to switch my current OS from Turris OS 3.x to Turris OS 4.x. I would then like to switch from OS 4.x to 5.x

How do I switch from 3.x to 4.x?

I’ve tried command switch-branch rc, and switch-branch nightly, but no changes to the OS are observable in Foris.

What should I do?

Have a look around in the forums. Automatic update from 3 to 4 is not (yet) supported (and will probably never be, but migration 3->5 is expected). You need to reflash your router with a medkit with either TOS 4 or even TOS 5, depending on how experimental you feel.

I found it here: Turris OS 4.0.3 is released!

So now, unfortunately, it seems I have bricked my device.

No SSH, but I can connect through serial console.

I’ve tried to use the medkit/USB method to return to a Turris OS, but that does not work.

A kernel starts, but I eventually reach this ERROR: Did not find a cmdline Flattened Device Tree Coult not find a valid device tree

Once I was using the Turris OS 5.0, I tried to upgrade to OpenWRT 19.07.2 using sysupgrade through SSH. That is what bricked the device.

Does anyone have a solution to this ERROR?

Caused by doing a sysupgrade, which is dangerous. Turris OS 5.0 is based on top of OpenWrt 19.07.2 with our patches and feed. There was created an follow-up of this thread. So, let’s move it there: