Turris OS 3.9.6 is out!

Dear Turris users,

we just released Turris OS 3.9.6. It contains mainly bugfixes (plenty of them) but also few minor enhancements. Full release notes are following:

  • haas: update and fix logging and firewall
  • irssi, rsync, dovecot, squid, mxml, libvorbis, libtasn1, unzip, php: security updates
  • xfsprogs: add xfs_admin tool
  • luci-lxc: fix container creation
  • kernel: update, modules for dvb-mn88473 and dvb-usb-cxusb added
  • dnsmasq: fix sequential ip assignment
  • suricata: fix workaround for some IPv6 issues

As always, we appreciate your feedback and wish you happy routing!

3 Likes
Output from ucollect-config.preinst:
cat: write error: No space left on device
cat: can't open '2': No such file or directory
INFO:Running post-install and post-rm scripts
INFO:Removing packages and leftover files
INFO:Cleaning up control files
WARN:Restart your device to apply all changes.
INFO:Executing reboot_required hooks...
INFO:Executed: /etc/updater/hook_reboot_required/50-create-notification.sh
INFO:Executing postupdate hooks...
Working on message: 1520358930-10206
Working on message: 1520358942-11435
Working on message: 1520358942-11450
warning: commands will be executed using /bin/sh
job 1 at Fri Mar  9 03:30:00 2018
root@turris:~# df
Filesystem           1K-blocks      Used Available Use% Mounted on
ubi0:rootfs             227420    141744     85676  62% /
tmpfs                  1035776     11376   1024400   1% /tmp
tmpfs                      512       512         0 100% /dev
/dev/mmcblk0p1        30542348   3156524  25811296  11% /mnt/tsd
root@turris:~#

Is this problem?
cat: write error: No space left on device
cat: can’t open ‘2’: No such file or directory

1 Like

kmod-dvb-mn88473 contains no files.

1 Like

Hello,
I can see in your output that you have used all your space in /dev, which is stored in RAM and that’s why it is saying to you that some files don’tt have enough space.

Restart your router and you can run Updater.sh again or you can just click to Save changes button in the administration interface Foris in Updater tab, which will call Updater.sh in background.

@kmarty: Thanks. We’ll look, why the kernel module didn’t build.

Maybe OT. When i run Updater.sh
root@turris:~# updater.sh
WARN:Script file:///usr/share/updater/localrepo/localrepo.lua not found, but ignoring its absence as requested
WARN:Requested package luci-i18n-ddns-en that is missing, ignoring as requested.
WARN:Requested package foris-netmetr-plugin-l10n-cs that is missing, ignoring as requested.
WARN:Requested package kmod-crypto-arc4 that is missing, ignoring as requested.
WARN:Requested package libi2c that is missing, ignoring as requested.
There is no message to send.

Updater in Foris send me this error message - RPCError(’/usr/share/nuci//lua_lib/datastore.lua:59: Failed to read xml string’,) and all boxes are unsticked.

Why this update stopped LXC containers? Turris Omnia is asking me to restart to finish installation, but LXC has been already shut down.

1 Like

Hi,
please, can you provide me more details?
From your description I can’t really see what is wrong and that’s why I can’t help you.

After this update there seems to be a problem with rsync.

I have a cron job setup to backup one of my disks using rsync to an offsite server, and after this update rsync is now busy backing up the entire disk like it’s a new backup. Given it’s a 4TB disk this will take a LONG time.

What should I do?

Edit: Actually I realised that it’s my ONSITE backup that is exhibiting this behaviour, the offsite one seems OK. It could be something to do with the rsync flags I use for that, which are different than for the offsite one. There was a bug with some version of rsync that did this, not sure if that’s the case here.

So I assuming, that DVB T2 with this driver still dont work? Even with 3.9.6 kernel?

We test it before from nightly repo (Missing kernel module mn88473/general kmod questions) and it doesnt scan anything…

Could someone from team look on it?

On further inspection, it looks like the packages needed to mount the ssd weren’t available after the upgrade. I use pi-hole via LXC that is on my mounted ssd. When the container didn’t come up, all sorts of hell broke loose.

I manually changed the DNS in Luci to point to google, installed the “NAS” option in Floris, rebooted, and everything worked.

I’m not sure what caused the packages to no longer be available: running DNS on an LXC container or the upgrade. I can try to dig in further if you like.

Hi, this update is pure nightmare
I have 2 Turris Omnias:
one router installed update automatically, the router does not respond after the update, I can not access SSH, Luci and Foris interfaces are down - browswer just loading- I cant ping the router, it seems I have one bricked router.
I use stock 3.9.5 here, no custom patches etc.,no custom configuration, just run NAS server,DNS and DLNA

the second router must approve this update in the foris … but after this experience I will stay on the kernel 3.9.5
I cant experiment with this router

Hello guys,
our kernel, which we use doesn’t support DVB-T2 / HEVC as I said in different thread support for it will be in later 2018.

Most drivers for DVB-T2 should be included in LTS kernel, which is 4.14 and we’ll have it in Turris OS 4.0.
Anyway thanks for reporting that kmod-dvb-mn88473 has no files. We’ll fix it.

Regarding LXC containers:
The router usually run a long time without a restart and if we’ll a release security update for Samba (as an example), we need to restart Samba to include security fix. So for almost all packages, which we update we required to restart them.
In this release, we fixed to install LXC containers in LuCI.
Each container, which you has was restarted.
If you don’t have configured that some service will start up after a reboot or starting LXC container then you can experience that service in the container isn’t running, but the container itself is running.
This depends on your configuration in LXC container.

Right now we have no plan to update lxc-auto, which was responsible for restarting LXC containers until Turris OS 4.0.

2 Likes

Looks like WiFi problems are back. Looks like random connectivity losses.

Hello,
In this update, we didn’t change anything to WiFi as you can see from release notes.

Can you please explain it more?

  • On which frequencies
  • On which devices?

Can you see something related in /var/log/messages or in syslog, which you can access also in LuCI?

To me the problem looked like random connectivity losses. Wifi on my laptop stays connected, but the internet becomes unreachable. Turning the Wifi off and on always temporarily fixed the problem.

I didn’t have enough time to look into it more at the moment, but the problem was very similar to Update broke my router

The issue maybe seems similar, but the cause of this issue could be completely different. I see that you posted here one year old thread. In this case, when it happens again, we’d from you diagnostics, where we can see more details and you need to tell us about devices, where it is happening. Only on one and it works on the others? Or it affects all devices connected via Wi-Fi?

I realized after the fact that it may have been pointless to post about it, because I didn’t post any logs or additional info. I’ll look into it some more.

Looks like the problem is gone. I wasn’t able to find anything useful in the logs. Thanks!