Turris OS 3.9.6 in RC!

Dear Turris users,

we just released Turris OS 3.9.6 into RC. It contains mainly bugfixes (plenty of them) but also few minor enhancements. Full release notes are following:

  • haas: update and fix logging and firewall
  • irssi, rsync, dovecot, squid, mxml, libvorbis, libtasn1, unzip, php: security updates
  • xfsprogs: add xfs_admin tool
  • luci-lxc: fix container creation
  • kernel: update, modules for dvb-mn88473 and dvb-usb-cxusb added
  • dnsmasq: fix sequential ip assignment
  • suricata: fix workaround for some IPv6 issues

As always, we appreciate your feedback and wish you happy routing!

RC2: Kernel update to fix problems with 2.4GHz WiFi

1 Like

Turris Omnia, just allowed install of RC 3.9.6… unfortunately lot of errors:

Chyba z 28. 02. 2018 16:59:59
Updater selhal: Failed operations:
kmod-usb-net-rndis/postinst:
kmod-usb-net-qmi-wwan/postinst:
kmod-nf-nat6/postinst:
kmod-usb-serial-option/postinst:
kmod-ppp/postinst:
kmod-usb-net-cdc-ether/postinst:
kmod-mppe/postinst:
kmod-usb-serial-qualcomm/postinst:
kmod-ebtables/postinst:
kmod-usb-wdm/postinst:
kmod-lib-textsearch/postinst:
kmod-thermal-armada/postinst:
kmod-lib-crc-ccitt/postinst:
kmod-lib-crc32c/postinst:
kmod-ipt-conntrack-extra/postinst:
kmod-nf-ipt6/postinst:
kmod-ipt-core/postinst:
kmod-nf-conntrack6/postinst:
kmod-usb-serial/postinst:
kmod-ipt-ipopt/postinst:
kmod-usb-storage-extras/postinst:
kmod-ipt-tproxy/postinst:
kmod-nf-nathelper-extra/postinst:
kmod-nf-nathelper/postinst:
kmod-usb-net/postinst:
kmod-usb-serial-wwan/postinst:
kmod-nfnetlink-log/postinst:
kmod-nf-ipt/postinst:
kmod-thermal/postinst:
kmod-ipt-conntrack/postinst:
kmod-lib-oid-registry/postinst:
kmod-ipt-nat/postinst:
kmod-lib-crc-itu-t/postinst:
kmod-nfnetlink-nfacct/postinst:
kmod-nf-nat/postinst:
kmod-nf-conntrack-netlink/postinst:
kmod-nf-conntrack/postinst:

Fortunately, LAN & WiFi OK :wink:

Sometimes during night 28.2.2018 2.4 GHz WiFi got lost… (maybe it was mising earlier and I simply didn’t notice, but I remeber connecting my tablet to TOjp2 WiFi [2.4 GHz] during 28.2. day). Neither “wifi reload” nor reboot did help.

In Foris there is displayed 5 GHz WiFi only, “Enable WiFi 2” clickable box isn’t displayed.

In LuCI (-> network → wireless) it can be seen

Generic 802.11 Wireless Controller (radio1)
SSID: TOjp2 | Mode: Master
Wireless is disabled or not associated

But, instead of something simmilar to what is displayed for 5 GHz WiFi, i.e.:

Qualcomm Atheros QCA9880 802.11bgnac (radio0)
Channel: 40 (5.200 GHz) | Bitrate: 6 Mbit/s
SSID: TOjp | Mode: Master
BSSID: 04:F0:21:24:02:1E | Encryption: WPA2 PSK (TKIP, CCMP)

there is this “Generic 802.11 Wireless Controller (radio1)”

Repeated scan operation didn’t help.

Hello,
these messages about postinst should be harmless.
We’ll fix it in next RC.

About WiFi, we’re not aware of this problem.
Is 2.4 GHz WiFi card detected in lspci?

Yes, both WiFi cards are detected:

root@turris:~# lspci
00:01.0 PCI bridge: Marvell Technology Group Ltd. Device 6820 (rev 04)
00:02.0 PCI bridge: Marvell Technology Group Ltd. Device 6820 (rev 04)
00:03.0 PCI bridge: Marvell Technology Group Ltd. Device 6820 (rev 04)
01:00.0 Network controller: Qualcomm Atheros AR9287 Wireless Network Adapter (PCI-Express) (rev 01)
02:00.0 Network controller: Qualcomm Atheros QCA986x/988x 802.11ac Wireless Network Adapter

!!! EDIT !!!

But, couldn’t there be a problem in /etc/config/wireless?

root@turris:/etc/config# cat wireless

config wifi-device ‘radio0’
option type ‘mac80211’
option country ‘CZ’
option path ‘platform/soc/soc:pcie-controller/pci0000:00/0000:00:02.0/00 00:02:00.0’
option hwmode ‘11a’
option channel ‘40’
option htmode ‘HT20’
option txpower ‘27’

config wifi-iface
option device ‘radio0’
option network ‘lan’
option mode ‘ap’
option ssid ‘TOjp’
option encryption ‘psk2+tkip+aes’
option key *****

config wifi-device ‘radio1’
option type ‘mac80211’
option country ‘CZ’
option path ‘platform/soc/soc:pcie-controller/pci0000:00/0000:00:01.0/00 00:01:00.0’
option disabled ‘0’
option hwmode ‘11a’
option channel ‘auto’

config wifi-iface
option device ‘radio1’
option network ‘lan’
option mode ‘ap’
option ssid ‘TOjp2’
option encryption ‘psk2+tkip+aes’
option key *****
option disabled ‘0’

I noticed there is line “option disabled ‘0’” in configuration for “radio1”, which there isn’t in configuration of “radio0”.

!!! EDIT !!! EDIT !!!

Unfortnunately, commenting these two lines didn’t help… tried wifi reload and reboot, 2.4 GHz Wifi isn’t working :frowning:

One thing more: /etc/config/lxc-auto, which I had modified because of Ubuntu container, was rewritten by default file :frowning:

/etc/config/lxc-auto should not be overwriten. Can you check that you had it modified before update and that it was listed in /usr/lib/opkg/info/lxc-auto.conffiles? Regarding the WiFi, one idea would be delete /etc/config/wireless and regenerate it using wifi detect and see what changed, but there should be almost no change regarding WiFi in this release.

Hi @jada4p, we are investigating the problem.

Can you confirm that you have Data collection enabled? If so, try to switch it off, apply uninstalling ucollect (if you use installation approvals) and reboot the router.

Thanks for the report

Hello guys,

We’ve just released another RC. It just fixes WiFi issue for 2.4 GHz network. In some cases it wasn’t ath9k driver for Turris Omnia routers.

as @Pepe wrote: We released a another RC with new kernel. Wi-Fi issue should be fixed and no other action need to be done @jada4p (you can let Data collection enabled)

1 Like

I’m quite sure I’d modified /etc/config/lxc-auto because of Ubuntu container. But, later, in course of some experiments with Ubuntu container, I made all modifications comments.

As to your request - yes, it is listed there:

root@turris:~# ls -l /usr/lib/opkg/info/lxc-auto.conffiles
-rw-r–r-- 1 root root 21 Feb 28 11:53 /usr/lib/opkg/info/lxc-auto.conffiles
root@turris:~# cat /usr/lib/opkg/info/lxc-auto.conffiles
/etc/config/lxc-auto

As to WiFi, it should be, according to @Pepe, solved in recently released new RC. Let’s see - I do hope so!

That was the same with me. In fact, I’ve already tried it. I can confirm that I have Data collection on. I was waiting for @jada4p because it’s his discovery. I turned on Data collection again and then updated it. It seems all I’ve enabled is running.

TO, nas, smb and tm.

It seems, for the moment at least, that 2.4 GHz WiFi is back alive. I have to tune it little bit more (find less busy channel)…

One problem still remains: instead of proper device, which lspci command can find

root@turris:~# lspci
00:01.0 PCI bridge: Marvell Technology Group Ltd. Device 6820 (rev 04)
00:02.0 PCI bridge: Marvell Technology Group Ltd. Device 6820 (rev 04)
00:03.0 PCI bridge: Marvell Technology Group Ltd. Device 6820 (rev 04)
01:00.0 Network controller: Qualcomm Atheros AR9287 Wireless Network Adapter (PCI-Express) (rev 01)
02:00.0 Network controller: Qualcomm Atheros QCA986x/988x 802.11ac Wireless Network Adapter

LuCI Wireless Overview displays

Generic MAC80211 802.11bgn (radio1)

How to make LuCI see real Qualcomm Atheros AR9287 adapter?

Hello,
once I deleted section wifi-device for radio0 in /etc/config/wireless then I couldn’t see the WiFi card in LuCi.

Right now you don’t see 5 GHz WiFi card Qualcomm Atheros QCA986x/988x, which is weird.

In this case, I think it will be better to do this and once again set wireless network.

rm -f /etc/config/wireless
wifi detect >> /etc/config/wireless

then reload the page in LuCI and now you should see both WiFi cards.

If you didn’t see them, I’d need more logs from you. Anyway, I recommend you to use Foris to setup a wireless network.

Sorry, it’s in other way. LuCI does see 5 GHz Qualcomm Atheros QCA986x/988x (combo 5 & 2.4 GHz) card, but doesn’t see 2.4 GHz Qualcomm Atheros AR9287 card.

Do you still think I should reset wireless network or is there some other way?

I’m not aware right now about any issues in RC.

So I think you misconfigured something in the configuration file - /etc/config/wireless.


EDIT: Finally, I understand, where you have a problem.
All WiFI networks are working for you.

But you just complain that for 5 GHz card in LuCI you can see Qualcomm Atheros QCA986x/988x , but for 2.4 GHz there is name Generic MAC80211 802.11bgn, which you don’t like and you want to see Atheros AR9287.

I’m extreemly sorry, but I’m affraid you still don’t understand me. I didn’t directly modified /etc/config/wireless, all what I did was that I used Foris and LuCI to “revive” 2.4 GHz WiFi. The problem is that LuCI does recognize 5 GHz (combo) card (Qualcomm Atheros QCA9880), but doesn’t recognize 2.4 GHz only card (Qualcomm Atheros AR9287), assuming it is Generic MAC80211 card. The lspci command does recognize both cards for what they are.

Please don’t take me wrong, I don’t want to quarell with you (or anybody else), I only want to clarify the situation.

Even if you configured stuff just from LuCI/Foris, try regenerating /etc/config/wireless, there might be some leftovers from time when your WiFi didn’t work.

@Pepe - yes, finally, it’s so - I don’t understand (and don’l like) why LuCI is displaing one card by its proper name, while the other not.

But, as @Miska is suggesting, this situation could be caused by missing driver in 1st RC and later installing it in 2nd RC :frowning:

OK, I’ll try to re-generate WiFi, as suggested.

Now I cleared and re-generated /etc/config/wireless, as suggested by @Miska and @Pepe. I compared it with functioning previous version of itself (before RC 3.9.6), found in snapshot, and modified it accordingly (channels etc.). Both WiFis are working. But, to my amazement, the 2.4 GHz card is still displayed as Generic MAC80211 802.11bgn (radio1) in LuCI :frowning: I don’t understand it and I’m lost. I think I’m finished: I’ll take this as matter of fact and stop wonder and ask :frowning: