Turris OS 3.8.3 is out with dnsmasq security fixes and more

Dear Turris users,

we just released Turris OS 3.8.3 into a wild. This is mainly about security fixes in crucial parts of our stack - dnsmasq and openssh. But as part of the release we do also some small polishing. We updated kernel with various fixes to corner-case problems and we came up with workaround for problems with SATA controller.

Changes are:

  • dnsmasq: various security fixes
  • kernel: various small fixes
  • openssh: security update
  • asm1062: workaround for error with SATA controller

We are looking forward to reading your feedback!


I run updater.sh, this is output:

… (many Queue install)
INFO:Queue install of kmod-nf-nat6/turris/4.4.91+0-1-cb5e816fa6b1a6b5342df69755869d71-0
INFO:Queue install of kmod-ipt-nat6/turris/4.4.91+0-1-cb5e816fa6b1a6b5342df69755869d71-0
Press return to continue, CTRL+C to abort

I press return, but it didn’t nothing. I’m waiting 20minutes already, is it ok? :slight_smile:

… same problem, same message…

@miska, ps shows

9654 root 1132 S {updater.sh} /bin/sh /usr/bin/updater.sh
9671 root 748 S timeout -k 3005 3000 pkgupdate --state-log --task-log=/usr/share/updater/updater-log --ask-approval=/usr/share/updater/need_approval
9672 root 75908 T pkgupdate --state-log --task-log=/usr/share/updater/updater-log --ask-approval=/usr/share/updater/need_approval

still no progress

You have updates on approval, don’t you?

I don’t, only delayed updates. But I ran updater.sh manually…

I used to have on approval and this is what happens when you have that way modified updater settings.
Go change it. Aprovals or time delay are things that prevent you from using updater.sh manualy.


I changed automatic updates back and it works, thanks.

LXC issue shouldn’t be related to 3.8.3 but should be fixed now.

I have had the same problem from the version 3.8
The same errors still again and again.

And what problem/error might that be?

The updater (started from command line) wants approve installation or removing of packages (from the queue shown above), but “Press return or CTRL+C to abort” do nothing.

P.S.: I have “no approval” set in my /etc/config/updater

When you press return, it will start doing stuff, it just doesn’t output anything. I agree that this looks confusing. This user experience will be improved in next release.


Approval option bug has been identified and will be targeted in 3.8.4 (see other thread on that topic)

Got this warning during update

WARN:Requested package luci-i18n-ddns-en that is missing, ignoring as requested.

Already mentioned in other threads, warning is due to the different way luci-i18n-ddns does localization, so no worry, it is not a bug nor it is new.

Turris 1.1, under contract. DHCP not working after reboot again. Rolled back to

When will you fix the Foris configured OpenVPN issue? I cannot connect from phone, it times out. System log shows incoming request but seems like no response in the communication?!