Turris OS 3.11 in RC!

release

#92

@miska fixed it, I have tested it, and it looks good.
For our users, it means that we’d like to release another RC tomorrow, which will fix this, and also findutils.

In the meantime, it will be fixed in nightly branch for both of our routers.
For Turris Omnia, it should be fixed within an hour and for Turris 1.x around 2 hours.


#93

We’re releasing another RC version of Turris OS 3.11 containing small changes.

Changelog:


#94

I’ve just updated to the latest RC. Seems OK though I have a recurring problem at the moment, something keeps rewriting /etc/resolve.conf and removing my custom DNS entry pointing to my pi-hole server (LXC).

I didn’t have to do this previously but something has changed requiring I add this external DNS entry in order to get resolution on the Turris router (LAN works fine).

So where do I need to look to either ensure my changes are persistent over reboots or add to whatever is overwriting resolve.conf to set the additional DNS entry?


#95

I am on the RC but I still have problems with knot resolver :frowning: It is sporadically failing to resolve a lot of names (idos.cz, rouming.cz, rendl.cz, …). Restarting kresd solves the issue until it happens again a day or so later. I am running kresd version 3.1.0 on turris omnia.

I am attaching debug log of kresd from time I unsuccessfully tried to resolve idos.cz


#96

Thanks for reporting! @vcunat is looking into this.


#97

Thank you. If you need more information I sent an email to tech support with complete diagnostic output attached (I didn’t want to post it here)


#98

Hi, you can change it in dnsmasq config

uci set dhcp.@dnsmasq[0].local_dns_server="xx.xx.xx.xx"
uci commit dhcp

Updater fails: unable to resolve host address 'repo.turris.cz'
#99