Turris OS 3.11.3 is released!

mysql not work with php

First, thank you guys for great work. Installation was flawless now. I found only minor warning so far

2019-03-27 07:06:31 notice stunnel[]: LOG5[ui]: Compiled with OpenSSL 1.0.2o 27 Mar 2018
2019-03-27 07:06:31 notice stunnel[]: LOG5[ui]: Running with OpenSSL 1.0.2r 26 Feb 2019

I will try recompile stunnel package backporting from upstream by myself tonight if my debian vagrant toolchain is not damaged by LXC upgrade.

updated 2 omnias all went smooth, everything works without any issues

1 Like

Also, not sure why, but the 5G wifi issues seems to be gone.

I’ve the same issue. Did not tried second restart yet.

turris ~ # nikola 
Traceback (most recent call last):
  File "/usr/lib/python3.6/logging/handlers.py", line 835, in _connect_unixsocket
    self.socket.connect(address)
FileNotFoundError: [Errno 2] No such file or directory

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/bin/nikola", line 11, in <module>
    load_entry_point('nikola==43.1', 'console_scripts', 'nikola')()
  File "/usr/lib/python3.6/site-packages/nikola/__main__.py", line 139, in main
    logger = get_logger(options.debug)
  File "/usr/lib/python3.6/site-packages/nikola/logger.py", line 32, in get_logger
    sys_handler = logging.handlers.SysLogHandler(address="/dev/log")
  File "/usr/lib/python3.6/logging/handlers.py", line 818, in __init__
    self._connect_unixsocket(address)
  File "/usr/lib/python3.6/logging/handlers.py", line 846, in _connect_unixsocket
    self.socket.connect(address)
FileNotFoundError: [Errno 2] No such file or directory

Update: after restart - no change. Nikola does not work, firewall logs are not sent.

obrazek

There is no “/dev/log”

turris ~ # ls -la /dev/log
ls: /dev/log: No such file or directory

Did you make any changes to the file /etc/syslog-ng.conf ?
If you have the file /etc/syslog-ng.conf-opkg change its name to /etc/syslog-ng.conf and run syslog /etc/init.d/syslog-ng restart

Thanks, that’s it.

turris ~ # ls -la /etc/syslog-ng*
-rw-r--r--    1 root     root           863 Sep  7  2018 /etc/syslog-ng.conf
-rw-r--r--    1 root     root          1994 Mar 20 00:06 /etc/syslog-ng.conf-opkg

After renaming and syslog-ng restart it works now.

I’m not sure, if I did any changes there. Diff does not show any difference that I recognize.

Well. Seems to works, but is this correct?
No WAN device was set

turris ~ # nikola
recognized WAN interfaces: 
Establishing connection took 0.626054 seconds
No WAN device was set. No data will be send to the server!
Session init took 0.640514 seconds
Records parsed: 0
Records after filtering: 0
Records filtering took 0.001307 seconds
{'msg': 'Server was notified that client has no data to send.'}
Sending records took 0.018552 seconds

Aha. I know. This was a temporary solution for this issue:

2019-03-28 20:32:59 crit mountd[6979]: could not find a serial number for the device sdb

This was September 2018 - still not fixed :frowning:

My openvpn issue posted a while back has been resolved as well. The only remaining issue is that the openvpn service isn’t default enabled after installation. But this could just as well be related to the medkit I used (last modified date 2019-03-20). In what project in Gitlab should I enter an issue for that?

Guys, could we keep this thread clear and understandable to others, please? There are already 24 posts and if somebody has an issue, it doesn’t help when someone posts here 4 posts about the same issue or that he solved it within 2 days. If you do please share your solution or workaround in your post In that case, it’s better to use the EDIT button. I have noticed that somebody had some issue and he solved without writing the solution. If somebody wants to put here some output or even a snip, please use [code][/code]

To summarize it:

@nijel: Since yesterday @cynerd is in touch with you.

@JardaB: When you receive Foris error, don’t put it here and follow the instructions, which are there - short description of the steps which leads to that error together with that error to tech.support@turris.cz.

@karelf: That’s interesting finding! Would you please send us diagnostics, which you generate in Foris and send them to tech.support@turris.cz? So we can look what’s wrong.

@protree: This is not related to this release, however logs from ath10k says that it couldn’t find firmware files and fallbacking to other firmware files and in the end it found the firmware.

@Twinkie: It should be harmless, if not, we’ll look into it.

@FraX: If you’re not sure in which repository you should create the issue, I suggest to reach our support, which is available on email address tech.support@turris.cz and we will do it for you.

2 Likes

Hi, we have discuss this a lot inside the team and – as I stated in the issue – we had decide the new OpenVPN server instance will not use any compression however, to preserve once-configured client working, compression will stay on if you have it in the config.

So if you installed OpenVPN plugin before 3.11.3, you use compression. If you don’t like it, just delete compress option from uCI config and download new client config for all your devices/clients.

1 Like

FORIS - Pakon Safari log
Browser Safari
Machine
Turris 1.X
verze rozhraní foris: 99.7.1

Zařízení Turris - rtrs02
Verze Turris OS 3.11.3
Verze jádra systému 4.4.176-49a62e79231da4ac50e66e6eb4cd7945-0

Found a minor issue with the log date and time. Now is the 31-02-2019 21:10 (cca)
In the log see 2019-03-31 22:59 and similar dates (after DST +2hour, before DST +1)

Datum Trvání Klient Název stroje Port Odesláno Přijato
2019-03-31 22:59:16 00:00:20 00:21:e9:e0:c7:7b links.kampane.equabank.cz http 1.45 KiB 863 B
2019-03-31 22:54:12 00:00:53 00:21:e9:e0:c7:7b asset.stdout.cz https 15.27 KiB 180.66 KiB
2019-03-31 22:54:11 00:04:06 00:21:e9:e0:c7:7b id-eco.cz https 6.31 KiB 12.92 KiB
2019-03-31 20:58:17 00:00:00 00:21:e9:e0:c7:7b id-eco.cz https 148 B 74 B
2019-03-31 20:54:11 00:00:06 00:21:e9:e0:c7:7b id-eco.cz https 6.16 KiB 12.84 KiB

|2019-03-31 22:54:10|00:00:10|00:21:e9:e0:c7:7b|cookie.centrum.cz|https|4.39 KiB|11.34 KiB|
|2019-03-31 20:54:20|00:00:00|00:21:e9:e0:c7:7b|cookie.centrum.cz|https|2.35 KiB|6.56 KiB|
|2019-03-31 20:54:10|00:00:00|00:21:e9:e0:c7:7b|cookie.centrum.cz|https|2.04 KiB|4.77 KiB|

36

Updated yesterday and had no issues so far.
Setup includes several vlans, ddns, custom openvpn and tor relay as well as several connected vlan-enabled switches and WiFi access points.

Ocakaval som, ze po update na 3.11.3 bude fungovať luajit ale nefunguje. Luajit potrebujú mnohé iné balíky napr: knot-resolver. Ked ho sa ho pokusim spustiť výpise sa chybová sprava:

luajit /root/tools/omnia-loadcpu-color/omnia-loadcpu-color.lua
luajit: /root/tools/omnia-loadcpu-color/omnia-loadcpu-color.lua:13: module 'socket' not found:
        no field package.preload['socket']
        no file './socket.lua'
        no file '/usr/share/luajit-2.0.5/socket.lua'
        no file '/usr/local/share/lua/5.1/socket.lua'
        no file '/usr/local/share/lua/5.1/socket/init.lua'
        no file '/usr/share/lua/5.1/socket.lua'
        no file '/usr/share/lua/5.1/socket/init.lua'
        no file './socket.so'
        no file '/usr/local/lib/lua/5.1/socket.so'
        no file '/usr/lib/lua/5.1/socket.so'
        no file '/usr/local/lib/lua/5.1/loadall.so'
stack traceback:
        [C]: in function 'require'
        /root/tools/omnia-loadcpu-color/omnia-loadcpu-color.lua:13: in main chunk
        [C]: at 0x00014a1c

Prosím ako ho mam korektne spustiť? A tiež aj ako service s lua scriptom? D.

No change so far. Thread: https://gitlab.labs.nic.cz/turris/turris-os-packages/issues/310#note_102771

My Turris requires approval to update. I received a notification that the md5 sum does not match on libopenssl. Is it possible to force a new attempt to download that file?

New download is done every time updater is running to ensure that it is updating to latest versions of package so it is enough to run updater again. If problem persists then it is more likely that it is a problem with internet connection. It could be problem in our repository but you are only one encountering it, as far as I know, so I don’t expect that.

Thanks cynerd.

It looks to me that the only option I have is to ‘approve’ the installation of the download with the md5 warning. Is that what you suggest that I do? It is not clear what you mean by ‘run the updater again’.

Approve or just click save button in Foris in Updater tab. All those actions are going to run updater again. Hash mismatch is fatal updater error so if it happens then it won’t proceed with update.