Turris OS 3.11.3 in RC

release

#65

The likely culprit is the outdated netifd in TOS3.x, which probably will not get fixed any more in TOS3.x branch but only TOS4.x. I had similar issues with ipv6 on the wan and had to disable it too..

Since your connection is PPPoE and thus require kernel-modules the seqfault could be very well related.


#66

Changelog of Turris OS 3.11.3 RC4

Package updates:

  • updater-ng: fix for localrepo (mentioned here)
  • foris-controller-openvpn-module: compression logic updates (Gitlab issue)
  • kernel: update

Security updates:

  • openssh: update to version 7.9p1-1 (fixes CVE-2019-6109, CVE-2019-6111)
  • unbound: add patches for OpenSSL 1.0.2 host verify fix from Unbound
  • tiff: fix for CVE-2019-6128

#67

update from RC3 to RC4 went ok. unbound patch seems to be working. no issues thus far in the logs


#68

just update to RC4 2x omnia routers, working without any issues


#69
16:09:34 err modprobe[]: failed to open /lib/modules/4.4.172-7bc33afbb1b35f5830b2b1b42c9cd8a0-0/blocklayoutdriver.ko

Are these okay during the update?


#70

just updated to RC4 on my omnia, no issues.


#71

Yes, the newest RC also runs well on my Omnia.


#72

For me, UPnP still doesn’t working :frowning: I don’t know if ISP can block this feature or if it is bug in Windows 10 Pro x64 1809, but still I see “no active redirections”. My uTrorrent is set correctly, service is enabled and started. I don’t know :frowning:


#73

The part around your ISP is about your router (its WAN) getting a public IPv4. Well, theoretically they might specifically block torrents, as I’ve heard such ideas from ISPs already but they don’t seem too common nowadays.


#74

I tested all high ports from 1024 to 65535 TCP and UDP and all are closed. :frowning: Is possible that my issue is in Knot resolver on my Turris 1.x? Maybe I see problem, where it isn’t.


#75

I can’t see how DNS would be related. There’s still no knot-resolver package for Turris 1.x, too. (Unbound is the default resolver in there.)


#76

So i really don’t know. I also tried WiFi connection directly to router to bypass switch, but without effect.


#77

Did you see UPnP server not running? ?


#78

I tried both commands, without effect :frowning:


#79

The Pakon is too wide again.


#80

OpenVPN plugin still doesn’t work:


#81

It seems like Windows 10 1809 issue, 'cause I haven’t Teredo Adapter in Windows, and actually is no way, how to install It back, I try UPnP connection on computer with Win7 x64 and write update.


#82

Changelog of Turris OS 3.11.3 RC5, which we have released now.

Package updates:

  • netdata: update to version 1.12.0 (for Turris Omnia)
  • youtube-dl: update to version 2019.02.18
  • bird: update to version 1.6.5
  • dnssec-rootkey: removed old DNSSEC key
  • dovecot: compile fix
  • updater-ng: update to version 61.1.5.2 (fixes turris/foris#146)
  • kernel: update

Known bugs:

  • openvswitch: is missing due to compilation issues

#83

update from rc4 to rc5 went ok, thus far no issues lodged in the logs


#84

I updated from RC4 to RC5, no issues so far for this RC.

The last few updates I do see an error from netdata, any info on how to fix this netdata error in the logs?
2019-02-22 13:53:34 err netdata[9252]: BTRFS: failed to read ‘/sys/fs/btrfs/490430d3-794d-4d61-a795-daa1e1e1b126/allocation/data/total_bytes’

Thanks
John