Turris OS 3.11.3 in RC

Are you sure it should be ps | and not ps && ? I still don’t get it - you take the output of ps and pipe it to the input of syslog-ng (which probably doesn’t read stdin at all)

It would be a catch 22 since syslog-ng is not running/working.

after having run mkdir /etc/syslog-ng.d then

ps | syslog-ng

WARNING: syslog-ng dropped support for POSIX regexp implementations in syslog-ng 3.14 in favour of PCRE, which should be upward compatible. All ‘posix’ regexps are automatically switched to ‘pcre’. Please ensure that your regexps work with PCRE and specify type(‘pcre’) explicitly or increase @version to remove this warning;


ps | grep syslog-ng

5166 root 4812 S {syslog-ng} supervising syslog-ng
5167 root 9312 S syslog-ng
5331 root 1108 R grep syslog-ng

That apparently would sort it.

Issue about syslog-ng reported by @anon50890781 will be fixed in next RC. Thanks for reporting!

May I ask you, if it looks like it’s described in this thread?

We have changed the graph in Turris OS 3.11.

Yes, it’s the same as described in this thread.

In pakon-show does not working parameter -A (--aggregate)

root@turris:~# pakon-show -A
Traceback (most recent call last):
File “/usr/bin/pakon-show”, line 133, in
File “/usr/lib/python3.6/json/init.py”, line 354, in loads
return _default_decoder.decode(s)
File “/usr/lib/python3.6/json/decoder.py”, line 339, in decode
obj, end = self.raw_decode(s, idx=_w(s, 0).end())
File “/usr/lib/python3.6/json/decoder.py”, line 357, in raw_decode
raise JSONDecodeError(“Expecting value”, s, err.value) from None
json.decoder.JSONDecodeError: Expecting value: line 1 column 1 (char 0)

Turris 1.0, RC 3.11.3, pakon 1.2-17

Thank you for reporting! We will look at it if there’s something what we can do about it.

I looked into it and thing is that pakon-show -A will crash in case there are no aggregated data to show. Once data exists, pakon will show them as expected. Aggregation currently happens once per day, so please be patient.

You could run into this issue either when you delete pakon archive db or with freshly installed pakon. Thanks for reporting, we’ll provide a fix soon.

1 Like

I hope that UPnP will start work again, 'cause actually on 3.11.2 it doesn’t work. It shows “no active redirecions” but in previous builds it worked normally.

UPnP works for me on 3.11.2:

Is miniupnpd running on the router?

Yes, service is running. I didn’t touch to UPnP configuration maybe around two yrs, but everytime that worked, after update it stopped working. Service is running, I tried to restart service, reboot router, but without success. I saw somewhere on Turris, that somebody have the same problems.

A post was split to a new topic: My feedback/improvements for Turris OS

Aha, that might explain the trouble i have with some local mounts that dissapeard after 3.11.2. I was wondering why they dissapeared, but this can be the issue.

What about this one? Don’t tell me broken backups are low priority… It’s already been broken for 10+ days, and I don’t like that much.

Manually cloud backups work fine, only automatic not working good.

Hello guys,

We have just released another RC, which containing small bugfixes or updates.

  • Foris: unification of themes accross all Turris products
  • youtube-dl: update to version 2019.01.30.1
  • tar: update to version 1.31 (security fix)
  • fixed issue for Turris 1.x about smaller RAM than it should be (forum link)
  • syslog-ng: fixed missing folder /etc/syslog-ng.d
  • pakon-show: fix for parameter -A
  • Cloud backups fixed, which was reported in this thread.

update went ok, strange syslog entries after browsing Foris

err foris-controller[2829]: WARNING:turrishw:unsupported TOS version (on omnia): 3
err foris-controller[2618]: Last message ‘WARNING:turrishw:uns’ repeated 1 times, suppressed by syslog-ng on to

I have it too…
Turris 1.0, last RC…

2019-02-06 19:44:36 err foris-controller[6413]: WARNING:turrishw:unsupported model: TURRIS
2019-02-06 19:44:40 err foris-controller[5471]: Last message ‘WARNING:turrishw:uns’ repeated 1 times, suppressed by syslog-ng on turris
2019-02-06 19:44:42 err foris-controller[6413]: WARNING:turrishw:unsupported model: TURRIS
2019-02-06 19:44:46 err foris-controller[5471]: Last message ‘WARNING:turrishw:uns’ repeated 1 times, suppressed by syslog-ng on turris

I don’t think this is new, is there in 3.11.2:

2019-02-05 22:53:34 err foris-controller[4581]: WARNING:turrishw:unsupported TOS version (on omnia): 3
2019-02-05 22:53:39 err foris-controller[7238]: Last message 'WARNING:turrishw:uns' repeated 3 times, suppressed by syslog-ng on turris

Will file a bug for it https://gitlab.labs.nic.cz/turris/foris-controller/issues/64

And what about cloud backups issue - was it fix in this RC release or not?