Turris OS 3.11.23 -> OS 5 - recommended to wait due to issues?


I need stable Internet for school kids and working from home.

There have been various posts about Turris OS 5 instability, eg Random Omnia freezes and related LAN issues after update to 5.x

Is sticking with Turris OS 3 recommended for the time being if stability is important?

well, did the 3 to 5 already long time ago, run a basic omnia and MOX ( open vpn, adblock, 2.4 and 5 wifi, thats it ) . And over here all is fine? The upgrade did not went smooth, had to do a factory reset on the omnia to get it over to 5 so lost basically almost all settings. But after an hour all was set, and must admit that all my wifi issues has been solved.

I did a complete clean installation and have huge issues with WiFi connectivity (roaming of clients) that weren’t present in 3.x. If this bevahiour continues I am thinking about rolling back to 3.x…

@ssdnvv Do you have your other APs connected through one of the LAN ports of your TO? I had problems with roaming, too. I was able to fix it by connecting my other APs through a switch connected to the WAN Port of my TO. I then switched the WAN Port and one of the LAN Ports (assigned eth2 to br-lan and Lan4 to Interface WAN in LuCi -> Network -> Interfaces, you then have to switch the ethernet-cables, too, of course).

This fixed all of my Roaming Problems I had with TOS 5.X.

There seems to be some problems with switch configuration in TOS5.X due to switch to dsa from swconfig. Some traffic seems to be unable to pass the switch, especially when you use VLANs on the LAN ports (interfaces LANX.X). I suspect some IGMP-traffic isn‘t handled correctly but I didn‘t debug this further because I‘m fine with my workaround.

EDIT: Using my workaround my network is rock-solid :slight_smile:

1 Like

I had to rollback to 3.x on Turris 1.1 due to Wi-Fi and unresolved DNS issues. I have sent logs and diagnostics to Turris team but without any response.

In my case TO is an (dump) AP, but connected via lan4 (using 3 different VLANs).
I’ll try that, thanks.

btw - how did you find out? Did you try tagging via DSA directly (with bridge/ip commands)?

This config should be even easier :).

No, I just set up VLANs as described in the docs (VLAN - Turris Documentation). I have two TOs in two different locations, one of them is connected to a managed switch only and gets WAN through a VLAN and sends LAN back to the switch on a different VLAN through the same ethernet cable (due to structural reasons). This TO didn‘t have any problems while my other TO had those. IGMP is just an assumption because my main problem was that I was unable to connect to my sonos speakers after roaming between an AP and my TO (and back to the AP, too) and I read that IGMP is used for device discovery in the „sonos protocol“.

If you set up your TO as an AP are you sure you disabled dnsmasq, odhcp and ipv6 router advertisements on this TO?

EDIT: Maybe we should not hijack this thread…

After the initial move, I’ve not had any issues with the latest releases. There are still some occasional issues with updates, but I had things like that with 3.x.

There were some gotcha’s when I moved, but largely, I didn’t need to do anything special. I have some distinct DNS settings, but other than that, I don’t do anything out of the normal operation of Turris.

It indeed worked as you promised. Thanks alot, my family is happy again :upside_down_face:
Seems there is some bug in the DSA implementation…

1 Like

I went the reset road also. So saved configs, downloaded, installed 5.x from scretch and and adopted settings to the new config files (VPN, Firewall and Wireguard mainly). WIFI was working well before and after it was the same. So for me all went fine :slight_smile:

I changed to TOS5, but first had to reset my Omnia and install from USB-stick.
Then DNS didn’t work and I had a very, very slow internet, if it worked at all. I tried a month but couldn’t solve the problem.
Finally I installed TOS3 again and since then all is working normal.

I have only standard configs, like NFS server, integrated NAS, WIFI.

If there is a reasonable explanation found for the DNS problem, I would try it again, if I have a week to spent and don’t need reliable internet during that time. I know more about how to use schnapps now and generally it should be easy to try and roll back if needed. But I had to learn that procedure the hard way…