Turris OS 3.11.1 is out!

release

#21

Yes, it’s enough to simply overwrite that init file and then restart kresd e.g. by /etc/init.d/resolver restart – that’s how I tested it locally, too. It only changes the generated part of kresd config file.


#22

OK.
Changed the file. Restarted resolver. Changed DNS to Cloudfare TLS. Luci is snappy.
Good work.


#23

I uninstalled samba36 and installed samba4 and probably something has broken it , I can see lot of messages like this in a notification panel.

Updater selhal:

[string “transaction”]:323: [string “transaction”]:149: Collisions:

• /usr/sbin/smbd: samba4-server (existing-file), samba36-server (new-file)

• /etc/samba/smb.conf.template: samba4-server (existing-file), samba36-server (new-file)


#24

Odložené aktualizace se opět hlásí odlišně od nastavení (v mém případě 72 hodin).

Schválit aktualizaci z 2018-12-19 16:57:33

Pokud aktualizace nenainstalujete ručně, budou po 2019-03-01 16:57:33 nainstalovány automaticky.


#25

QR codes produced in Foris are recognised by Android apps but on iOS 12.1.1 the camera app is reporting

QR CODE DETECTED
No usable data found


Foris Guest network detection seems to be limited to parsing the string turris_guest. Using any other name and Foris has no awareness of it (contrary to LuCI) and subsequent does not present a QR code.


#26

Merry Christmas to all,

I just recently installed it without any change. Since then, my 5Ghz wifi is no longer usable.
Restarting Omnia or restarting the wifi does not bring any change.
Can it be due to the update for ath10k-ct?

Best regards

Edit: After another restart, the WLAN works now. No changes, no idea why it was. Everything great.


#27

Hello, pakon in forris on turris omnia is extremely slow.


#28

Hello, after performing the update the LUCI GUI became very slow. Some interaction (e.g. pressing the button to configure the wireless interface) takes about 15-20 seconds until there is a reaction.


#29

Hello,
Would you please try this workaround and tell us, if it works for you?


#30

I changed the init script manually and the problem is solved. Thank You!


#31

I had removed samba36 packages and installed samba4 packages but when run pkgupdate I get this:

openwrt /etc/updater # pkgupdate
ERROR:No /etc/opkg/customfeeds.conf file. No opkg feeds are included.
WARN:Request not satisfied to install package: domoticz-turris-gadgets
WARN:Requested package luci-i18n-ddns-en that is missing, ignoring as requested.
WARN:Requested package luci-i18n-wshaper-cs that is missing, ignoring as requested.
WARN:Requested package luci-i18n-wshaper-en that is missing, ignoring as requested.
INFO:Queue install of foris-pakon-plugin/turris/2.5.1-3.6-
INFO:Queue install of samba36-client/turris/3.6.25-11
INFO:Queue install of samba36-server/turris/3.6.25-11
INFO:Queue install of luci-app-samba/turris/git-18.328.59464-9636605-1
INFO:Queue install of luci-i18n-samba-en/turris/git-18.328.59464-9636605-1
INFO:Queue install of luci-i18n-samba-cs/turris/git-18.328.59464-9636605-1
INFO:Queue removal of lighttpd-mod-access
INFO:Queue removal of php7-cli
Press return to continue, CTRL+C to abort

even after added /etc/updater/user.lua :

openwrt /etc/updater # cat user.lua
Repository “local” “file:///data/repo”
Install “unison”
Install “links”
Install “tree”
Uninstall(“samba36-server”, { priority = 60})
Uninstall(“samba36-client”, { priority = 60})
Uninstall(“luci-app-samba”, { priority = 60})
Uninstall(“luci-i18n-samba-en”, { priority = 60})
Uninstall(“luci-i18n-samba-cs”, { priority = 60})

But pkgupdate ignore this and want to reinstall samba36. How to block it to keep only samba4 installed ?


#32

File /etc/updater/user.lua is no longer used. It was migrated to /etc/updater/conf.d/user.lua.


#33

Thank you moving that file solved the problem.


#34

@sid did you follow this guide? Samba4 experience


#35