Turris OS 3.11.1 is out!

release

#1

Dear Turris users,

we just released Turris OS 3.11.1. It contains mainly bugfixes and few updates that didn’t made it into 3.11, full release notes are bellow:

  • netdata: update for Omnia
  • subversion, unbound, git, ath10k-ct, miniupnpd, mwan3: updates
  • samba4, bzip2, openssl, tiff, apache, sqlite3: security updates
  • pakon: further improvements of archivation
  • majordomo: removed from the list of applications on updater page, still available for manual installation
  • mdadm, webapps, nextcloud: minor fixes
  • tvheadend: fix first time setup

Enjoy!


#2

#3

Issue Turris OS 3.11 is out! with schnapps list producing messages like

Warning, could not drop caches
parent transid verify failed on ...
ERROR: child eb corrupted: parent ...

seems to be solved in 3.11.1. No more messages like this after update and reboot.


#4

Why is this not in list of fixed stuff? In release notes?


#5

Updated. So far so good.

Noticed a small spelling error under Foris-Region and Time-Time settings.
It reads “Time should be up-to-date otherise DNS…”, the “w” in otherwise is missing.


#6

UPnP works great again. Thanks!


Turris OS 3.11 is out!
#7

Getting the following new error-message in syslog:

2018-12-19 23:02:21 err foris-controller[2904]: WARNING:turrishw:unsupported TOS version (on omnia): 3
2018-12-19 23:02:25 err foris-controller[2760]: Last message 'WARNING:turrishw:uns' repeated 1 times, suppressed by syslog-ng on Router
2018-12-19 23:02:30 err foris-controller[2904]: WARNING:turrishw:unsupported TOS version (on omnia): 3
2018-12-19 23:02:34 err foris-controller[2760]: Last message 'WARNING:turrishw:uns' repeated 1 times, suppressed by syslog-ng on Router```

#8

Feel free to help out: https://doc.turris.cz/doc/en/howto/localisation :slight_smile:


#9

Yesterday, my Omnia with the latest OS 3.11.1 lost suddenly connectivity. I was listening on my hifi music from dlna server and suddenly the system stopped playing - HiFi is to DLNA server connected by wire. Tablet showed that WiFi is connected by internet didn’t work. I had to make HW router restart and since then it worked correctly. Because of warning on this forum I’ve now disabled DNS over TLS.


#10

I looked at this.
Is it me or is English not listed as translatable language? Thus, how can i correct this writing error?


#11

Well, the “Luci slowness” is still in there.
As soon as something else as the DNS of your own provider is picked Luci slows down. Some pages more (like WOL) than others.
Luci has a normal speed when picking your providers DNS (or disable forwarding).

As i can reproduce this, is there something i can do to debug this?


#12

No, thanks, I see now what’s happening. For some reason luci is generating reverse queries on some IP addresses used in the network, and I didn’t expect that. I still can’t see why it’s done but it’s nothing wrong, it just interacts badly with some configuration oversights in default forwarding with Omnia+kresd.


#13

I confirm the removal of problems with SD card formatted with btrfs and schnapps as confirmed by @winkler above.
Either the problem has been removed or there was problem with logging, I hope in the first option.


#14

For Turris 1.x routers, we have enabled one option (CONFIG_ADVISE_SYSCALLS ) in the kernel, which we have for Turris Omnia.

In release notes, we include changes, which seems to be important. We wouldn’t want to include each change in release notes, because it will be a really large list.

Each commit, which we do can be found in our Gitlab and each our version, which we release is tagged, which is useful if you’re looking for these changes.


#15

It reads “Time should be up-to-date otherise DNS…”, the “w” in otherwise is missing.

Thank you for reporting it. We have fixed by this commit, however, the change will be in some new future release.

English isn’t in Weblate, because it’s a source language created from us and from which you can translate it to the others.


#16

A workaround avoids this; it’s on the way to -nightly (not sure when exactly). It’s also possible to just replace the init script by hand, in case anyone wanted the change very fast or without other changes.


DNS broken after factory reset and update to 3.11.1
Turris OS 3.11 is out!
Opening LuCI port forwarding page is very slow (40s)
#17

Huge performance difference with Luci with this fix. Thanks @vcunat!


#18

Still the very same issue with DNS over TLS as with 3.11 (FORIS klicking solution = descriped SSH-solution) - after approximately 24 hours DNS resolution doesn’t work anymore. Restarting resolver doesn’t help - only way is to switch back to provider DNS resolution.
@Pepe or any other turris team member please have a look into that.


#19

“Doesn’t work” is too little information, as the problem doesn’t happen for us. I’d like to see verbose logs around the point when it started to fail (or at least any time it fails). The easiest way for you to enable them should be command

echo 'verbose(true)' | socat - /tmp/kresd/tty/"$(pgrep kresd)"

(confirmed by output > true) Then there should be very many kresd lines getting into your system log. Well, I’m not 100% sure the init collects those logs by default; this guide should be complete in case nothing appears.


#20

Hi vcunat,

Could you enlighten us with some guidance to implement the workaround (I don’t speak cz.nic and don’t want to screw up my TO).

I guess the file /etc/init.d/kresd should be edited.
The red marked original lines (339, 341, 387 and 388) should be deleted.
The green new lines (338, 339, 340, 342, 344 and 390) should be added.

And then? A restart of resolver? That’s it?