Turris OS 3.10 is out now!

Dear Turris users,

We just released new version of Turris OS! It contains plenty of updates and small fixes, but also some new features and cleanups. There was plenty of changes under the hood in Foris, but the end result for users is mostly just separate option to set date and time, but it will help us tremendously with maintaining and extending it. And develop new features like the ones we are announcing in this release.

We added experimental Web UI for Pakon, so you can now find out what were your devices up to easily in Foris. We also added possibility to backup your settings into our cloud and to move IO intensive application to external drive. So your containers or databases wouldn’t unnecessarily wear out your flash drive.

Hope you’ll enjoy the new features and as always, we welcome any feedback!


uhm… ok, Did the update. Activated the ext drive, but now netdata is giving me this error?
2018-05-10 13:36:25: netdata FATAL: Cannot cd to directory ‘/var/lib/netdata’ # : Invalid argument

2018-05-10 13:36:25: netdata INFO : Cleaning up database [0 hosts(s)]…
2018-05-10 13:36:25: netdata INFO : netdata exiting. Bye bye…

( edit , went in luci, looked at what was dis and enabled at startup, and netdata was disabled , working now )

Oh, and PAKON seems to find nothing… that lovely spinning thing just keeps turning :slight_smile:

best, DIKKE

After update to TurrisOS 3.10 OpenVPN plugin don’t show client configurations.
Is still generating but configurations is still working.
The files is in /etc/ssl/ca/openvpn

PS. I create issue on gitlab

I have automatic updated configured only after my approval, but Omnia doesn’t respect this and automatically installed update :frowning: Now I’m trying to administer router remotely but without success. VPN connection is created, but http access to foris doesn’t work and even ssh access to console doesn’t work.

This update broke my Foris at all. PLEASE DO NOT UPDATE for this version yet.

1 Like

would you please tell us more details? This doesn’t help us as we don’t have information what’s wrong.


Would you please send me output of these commands to tech.support@turris.cz?

ls -al /etc/ssl/ca/openvpn/
cat /etc/ssl/ca/openvpn/index.txt
cat /etc/ssl/ca/openvpn/notes.txt

Looking forward to hearing from you,

I have no further information. Before this update I had the latest production Turis Omnia firmware. I had disabled automatic updates through Foris interface - inspite of this I received email that my router need restart and after while second email about update information. I have immediately tried to remotely connect my router but without success. VPN connection is created, but web interface doesn’t work and command line access using ssh doesn’t work also. I’m not at home so I have no further information as I have no remote access to Omnia …

For Turris 1.0 without BTRFS there is an error in Foris when accessing the “Region and Time” section. The page is not displayed at all.

Report send to Tech Support already.

1 Like

// MOD: Log from /var/log/messages was deleted! It includes sensitive data.

Maybe i wll try to reinstall Foris as whole pkg, will it helps ?

VPN seems to working, i can connect from my mobile phone with DDNS on, but it says that “The currently installed ‘ddns-scripts’ package did not support all available settings.
Please update to the current version!”

BitTorrent client seems not working.

Adblock is wokring, Samba is wokring, RAID pool working, but with some errors, but its maybe the file system check is on, and i have RAID 1

/var/log/messages contains sensitive information. I’ll delete both of your logs.

This is not what I requested from you about Foris, which doesn’t show for you as you told us in Czech section.

I want from you to read the documentation - How to report bugs and send me output from opkg list-installed | grep foris
and diagnostics should be included as an attachment in your e-mail to tech.support@turris.cz.

I’m at home and I am able to access to omnia Foris localy. It seems to me that update disables routing among VPN and other zones.

I sent that email already with all info what i can get / is requested in “how to report bugs” guide.

Looks like the standard LXC container location has changed. With Turris OS 3.9 my /etc/lxc/lxc.conf had this content (was not changed by me):
lxc.lxcpath = /srv/lxc

After the update to 3.10 my LXC container was not found anymore, instead LuCI showed an (empty?) container with a generic / generated name.
To fix this, I did the following steps:

  • mount my mSATA drive to /lxc/srv in LuCI
  • log on to the Omnia with SSH
  • edit /etc/lxc/lxc.conf: set lxc.lxcpath = /lxc/srv
  • restart the lxc service (/etc/init.d/lxc-auto stop and /etc/init.d/lxc-auto start)

After that my container was back again.

To have the display in LuCI - Services - LXC Containers updated, I needed to restart of Omnia.

raised a ticket with tech support, in 3.10 kresd is returning that hosts which only have a AAAA DNS record don’t have a record at all. This was working fine before 3.10. for example on the Turris command line:

dig aaaa aaaa.v6ns.test-ipv6.com

returns that aaaa.v6ns.test-ipv6.com has no AAAA record, although it does. I have kresd set up with forwarding off and ipv6 enabled.

this causes the test-ipv6.com ipv6 test site to indicate that the DNS server I’m using (kresd) can’t handle ipv6 only sites.


1 Like

I send you an email
Thans for your reply

I have the same error message, specifically:

Software update required
The currently installed ‘ddns-scripts’ package did not support all available settings. Please update to the current version!

The installed version is (opkg list-installed | grep ddns): 2.7.3-1, the latest version is 2.7.7-5

I’ve got the same issue. Mailed support, waiting for answer.

Another problem is the new “Storage” function.
I know that is supposed to format the internal eSATA drive and move all the stuff that is IO intensive to it.
However, when I try to format the disk I get the following error:

2018-05-11 00:05:22 err foris-controller[7572]: busybox: applet not found
2018-05-11 00:05:23 err foris-controller[7572]: umount: can’t unmount /dev/sda: Invalid argument
2018-05-11 00:05:23 err foris-controller[7572]: expr: warning: ‘^.*[a-z]$’: using ‘^’ as the first character
2018-05-11 00:05:23 err foris-controller[7572]: of a basic regular expression is not portable; it is ignored

And under “Notification” in the WeGui I get:
_(Formatting drive failed, try unpluging it and repluging it in again.)

The disk however IS unmounted, but not formated.

The disk already have a partition on it, but I suppose that it shouldn’t make a difference.

Keep up the good work!


ok, this is very weird…

dig aaaa aaaa.v6ns.test-ipv6.com

fails to return the AAAA right after the router reboots, but if I stop kresd and start it again, then it returns the AAAA correctly.