Turris OS 3.10.4 is in RC!


#1

Dear Turris users,

we just released Turris OS 3.10.4 into RC phase. It contains mainly bugfixes and few updates. Full release notes are as follows:

  • owfs, ustream-ssl, nextcloud, knot-resolver, kernel, nginx update
  • haas-proxy: update, more logging options and limit for resources
  • storage: small fixes and enhancements
  • transmission: update and option for custom webui
  • pakon: fix new device notification and use IDS by default

As always, if you encounter any issues during testing, let us know.


#2

busybox stays outdated then and the Socket statics issue is not fixed either?


#3

Update from 2018/08/09 12:43:37
Updater selhal: inconsistent: Requested package netdata that is not available

Moreover, option “Update approvals”: “Update approval needed” is set in Foris - Updater!

What does it mean?


#4

It means that netdata is missing, thanks, we will look into that.

Approval is asked only if update is installable, so it failed for you even before you could approve it.


#5

Thanks for explanation.


#6

We’ve released another RC. For now just for Turris Omnia.

Changelog:
hostapd: backport fix for CVE-2018-14526
ca-certificates: update to the version 2018/04/09
foris-storage-plugin: minor polishing

Netdata is still not there, it doesn’t compile, but we’re working on it.


#7

has this fixed the problem with update not being able to resolve your repo host for performing updates?

I just re-imaged my router from scratch, and this problem still occurs as described below.


#8

I checked the thread and would like to clarify few things. There is no such problem with updater not being able to resolve repo.turris.cz. There are people who have broken DNS configuration and should try to fix it by usual means - like disable/enable forwarding and maybe try to contact support if it doesn’t help.


#9

I guess this all depends on the interpretation of what a problem is. :grinning::grinning:

As an example. I reflash the router, make zero changes to DNS configuration and the problem exists.

Another case, I change default settings for DNS and disable forwarding, the problem exists.

So go figure what I did wrong with the DNS configuration?!?!

Another note, with these DNS problems occuring, the the 10 step wizard for initial router configuration also fails. Probably not the most optimal end user experience.

When I bought the router from the original campaign, this worked.

Something is definitely not working as expected. I’ll be happy to provide logs if required for further diagnosis.


#10

One more update to RC, latest kernel added.


#11

Try thread about DNS problems diagnostics or contact our support to help you figure out what changed in your network and why is it failing.


#12

Aren’t you connected over PPPoE (xDSL) with Turris being the PPPoE “controller”? I had this problem with the older firmwares, that setting up the connection after boot took a longer time, and the updater gave up before the connection went up.


#13

I have fiber and not xDSL … my Omnia router is connected via ethernet cable to the router provided by the ISP (which runs over fiber)