Turris OS 3.10.3 released

release

#1

Dear Turris users,

we just released Turris OS 3.10.3. Most of the stuff is really minor, the main reason for release is updated Unbound that includes workaround for some broken Microsoft DNS servers. So it mainly affects Turris 1.X users but there are few minor fixes for everybody. Full release notes are as follows:

  • nextcloud: update
  • pakon, storage: minor fixes
  • kernel, unbound: update and minor fixes

As always, if you encounter any issues, let us know.


Turris OS 3.10.3 vydán
#2

This to be expected?

INFO:Running post-install and post-rm scripts
Output from unbound.postinst:
+ [ -n  ]
+ /usr/share/unbound/postinst
+ /etc/init.d/resolver restart
Command failed: Not found
[1530092262] unbound-control[25534:0] fatal error: could not send: Connection reset by peer
+ /etc/init.d/resolver restart
[1530092283] unbound-control[25809:0] fatal error: could not recv: Connection reset by peer

#3

after reboot

err foris-controller[2525]: busybox: applet not found


#4

#5

The new version works great for me.

These errors are finally gone.

[46663.372015] sit: non-ECT from remote ip with TOS=0x2
[46673.611261] sit: non-ECT from remote ip with TOS=0x2

regards,
nikolay


#6

After update on this version, I have issue with DNS resolve - I have Turris 1.1. Not sure, what is wrong, but on Foris, there is this message:

Updater failed:

unreachable: https://repo.turris.cz/turris/lists/base.lua: Couldn’t resolve host ‘repo.turris.cz’

Pcs behind Turris can not resolve DNS, I had to setup on them manually DNS servers 8.8.8.8 to be able to work normally.

Any suggestion, how to fix the issue?


#7

Process “ucollect” is running, I can see in Foris, that data are send:
Sending of uCollect data Online (status updated 93 seconds ago)

But file /var/run/ucollect.pid does not exist, even if it is used in /etc/init.d/ucollect.


#8

My omnia just rebooted because of a crash in wifi driver. Here is the log:

Jun 28 22:57:59 turris kernel: [90642.873139] ath10k_pci 0000:02:00.0: firmware crashed! (uuid 8a784fc1-71fb-430b-a883-9e0249022f09)
Jun 28 22:57:59 turris kernel: [90642.882147] ath10k_pci 0000:02:00.0: qca988x hw2.0 target 0x4100016c chip_id 0x043202ff sub 0000:0000
Jun 28 22:57:59 turris kernel: [90642.891412] ath10k_pci 0000:02:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 1
Jun 28 22:57:59 turris kernel: [90642.901034] ath10k_pci 0000:02:00.0: firmware ver 10.2.4-1.0-00029 api 5 features no-p2p,raw-mode,mfp,allows-mesh-bcast crc32 88595bb8
Jun 28 22:57:59 turris kernel: [90642.913179] ath10k_pci 0000:02:00.0: board_file api 1 bmi_id N/A crc32 bebc7c08
Jun 28 22:57:59 turris kernel: [90642.920514] ath10k_pci 0000:02:00.0: htt-ver 2.1 wmi-op 5 htt-op 2 cal otp max-sta 128 raw 0 hwcrypto 1
Jun 28 22:57:59 turris kernel: [90642.941966] ath10k_pci 0000:02:00.0: failed to get memcpy hi address for firmware address 4: -16
Jun 28 22:57:59 turris kernel: [90642.950776] ath10k_pci 0000:02:00.0: failed to read firmware dump area: -16
Jun 28 22:57:59 turris kernel: [90642.957757] ath10k_pci 0000:02:00.0: Copy Engine register dump:
Jun 28 22:57:59 turris kernel: [90642.963699] ath10k_pci 0000:02:00.0: [00]: 0x00057400  15  15   3   3
Jun 28 22:57:59 turris kernel: [90642.970164] ath10k_pci 0000:02:00.0: [01]: 0x00057800  20  20 119 120
Jun 28 22:57:59 turris kernel: [90642.976630] ath10k_pci 0000:02:00.0: [02]: 0x00057c00  36  35  34  35
Jun 28 22:57:59 turris kernel: [90642.983090] ath10k_pci 0000:02:00.0: [03]: 0x00058000  17  17  19  17
Jun 28 22:57:59 turris kernel: [90642.989553] ath10k_pci 0000:02:00.0: [04]: 0x00058400 4600 4553  21 237
Jun 28 22:57:59 turris kernel: [90642.996191] ath10k_pci 0000:02:00.0: [05]: 0x00058800  31  31  94  95
Jun 28 22:57:59 turris kernel: [90643.002650] ath10k_pci 0000:02:00.0: [06]: 0x00058c00  25  25  25  25
Jun 28 22:57:59 turris kernel: [90643.009113] ath10k_pci 0000:02:00.0: [07]: 0x00059000   1   0   1   0
Jun 28 22:57:59 turris kernel: [90643.045188] ath10k_pci 0000:02:00.0: failed to read hi_board_data address: -28
Jun 28 22:57:59 turris kernel: [90643.125864] ieee80211 phy0: Hardware restart was requested
Jun 28 22:57:59 turris kernel: [90643.217423] ath10k_pci 0000:02:00.0: failed to poke copy engine: -16
Jun 28 22:57:59 turris kernel: [90643.307393] ath10k_pci 0000:02:00.0: failed to poke copy engine: -16
Jun 28 22:58:00 turris kernel: [90643.397403] ath10k_pci 0000:02:00.0: failed to poke copy engine: -16

#10

Socket statics are gone missing.

ss -tulpn

-ash: ss: not found

Is it related to:

err foris-controller[2525]: busybox: applet not found


#11

Same for me since since 3.10.1: Router reboot loop after latest update (3.10.1)


#12

it happened only once so far for me.


#13

Unfortunately this happens to me every single time. I cannot bring the wifi-up, if I do the router always reboots after a period of time between a few seconds and a minute. The error is exactly the same as you posted. Tried 3.10.1, 3.10.2 and now 3.10.3 and they all trigger the same error. Any version older than that works flawlessly.


#14

A post was merged into an existing topic: Turris OS 3.10.3 vydán


#15

Can you update the wireguard package?
Somebody said it will be a goal for 3.10.
Some of us don’t really care about Foris,Pakon,Nextcloud and all other stuff.


#16

New information about NUT package.

Can not perform shutdowns Ups. Please help.

Details of our installation are:
OS: Turris Omnia (TO) 3.10.3
NUT version: 2.7.4-5
Installation method: from package
UPS device: EATON UPS 5SC 500i , 230V, 350W, 500VA, USB bought in jun 2018

If you connect to TO UPS via USB, the /dev/hidraw0 device will be created.
No any programs from NUT package is not running.

When I run:
/lib/nut/usbhid-ups -a qnapups
Network UPS Tools - Generic HID driver 0.41 (3.10-76-gd2caa7d) USB communication driver 0.33
kill: No such process
Using subdriver: MGE HID 1.39

device /dev /hidraw0 is deleted.

Now I’m ordering to shut down UPS:

/lib/nut/usbhid-ups -a qnapups -k
Network UPS Tools - Generic HID driver 0.41 (3.10-76-gd2caa7d) USB communication driver 0.33 Can not claim USB device [0463: ffff]: No such file or directory

Please do you know how to change the status?

Well thank you.


#17

After update to 3.10.3 pakon stopped to work.
I have tried to tips already available in forum such as py script to create database,reinstall and restarts,but nothing helped.
This is what I get in console:

root@turris:~# pakon-show
Traceback (most recent call last):
  File "/usr/bin/pakon-show", line 133, in 
    data=json.loads(response)
  File "/usr/lib/python3.5/json/__init__.py", line 319, in loads
    return _default_decoder.decode(s)
  File "/usr/lib/python3.5/json/decoder.py", line 339, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/lib/python3.5/json/decoder.py", line 357, in raw_decode
    raise JSONDecodeError("Expecting value", s, err.value) from None
json.decoder.JSONDecodeError: Expecting value: line 1 column 1 (char 0)
root@turris:~# 

Please help. Thank you


#18

Hello,

Is there any possibility that you deleted /srv/pakon or maybe did you deleted some records in the database?

Would you please try this command again w/o reinstalling it?

/usr/libexec/pakon-light/create_db.py

and let me know if it works for you?


#19

It did not help. I have tried it once more time.


#20

No crash yet but I have a lot of these in the logs:

[293100.962181] ath10k_pci 0000:02:00.0: SWBA overrun on vdev 0, skipped old beacon
[293101.064573] ath10k_pci 0000:02:00.0: SWBA overrun on vdev 0, skipped old beacon
[293101.166971] ath10k_pci 0000:02:00.0: SWBA overrun on vdev 0, skipped old beacon
[293101.269361] ath10k_pci 0000:02:00.0: SWBA overrun on vdev 0, skipped old beacon

#21

Hi,
one question to the release info: Why is it in Community Office section? The RC post was in Software and the czech-notes is in Software[CZ]. Everytime i clicked a way the banner and then want so search for the notes to read again, i am looking into Software (as it is software…).

Anyway, the update was smooth for me and Storage Page bug was fixed for me.