Turris OS 3.10.1 released!

release

#1

Dear Turris users,

We just released bugfix release 3.10.1. Nothing big, mostly just few fixes. We are still aware of some issues with odhcp6c an ucollect that we are trying to address but we decided not to delay the fixes we ready have.

Side-note regarding IPv6 workaround, we know those are not the best way how to get IPv6 - the best option would be for all ISP to stop beating a dead horse and embrace the future, but unfortunately, plenty of our users still have to deal with ISPs stuck in the past and thus depend on those.

Full release notes are as follows:

  • foris: support 6in4 and 6to4
  • foris: ability to set protocol in VPN
  • kernel: update and UAS driver
  • foris-pakon: bug and compatibility fixes
  • odhcp6c: fix after update
  • netmetr: fix synchronization code

As always, if you encounter any new issue, let us know.


Turris OS 3.10.1 vydán!
#3

Something hangs in postinstall. Last line displayed:
/usr/lib/opkg/info//luci-i18n-samba-de.postinst: .: line 4: can’t open ‘/etc/uci-defaults/luci-i18n-samba-de’


#4

Do I need to do something? Still on 3.10

'##### Update notifications #####
Updater selhal:

corruption: Signature validation failed

• Installed version 7.60.0-1 of package libcurl
• Installed version 60.2.4-2 of package updater-ng


#5

After a reboot, additional problems:
Detected existing journal. Trying to recover it.
line not found
line not found
line not found
line not found
DIE:
[string “backend”]:1172: [string “backend”]:1163: Failed to lock the lock file //var/lock/opkg.lock: Resource temporarily unavailable


#6

Cannot reach administration page from internet, only from local network or via VPN.


#7

The updater hangs in postinstall. No more logs after:
“info updater[14066]: transaction.lua:199 (fun): Running post-install and post-rm scripts”

The process pkgupdate still running after two hours. Should I reboot the TO or wait?


#8

I’d suggest waiting - otherwise you’ll probably end up like me :confused:


#9

Detected existing journal. Trying to recover it.

You have running updater in the background and when you run it manually you end up with running another instance of the updater, which failed. I suggest you wait.


#10

Just disconnect from SSH and connect back. Anyway, It would be great if you can send us diagnostics, which you can generate in Foris.


#11

I´ve just sent the diagnostics to tech.support. Nothing changes if I connect/disconnect from ssh. I didn’t run updater from command line. It is an automatic installation


#12

Hello,
Would you please go to Updater tab and click on Save changes? It will run the Updater in the background.


#13

Should I do something special for the UAS driver to be used? I have a USB 3.0 NAS box connected, by specification it should support UASP, but in lsusb -t I still see Driver=usb-storage.

I’m on 3.10.1, tried rebooting the router several times.

If it helps, the NAS box is set up to be used as /srv through the Storage Foris plugin.


#14

Can you check if you have installed kernel module kmod-usb-storage-uas? It is included also in NAS user list.

Anyway, it’s also possible that USB-SATA controller doesn’t support UASP. You can check with lsusb -v if there is bInterfaceProtocol 98.


#15

opkg info kmod-usb-storage-uas

Package: kmod-usb-storage-uas
Version: 4.4.134+0-1-8f7f4132dc88fb7034ce9648e5961be5-0
Depends: kernel (= 4.4.134-1-8f7f4132dc88fb7034ce9648e5961be5-0), kmod-usb-storage
Status: install user installed
Architecture: mvebu
Installed-Time: 1528369434

The device does have interface protocol 98: https://gist.github.com/peci1/be26ffd64ff420ef9e5e559aed3d371f


#16

@miska: by those odhcp6c issues you mean Turris OS 3.10: DHCPv6 loses address after 1 hour or (also) something else?


#17

Yes, this thread and also this one:

Anyway, @paja is looking for the solution.


#18

This was something else I think, the other issue is still being worked on.


#19

Can you please send us the output from

lsmod | grep uas

and also dmesg?


#20
$ lsmod | grep uas
uas                    11367  0

dmesg: https://gist.github.com/peci1/ea90896bef9ae20e32a7f700eed94b2d

However, probably because I also use the NAS for storing logs, /var/log/messages does not contain information about the USB drive connection, since it happens before syslog-ng can be fully started.


#21

But it contains loading of uas driver surprisingly. Can you try
ln -s ../modules.d/usb-storage-uas /etc/modules-boot.d/
and then reboot?

Also dmesg should contain information even before your syslog started.