Turris omnia won't let me get into forris

Hello, this is my first time trying to use the turris omnia. Everything works fine until I update the device, first time updating the device I waited nearly an hour or so and still couldn’t connect to forris.

So naturally I went to forums for help, no one has stated an average wait time for updates. So I tried factory reset and did it allover again, this time I didn’t try to install any plugins with update. This still resulted in a long long wait. About the only thing it did was make pci2 light up in it’s unusable state.

During this state after a long wait connecting to connection gets refused.

The packages I tried to install was LTE support, open VPN, and tor. I also selected to remove the non English languages.

The only thing I’ve modified with the router is installing a quectel EP06A and a T mobile data sim. I plan on using LTE as my primary ISP as soon as I get it working.

maybe a nOOB remark, but why not try to boot the baby in full standard config? So without all the whistles and bells?
i assume you are on the 5.x OS?
And if you have it running in a standard mode, try one by one, and see what ad on gives trouble?

The router is on 4.x I believe, and I tried without installing any plugins as well to see if that’s what was hanging up the router. It’s brand new.

try to install the 5.2.3 OS?