Turris Omnia with v3.11.5 is very unstable

I am experiencing daily (at least) 5GHz wifi drops and/or spontaneous router reboots. And when it is working, both wireless and wired clients get disconnected and have to reconnect very frequently: guess what it does to games?!.

I am using PPPoE (50M/10M), setup with four wired tagged VLAN’s and on a LAN port with a dumb switch connected, and a half a dozen AP’s spread across lan and _turris_guest. At any given moment of time there are at least five devices using the router.

Are there any hints on how to stabilize the thing?

did you take a look at cat /sys/kernel/debug/crashlog after such reboot, see if there is a crashlog?


about the Wlan connectivity drops - there are some factors to consider - the config for the AP’s a/o potentially environment (signal pollution , incl. USB3 interference if any attached to the router)

Also depending on the country the router to operate in 5GHz will do some DFS scanning in accordance with the country’s legislation, that if the channel is set to auto. During such scans the AP is not accessible to clients. I am not sure about how frequent such DFS scans are executed.

Did you try to:

  • set different frequencies other than auto?
  • different channel width 20/40/80 Mhz?
  • 802.11w on | off
  • 802.11r on | off

Yes, I am aware of all of those (except for the crashlog thing that I will keep in mind next time) and tried them. No USB devices attached, no auto/DFS channels, running in an env with ambient temperature of 18C, no lxc and stuff, etc. Just a pure router. The point here is that a r7800 with OpenWRT in the same location, identically configured, and under the same exact load is rock solid. A Turris Omnia with v3.11.5 cannot even survive for 12 hours: I have around a half a dozen devices active at any point of time with over 50 in total. And if it does survive longer, then wired devices start loosing connections every several seconds and I need to reboot the router myself.
My guess is that a TO unit and/or v3.11.5 firmware is/are just getting tired too quickly, while an r7800 keeps chugging along without any hiccups. Maybe it is working for others with less load, but not in my case.
Now I just need to see if the unit is a lemon…

all pertaining network components - netifd | hostapd | wpad - are known as outdated/buggy in TOS3.x, probably also the drivers for the Wlan cards. This will change with the upcoming TOS4.x|5.x.

If still happens then the node in question may suffer from some hardware issue instead.

So far, I am not impressed with OpenWRT 19.07 on a Turris Omnia either: 5GHz goes down hourly…

On a positive note no spontaneous reboots you reported initially?

about the 5Ghz it may bear down to the candela driver not being utilized in the TO

there are issue reported with a high number of clients
http://lists.infradead.org/pipermail/openwrt-devel/2019-July/017937.html


though the r7800 features the same Wlan chipset but uses the candela driver instead if I am not mistaken? and suffers it in its own right

http://lists.infradead.org/pipermail/openwrt-devel/2019-June/017781.html

Well, 3.11.5 solved a lot of strange anomalies here, no clue why. Including the wonky 5G ?
And my TO is standard. The only thing i keep finding dodgy is the pakon part, the rest is all working ( again ).

i knew i should have written this… as since 24 hours the whole 5 G is down. The only thing i changed was switching the 5 G channel from 52 to 100.

hmm,ok. apperantly the ( current ) 5G problem seems to be related to the channel/auto selection? Since now i have set the channel manual ( 48 ) and 5G is up and running. Channel 52 means 5G is disabled. Interesting.