Turris Omnia - WiFi modules disappeared and Factory Reset not possible


since a reboot several days ago the Omnia is not providig WiFi anymore (worked for nearly two years). LuCi does not show Wireless options anymore and the basic config says under wifi: “We were unable to detect any wireless cards in your router.” - it offers a reset, I did that several times, but nothing happened.

Ifconfig does not list any wireless modules anymore.

I tried a factory reset (pressing reset button until leds power, 0 and 1 were showing), but the next strange thing happened: the router went back to the settings it already had (after doing a light show with the leds), so nothing changed.

I also rebooted the router several times, switched it off several minutes from power supply, nothing changed.

I’m a bit helpless now and would like to understand what I’m doing wrong or where I could look.

Thanks a lot for any kind of help.


you could try flashing a medkit

@hadc that’s not a solution.

Would you please send diagnostics, which you can generate in Foris to tech.support@turris.cz? From the diagnostics, we should know more.

Similar problem on my turris omnia. No WiFi card installed - when it asks for the it during the installation (step 4?) it ends up with a reset too. Tried to reinstall latest os from USB-Stick - no change.