Turris breaking down more and more (Updater not working)

in the last couple days i noticed that my Turris Omnia is breaking down more and more without me doing anything.
It started with an LXC Container failing.

Today after my samba share broke down too and i could not connect anymore i started to investigate.

I checked the web gui and besides it showing that the updater was still running and it is slow in general it looked ok.

So i tried a simple restart.

  • restart from GUI did nothing.
  • restart from CLI did nothing

so i ended up cutting power.

after starting up, i could visit the web gui again and the update process was not running anymore, but the LuCI Gui failed with error 500.

connecting to the shell again i could not execute a single command because of some error after every command. (sorry did not write down the exact error. but it did not sound good.)

So i restarted again.
After that it seemed to behave better. Shell commands work and the web gui and LuCI work again.
So i tried an update from the shell since it showed it stuck in the web gui.
it failed with some journal error, so i found this thread

which suggested deleting the journal. that helped a bit since now the updater at least does something but now fails with the following error at the end.

pkgupdate -e DBG
/usr/share/updater/unpacked//updater-peijLj /usr/share/updater/unpacked//updater-BIliOo /usr/share/updater/unpacked//updater-CCPmka /usr/share/updater/unpacked//updater-eiPKpn /usr/share/updater/unpacked//updater-jEKcCF /usr/share/updater/unpacked//updater-BnOLho /usr/share/updater/unpacked//updater-eAoCMi /usr/share/updater/unpacked//updater-EJGJbf /usr/share/updater/unpacked//updater-HEFEgm /usr/share/updater/unpacked//updater-ogNAgJ /usr/share/updater/unpacked//updater-IBBOeA /usr/share/updater/unpacked//updater-MaDjPA /usr/share/updater/unpacked//updater-HOkDlg /usr/share/updater/unpacked//updater-EmLbgn /usr/share/updater/unpacked//updater-pclGap /usr/share/updater/unpacked//updater-bKFgDN /usr/share/updater/unpacked//updater-MMfAPO /usr/share/updater/unpacked//updater-kcGBEN /usr/share/updater/unpacked//updater-NhPlmj /usr/share/updater/unpacked//updater-hmEedK /usr/share/updater/unpacked//updater-NgBFHj /usr/share/updater/unpacked//updater-BMkkJM /usr/share/updater/unpacked//updater-cGIcDK /usr/share/updater/unpacked//updater-LGKjDI
/usr/share/updater/unpacked//updater-OggACn /usr/share/updater/unpacked//updater-NjJFac /usr/share/updater/unpacked//updater-lKjOkn /usr/share/updater/unpacked//updater-jfEaoH /usr/share/updater/unpacked//updater-EKMAph /usr/share/updater/unpacked//updater-oAOcIe /usr/share/updater/unpacked//updater-HHlCFi /usr/share/updater/unpacked//updater-adNfIj /usr/share/updater/unpacked//updater-mmcGBf /usr/share/updater/unpacked//updater-ojIopD /usr/share/updater/unpacked//updater-GKGAnO /usr/share/updater/unpacked//updater-HHoiBl /usr/share/updater/unpacked//updater-KAkGnP /usr/share/updater/unpacked//updater-dCMiHN /usr/share/updater/unpacked//updater-pNiDLg /usr/share/updater/unpacked//updater-NkGIem
DEBUG:src/lib/journal.c:286 (lua_finish):Closing journal
line not found
line not found
line not found
line not found
line not found
line not found
DIE:src/pkgupdate/main.c:300 (main):
[string "transaction"]:334: [string "backend"]:897: /usr/lib/opkg/info//kmod-ledtrig-netfilter.prerm: I/O error

Since it shows also quite a bit I/O warnings before that, i am already worried that it might have some hardware defect.

any idea what i could do or what might be the issue with my device? Its my NAS that is mostly running without me doing anything with it for a long time except writing files and using 2 or 3 lxc containers with software in it.

Hopefully, you were running your LXC from some external storage and not the main storage area. Either an external USB or an SSD attached to the internal slot.

LXC containers are known for destroying the internal flash.

I would search elsewhere on the forum how to determine the state of our internal flash in any case.

1 Like

uhh. i fear they where running from the internal memory…
any chance for replacements in that case?

To install the system on an external (internal) disk


1 Like