Turris 1.x - python-netifaces a onkyo

Zdravím,
mometnálně řeším problém s instalací python scriptů pro ovládání AV receiveru. Je na to pythoní “knihovna” https://github.com/miracle2k/onkyo-eiscp ale nedaří se mi to zprovoznit.
Po nainstalování python setup tools a nainstalování tohoto balíčku pomocí easy_install se mi po spuštění např “onkyo -discover” dostává chyby: pkg_resources.DistributionNotFound: The ‘netifaces’ distribution was not found and is required by onkyo-eiscp

Balíčky netdiscover a netifaces jsem doinstaloval, ale problém vidím v tom, že jsou to pouze python3-netifaces atd…Tj, nejsou dostupné pro python2, který se v základu spouští (ale možná se pletu, v tomhle se úplně nevyznám). Python2 netifaces balíček jsem pro powerPC platformu na které je turris nikde nenašel.

Dokáže mi někdo poradit, jak bych měl co nainstalovat, aby to běželo?

Díky!

Edit: a ještě při instalacích, např při pokusu o instalaci tohoto i onkyo-eisc mi to hlásí tento error:
error: command ‘ccache_cc’ failed with exit status 1

Edit2: ještě jsem zkoušel zprovoznit ovládání přes home-assistant balíček, ale tam po přidání configu a onkyo, který je uvedený přímo na webu mám v logu opět error:
17-12-05 00:59:06 homeassistant.loader: Unable to find component media_player.onkyo

Ahoj,
zkoušel jsem homeassistant zprovoznit přimo na turrisu, ale narazil jsem na to, že tam některé balíčky chybí v opkg. A při pokusu o instalaci přes pip3 se jej pip3 pokoušelo zkompilovat, což se mu nepovedlo. Nakonec jsem nahodil debian v lxc kontejneru a tam už instalace a HA funguje.

Ta chyba s ccache_cc by mohla napovídat, že v tomto případě se taky interně pokouší o kompilaci.

díky za radu, také zjišťuji, že spousta balíčků není a kompilace nejede, protože chybí gcc… sice už jsem asi našel návod, jak si ho pro turris zkompilovat, ale to bylo nějaké komplikované.

Každopádně první fáze vyřešena - stačilo natvrdo nainstalovat onkyo-eisc přes python3, pomocí “python3 -m easy_install onkyo-eisc”. Předchozí instalace se zasekávala právě na kompilaci netifaces pro python2, pro python3 je dostupná, takže to úspěšně dojelo až do konce…

Home assistant jsem prozatím nezprovoznil, ale tam to bude asi podobný problém, právě kvůli chybějícím balíčkům. Uvidíme, co z toho se podaří rozjet, ale z principu to nepořebuji stačí mi, když dostanu ven nějaké api pro onkyo (což si už klidně napíšu a pustím na nějakém zjednodušeném webserveru) a přes IFTTT to nabinduji na Google home :)) No, uvidíme, jak to pojede…