Ttransmission 404: Not Found

Hello people,
i have problem to run transmission torrent client.
Web interface of client has this eror message:
http://192.168.10.1:9091/transmission/web/

404: Not Found

Couldn’t find Transmission’s web interface files!

Users: to tell Transmission where to look, set the TRANSMISSION_WEB_HOME environment variable to the folder where the web interface’s index.html is located.

Package Builders: to set a custom default at compile time, #define PACKAGE_DATA_DIR in libtransmission/platform.c or tweak tr_getClutchDir () by hand.

But i can´t find what is wrong. In logs is nothing suspicious.
And my config files looks normaly like every time.

/etc/config/transmission

config transmission
option mem_percentage '50’
option nice '10’
option ionice_flags '-c 3’
option alt_speed_enabled 'false’
option bind_address_ipv4 '0.0.0.0’
option bind_address_ipv6 '::'
option blocklist_enabled 'false’
option cache_size_mb '2’
option dht_enabled 'true’
option download_queue_enabled 'true’
option download_queue_size '4’
option encryption '1’
option idle_seeding_limit_enabled 'false’
option incomplete_dir_enabled 'false’
option lazy_bitfield_enabled 'true’
option lpd_enabled 'false’
option peer_limit_global '240’
option peer_limit_per_torrent '60’
option peer_port_random_on_start 'false’
option peer_socket_tos 'default’
option pex_enabled 'true’
option port_forwarding_enabled 'true’
option queue_stalled_enabled 'true’
option queue_stalled_minutes '30’
option ratio_limit '2.0000’
option rpc_bind_address '0.0.0.0’
option rpc_enabled 'true’
option rpc_port '9091’
option rpc_url '/transmission/'
option rpc_whitelist_enabled 'true’
option scrape_paused_torrents_enabled 'true’
option script_torrent_done_enabled 'false’
option seed_queue_enabled 'false’
option speed_limit_down_enabled 'false’
option speed_limit_up_enabled 'false’
option start_added_torrents 'true’
option trash_original_torrent_files 'false’
option umask '18’
option upload_slots_per_torrent '14’
option utp_enabled 'true’
option scrape_paused_torrents 'true’
option watch_dir_enabled 'false’
option enabled '1’
option download_dir '/mnt/Gigantus/'
option preallocation '0’
option rename_partial_files 'false’
option message_level '2’
option peer_port '51000’
option rpc_whitelist '127.0.0.1,192.168.10.*'
option rpc_authentication_required 'true’
option ratio_limit_enabled 'true’
option rpc_username 'torrent’
option rpc_password 'torrent’
option config_dir ‘/mnt/SamsungFlash/transmission/’

config_dir ‘/mnt/SamsungFlash/transmission/’ seems to be ok too.

Reinstall transmission didn´t help. After factory reset i have same issue.
Does anyone have any idea how to fix it?

You do not have instaled transmission-web package.

Thanks, you are right …
opkg install transmission-web solved my problem :smiley:

I am unable to install the package… Was it renamed?

root@turris:~# opkg install transmission-web
Unknown package 'transmission-web'.
Collected errors:
* opkg_install_cmd: Cannot install package transmission-web.
1 Like

After last upgrade of Turis OS i have same issue.
Updated can´t finish and spam me with error message:
Updater failed:
inconsistent: Requested package transmission-web that is not available.
I hope that developers will resolve it soon. Or next update.

It failed to build when preparing 3.8, as reported by the team in the 3.8 release thread in the forums. Should be back for 3.8.1.

1 Like

is this still missing in 3.9? I am getting the same error…

Hi,
I’ve just tried it on 3.9 and I can install transmision-web (but before it you need to run opkg update)

root@turris:~# opkg install transmission-web
Installing transmission-web (2.92-3) to root…
Downloading https://repo.turris.cz/omnia-rc/packages//turrispackages/transmission-web_2.92-3_mvebu.ipk
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 237k 100 237k 0 0 237k 0 0:00:01 --:–:-- 0:00:01 3601k
Configuring transmission-web.

1 Like

Thanks :wink: That was the problem.